Visit Our UNIX and Linux User Community


redhat 6.2 : Apache + PHP4


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers redhat 6.2 : Apache + PHP4
# 1  
Old 08-30-2001
redhat 6.2 : Apache + PHP4

Hello,
how are you all , I am having a hard time here

I've got my Linux Redhat 6.2 server , with pre-instalation of redhat.
anyway , I installed mysql (not rpm) and its working very well, but I faced lot of trouple with PHP4.

Apache 1.1.12 was installed through rpm package and I updated it to 1.1.14 today, and I installed ( rpm package) PHP3.0.18 .

I want to install PHP4.0.4pl1 , it's avalable in redhat.com, I tried to download it and run the installation but it failed, it keeps asking for 2 files which are ( libc.so.6 And libresolv.so.2 -GLIBC 2.2- as dependencies). I upgrade the glibc to 2.1.x before that and the those files are on my system but it still asking for them , anyway I failed to upgrade to ( glibc 2.2 which resides on version 7.0 of redhat at ftp.redhat.com) .

I looked at the files at ftp.redhat.com and I couldn't find a GLIBC 2.2 in redhat 6.2 folder , the max version was 2.1 ,, there is GLIBC 2.2 but it's in redhat 7.0 folder , I've tried to install it ! but it also failed.

How in earth could I install PHP4.0.4 (or later) at redhat through rpm ?

---Another thing I did. ( If you think whats below is better, forget what I wrote above there)
Actully I installed PHP4.0.6 (latest stable version ) on my box yesterday, but with no ( --with-apache NOR --with-apx ) because when I tried to use : --with-apache , and I specified the directory ( /etc/httpd ) which is in the access.conf file , make command failed : wrong path to apache, can't find apache.h ( as I think). --with-apx , I failed to find the directory, It's not there.
I compiled it without two options and It goes fine ( with warning about the CGI ) anyway , I added :
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
to access.conf file and I restrated Apache , but it doesn't work !

So now I couldn't have PHP4.x.x installed at all, and the main problem is : my code uses some functions on PHP which require PHP > 4 . in the meantime situation I can't run my code .
Smilie
Sencerely yours.

Last edited by t_zone; 08-30-2001 at 07:16 PM..
# 2  
Old 09-02-2001
redhat 6.2: apache+php4

redhat 6.2 packaged with php3. so i think if you just want to run apache+php4, and don't want to be meshed up with setting some rpm, and some are not, why don't you upgrade to redhat 7.0 or 7.1. it include php4 engine 'off the shelf'.

i currently am running redhat 7.0 and without problem running php4 script 'off the shelf'. if you're maintaining php3 files, you still can run it, but it's better to change extension '.php3' to 'php' only.

qodoc
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #687
Difficulty: Medium
In comparison testing of reverse Polish notation with algebraic notation, reverse Polish has been found to lead to slower calculations.
True or False?

4 More Discussions You Might Find Interesting

1. Red Hat

Redhat Apache

How is it possible to tied a IP address to folder in apache, so when someone put the ip in there browser they land in that folder? (3 Replies)
Discussion started by: da2013
3 Replies

2. Red Hat

How to start the right instance of Apache on RedHat server

Hi, I have 2 apache instance on my machine (RedHat), and i need to start the "apache2" after any reboot but could not find the way ( searching into "httpd.conf" ), so i'am starting "apache2" manually. After a reboot, none of them starts and when i when doing : httpd -k start, i got "apache"... (14 Replies)
Discussion started by: mehdi1973
14 Replies

3. UNIX for Advanced & Expert Users

Where to set the right "Apache" to run after reboot on a RedHat 5 machine ?!

Hi, I'am working on a RedHat server (V5) and having on it 2 Apache instances, but after each reboot i have the wrong one starting so that i have to stop it doing "httpd -k stop" and than launch the right one doing "/etc/init.d/httpd -k start". For more Details, you may see the link i inserted... (4 Replies)
Discussion started by: mehdi1973
4 Replies

4. Red Hat

Installing PHP4 - REHL 5

Hi All, Is there anyone facing a problem installing PHP 4 at Red hat Enterprise 5? I paid for the red hat update subscription and when i look at the website it seems PHP4 is only for Red Hat enterprise 4. My web server only can use PHP 4 and i cant use PHP 5. Am i going to have an issue... (0 Replies)
Discussion started by: c00kie88
0 Replies

Featured Tech Videos