Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers echo
# 1  
Old 08-03-2012

I'm working with ksh.
I was working with the echo command

That is
echo "Today is $date"

which would show for example
Toady is 7/12/12
which was fine

however, know I only recieve the first part of the echo without the date.
Today is

Could I have edited the echo function?

Thanks JD
# 2  
Old 08-03-2012
Seems like your "date" variable is empty/undefined. Check how are you assigning "date" it's value.
# 3  
Old 08-03-2012
Looks like your "date" variable is unset. Are you running another shell or did you logout/login in between? Try to execute the date command like
echo "Today is " $(date)

Congratulation @bartus11 - you were first!
# 4  
Old 08-03-2012
I don't know what happend it just stopped working. Then I did logout then logged back in getting the same results bad. No I only have ksh shell. The command you provided works. However, can I reset it?
# 5  
Old 08-03-2012
You can (re)assign a value to a variable, in this case

First dateis the variable, the second date is the command that is run with the $(...) construct, and its output is assigned to the variable. Variables are lost when you log out. Use your respective login script to (re)assign them on login.
# 6  
Old 08-03-2012
$date is not a command which prints the date. It's just a variable named the letters "d", "a", "t", "e". You could have called it 'slartibartfast', 'green', or 'clockwise' too.

At one point you put the following letters in it, in order: "7", "/", "1", "2", "/", "1", "2".

So, you weren't really getting the date there, you were just printing a string you'd put in there earlier. If you want to get the date, try date +%D. See man date for what %D represents as well as other options.
# 7  
Old 08-03-2012
Ok that worked thanks

But it seem no matter which command I use it won't show with the echo command unless I (re)assign like you stated. For example
I tried
echo "$ls"
which showed nothing
then I (re)assigned as a variable
which works same for other command. I think I unset more than one command

Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Difference between echo `ls -l` and echo "`ls -l`" ?

Hi guys, Been messing around with shell programming for a couple of days and I found something that was pretty odd in the behavior of the echo command. Below is an example-: When I type the following in my /home directory from my lxterminal in Debian-: echo "`ls -l`" I get the... (2 Replies)
Discussion started by: sreyan32
2 Replies

2. Shell Programming and Scripting

tcsh - understanding difference between "echo string" and "echo string > /dev/stdout"

I came across and unexpected behavior with redirections in tcsh. I know, csh is not best for redirections, but I'd like to understand what is happening here. I have following script (called out_to_streams.csh): #!/bin/tcsh -f echo Redirected to STDOUT > /dev/stdout echo Redirected to... (2 Replies)
Discussion started by: marcink
2 Replies

3. Shell Programming and Scripting

With that logic this echoes "echo". Question about echo!

echo `echo ` doesn't echoes anything. And it's logic. But echo `echo `echo ` ` does echoes "echo". What's the logic of it? the `echo `echo ` inside of the whole (first) echo, echoes nothing, so the first echo have to echo nothing but echoes "echo" (too much echoing :P):o (2 Replies)
Discussion started by: hakermania
2 Replies

4. Shell Programming and Scripting

Help with echo

Hi Guys, I need to print a value in the same line , But when we use the echo instead the loops (while), the value goes to the next line.. Can you help me in this.. Thanks For your help in advance. (6 Replies)
Discussion started by: mac4rfree
6 Replies

5. UNIX for Dummies Questions & Answers

How to correctly use an echo inside an echo?

Bit of a weird one i suppose, i want to use an echo inside an echo... For example... i have a script that i want to use to take users input and create another script. Inside this script it creates it also needs to use echos... echo "echo "hello"" >$file echo "echo "goodbye"" >$file ... (3 Replies)
Discussion started by: mokachoka
3 Replies

6. Shell Programming and Scripting

echo !.

can someone tell me what does this code do? echo !. (2 Replies)
Discussion started by: ryandegreat25
2 Replies

7. Shell Programming and Scripting

Difference between using "echo" builtin and /bin/echo

So in my shell i execute: { while true; do echo string; sleep 1; done } | read line This waits one second and returns. But { while true; do /bin/echo string; sleep 1; done } | read line continues to run, and doesn't stop until i kill it explicitly. I have tried this in bash as well as zsh,... (2 Replies)
Discussion started by: ulidtko
2 Replies

8. UNIX for Dummies Questions & Answers


Is there a way to get echo to make newlines without using any type of quotes? I've done a lot of searches and went into my Linux book to no avail. I'm trying to write five separate lines to a file. I can get echo to accept all five lines like this echo \ \this is line 1\ \this is line 2\ >... (6 Replies)
Discussion started by: Trekker182
6 Replies

9. Solaris

echo help...

Hi anyone know... ID1=1234 ID2=2345 ID3=3456 count=1 while do echo $(ID$count) --> i would like the out put to be 1234 count=$((count + 1)) done exit 0 if i would like to echo ID1 then it will should 1234567. how should i echo like this would not works -> echo $(ID$count) ... (7 Replies)
Discussion started by: summerpeh
7 Replies

10. Shell Programming and Scripting


what is the meaning of this echo $description | wc -m` -ne "1" (0 Replies)
Discussion started by: debasis.mishra
0 Replies
Login or Register to Ask a Question

Featured Tech Videos