Visit The New, Modern Unix Linux Community

Execute a command as root from normal user

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Execute a command as root from normal user
# 1  
Execute a command as root from normal user

Hi ,

I am trying to stop and start a process using the below code. I have sudo access on my machine
## PID = process id
echo "$PASSWD" | sudo -S kill -9 <PID>

echo "$PASSWD" | sudo -S /opt/abc/startserver
/opt/abc/startserver: error while loading shared libraries: cannot open shared object file: No such file or directory

But its working if i follow the below procedure
$ sudo -i
# opt/abc/startserver
Server Started

How do i execute a process with sudo access in my case , i have tried -p <promt option > but no use

any help is much appreciated
# 2  
You are running the upper code in a crontab? In any case it looks like the environment in the first example is missing LD_LIBRARY_PATH variable.
# 3  
First code is a script file not in cron.

The former are the series of commands executed in shell one after the other (not through scripting)
The below commands are working fine
<<command 1>>
$sudo -i 
<<command 2>>
# opt/abc/startserver Server Started 

i tried 
$sudo /opt/abc/startserver    , it throws the same error

# 4  
What, as the concerned user, is the output of
 sudo -l

# 5  
output of sudo -l
User <xyz> may run the following commands on this host:
# 6  
Ok its OT but, I feel a bit concerned by your security with what I see above...
Cant you get your user to have:
n12:/home/vbe $ sudo -l
User vbe may run the following commands on this host:

What I mean is execution without password... since he has all rights... or you all know the passwd and could not care...

Your issue now, it look like suggests Jim, to do with the environment...To see if its that source root's .profile before executing you commands:
 .  ~root/.profile

# 7  
Thanks vbe and jim

Finally the below code worked
## startserver is already included in the Current environment through /etc/profile
 echo "PASSWD" | sudo -S -E startserver

I dont want to try the below trick because this is just adhoc not a regular task.


Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #14
Difficulty: Easy
The F9 function key needs to be pressed during a Windows reboot to enter into Safe Mode.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Execute a command with root user

i m logged in with user1 id. i wish to execute the below as root user for which i tried several commands but all of them fail. sudo 'cat /tmp/tmp.file >>/etc/logger' Password: sudo: cat /tmp/tmp.file >>/etc/logger: command not found sudo cat /tmp/tmp.file >>/etc/logger bash:... (5 Replies)
Discussion started by: mohtashims
5 Replies

2. Shell Programming and Scripting

Will Chkconfig works for normal user apart from root user

Hi, I am trying to schedule a script that starts on reboot.I came across chkconfig utility to schedule scripts on reboot. Problem here is can i how to use this chkconfig to schedule a script that runs a s normal user. Or if there is any other function to schedule on reboot as normal user... (4 Replies)
Discussion started by: praveena kotapa
4 Replies

3. UNIX for Dummies Questions & Answers

Switching from root to normal user takes me to user's home dir

Whenever i switch from root to another user, by doing su - user, it takes me to home directory of user. This is very annoying as i want to be in same dir to run different commands as root sometimes and sometimes as normal user. How to fix this? (1 Reply)
Discussion started by: syncmaster
1 Replies

4. Solaris

java version mismatch for normal user and root user

:confused: I installed latest version of java ( jre 1.6) on Solaris Machine ......when I run java -version as root, shows the latest version but when I run java -version as normal user, shows the old / previous version What should I do to fix this ...should show the latest version... (3 Replies)
Discussion started by: frintocf
3 Replies

5. Shell Programming and Scripting

Execute Root command as Normal user

Hi, We need to execute a root commmand to change the expiry period of a user but we are getting error as permission denied Q How can we execute a root command by a normal user ? :mad: any thing or suggestion will be good .... :b: (3 Replies)
Discussion started by: abhishek1979
3 Replies

6. Shell Programming and Scripting

root user command in shell script execute as normal user

Hi All I have written one shell script for GPRS route add is given below named URL="" VBURL="" echo "Setting route for $URL for GPRS" URL_Address=`nslookup $URL|grep Address:|grep -v "#"|awk -F " " '{print $2}'|head -1` echo "Executing ... (3 Replies)
Discussion started by: mnmonu
3 Replies

7. Shell Programming and Scripting

login into root from user and execute command through script

i have logged in as user. I want to write a script to login into root and execute commands for eg. ifconfig or other command. kindly help me out. (6 Replies)
Discussion started by: pradeepreddy
6 Replies

8. Shell Programming and Scripting

su root from normal user

Got a cron to run everyday under my user. this cronjob runs a script from my /home/jack/scripts/ clear # # su to root and run a script, return with result # su - # passwd # run / # return with result # the result will copy 2 files from /prod/app/logs/ and... (0 Replies)
Discussion started by: karthikn7974
0 Replies

9. Shell Programming and Scripting

switching between root and a normal user

I am writing a script that has some tasks that must be run as root, then set of tasks to be run as normal user, then again as root. is there a way to switch between users in a script? any other alternatives? thx (3 Replies)
Discussion started by: melanie_pfefer
3 Replies

10. UNIX for Advanced & Expert Users

Other than root user .Normal user is unable to create files

Hi all, I am using Sun Solaris 9 .In this system normal users unable to create files from the command line.I added these users in bin,adm and even root group i found them unable to create a file. (1 Reply)
Discussion started by: mallesh
1 Replies

Featured Tech Videos