Mounting File System


 
Thread Tools Search this Thread
# 1  
Mounting File System

Hi Team ,

Team Can any give me a good explanation of mount file system.Smilieif we have do a df -k it show /var/orcl/abc/txt mounted on /var/orcl.

example :

Filesystem 1K-blocks Used Available Use% Mounted on
tmpfs 4021876 0 4021876 0% /dev/shm

Kindly explain me what does Filesystem,Mounted on Means in the above example .


Thanks,
Anudeep
# 2  
Quote:
Originally Posted by kkabc789
Filesystem 1K-blocks Used Available Use% Mounted on
tmpfs 4021876 0 4021876 0% /dev/shm

Kindly explain me what does Filesystem,Mounted on Means in the above example .
The first field shows the type of the filesystem. "tmpfs" is a virtual filesystem that uses a portion of your RAM[*]. So it's extremely fast (but volatile).

The second field shows how big the filesystem is: 4021876 * 1kB, so about 4GB. Be careful: this does NOT mean that the filesystem blocks are actually 1kB each. You told df to show dimension in 1k blocks, using the "-k" option.

Third field shows the number of used (1k) blocks. 0 means that the fs is empty.

Fourth field shows the number of available (1k) blocks. In your example, all blocks are empty and available.

Fifth field shows the how much the filesystem is used, in percentage. Again, 0% means empty.

Last field shows the mount point of this filesystem. This tmpfs filesystem is mounted on /dev/shm, which is a directory on your primary filesystem (that is on your root partition). Even if this directory is not empty on the disk (however any mountpoint should be empty), as long as another filesystem is mounted on it you can't see (nor access to) the content of this directory on the disk: you will see the content of the mounted filesystem instead.

If you write, for instance, to /dev/shm/filetest, you're not writing to one of your disks, but to your virtual filesystem in RAM.

Try:
Code:
dd if=/dev/zero of=/dev/shm/filetest bs=16M count=50

Fast, isnt'it? Smilie

[*] More info about tmpfs here:
http://www.kernel.org/doc/Documentat...tems/tmpfs.txt
# 3  
Do you mind telling us on what platform and OS? I have doubts about your df -k output...
And next time use code tags and not fancy colors that doesnt help the search engines...
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

10 More Discussions You Might Find Interesting

1. Red Hat

Issue with mounting the file system .

Hi gurus, Need your help , Am facing some issue with one of the ext3 file system.while rebooting it failed to mount fs after running fsck i tried manuall but still no luck.However i made the machine up but am unable to mount file system can some one please help me. root@vm258902]~# cat... (2 Replies)
Discussion started by: kapil514
2 Replies

2. Emergency UNIX and Linux Support

Problem mounting NTFS file System in REDHAT Enterprise 5

When I am trying to mount my windows partitions in REDHAT Enterprise Linux 5 using these command mount -t ntfs-3g /dev/sda1 /mnt/ntfs I have encountered with the problem mentioned below FATAL: Module fuse not found. ntfs-3g-mount: fuse device is missing, try 'modprobe fuse' as root I have... (3 Replies)
Discussion started by: dearanik
3 Replies

3. UNIX for Dummies Questions & Answers

Mounting a floppy disk in System V

Hello all! I just recently inherited a mid-90s gateway full tower system (Original Pentium, SIMM style RAM, etc.). I had always wanted to try an old version of UNIX, and having come across a copy of AT&T System V R4 decided that the time was ripe. There were 30 disks total, and after booting to... (1 Reply)
Discussion started by: Northcott
1 Replies

4. UNIX for Dummies Questions & Answers

Facts about mounting remote file system

Say, we are going to mount a remote file system on our server. I am not too sure about how will data be transferred back to original host when it is written to the mounted FS. Could you please share an article or your knowledge on this? Thanks in advance; Stephen W. (2 Replies)
Discussion started by: swmk
2 Replies

5. Solaris

Mounting a NFS network file system across platforms - Solaris to AIX

Hi all, Kind of an emergency situation, I have to NFS mount an AIX filesystem on to a Sun Solaris OS (5.10). Typically from Sun to Sun is: mount -F nfs <remote file system>/dir <mount point> Which of course doesn't work if the remote file system is another OS (like AIX). Is there... (1 Reply)
Discussion started by: jeffpas
1 Replies

6. Solaris

mounting file system /etc/vfstab

Hello. When I use format command - It shows: /dev/dsk/c0d0s4 is normally mounted on /u02 according to /etc/vfstab. Please remove this entry to use this device. What does it mean? (4 Replies)
Discussion started by: panchpan
4 Replies

7. AIX

File system not mounting at bootup

Hi, I've got a recent problem with 2 file systems on an AIX 5.3 server. The fs's are marked to auto mount at startup and do show as being mounted after a a restart however if you cd to the mount point and 'df -g .' it shows the fs hasn't actually mounted. $ mount |grep SQLT0001.0 ... (2 Replies)
Discussion started by: m223464
2 Replies

8. Solaris

mounting windows(vfat) file system

how can i mount windows file system into solaris using vfstab or mount command. also please tell me how to display the partition information. (1 Reply)
Discussion started by: ajoy patel
1 Replies

9. UNIX for Dummies Questions & Answers

Mounting a Floppy on System V

Hi, i want to mount a floppy disk device on a System V/68 Release R3V6 system because i want to copy some files from this Unix computer to a Win-98 based computer. I have logged in as "root" and used command line: mount /dev/f0ps2 /floppy (the "floppy folder" on the computer i'm working on is... (1 Reply)
Discussion started by: xtremexp
1 Replies

10. UNIX for Advanced & Expert Users

Mounting an ISO As a file system in AIX

I want to mount an ISO image as a file system in AIX, have been unable to find a utility to do so after scouring the net. Bryan (1 Reply)
Discussion started by: murdaugh
1 Replies

Featured Tech Videos