ps command


 
Thread Tools Search this Thread
# 1  
ps command

What is the difference between ps -ax and ps -x? I got the meaning here but don't understand it clearly.

-a List information about all processes most frequently requested: all those except process group leaders and processes not associated with a terminal.

-x includes processes not attached to terminals

what are proccess group leaders and processes not associated with a terminal? processes not attached to terminals?

Can please someone explain this to me.
# 2  
These options are describing the BSD ps syntax (ps -x is invalid) so should not be prefixed by a dash.

process group leaders are processes that created a process group, commonly used with shell job control.

processes not associated with / attached to terminals are usually daemons and similar processes that do not use a terminal (tty) to read their input / write their output.
# 3  
Thank you so much for your reply.

I'm not sure about ps x. I read it from the book and it can run well when I type in the terminal.
# 4  
Quote:
Originally Posted by muffle
I'm not sure about ps x. I read it from the book and it can run well when I type in the terminal.
That depends on the OS you use. It runs with a warning on Gnu/Linux but fails on Solaris.

Linux:
Code:
$ ps -x
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
  PID TTY      STAT   TIME COMMAND
 1611 ?        Ssl    0:00 gnome-session
 1642 ?        Ss     0:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-s

Solaris:
Code:
$ ps -x
ps: illegal option -- x
usage: ps [ -aAdeflcjLPyZ ] [ -o format ] [ -t termlist ]
        [ -u userlist ] [ -U userlist ] [ -G grouplist ]
        [ -p proclist ] [ -g pgrplist ] [ -s sidlist ] [ -z zonelist ]
  'format' is one or more of:
        user ruser group rgroup uid ruid gid rgid pid ppid pgid sid taskid ctid
        pri opri pcpu pmem vsz rss osz nice class time etime stime zone zoneid
        f s c lwp nlwp psr tty addr wchan fname comm args projid project pset

# 5  
As a side note, the Berkeley version of some Unix programs could be found in /usr/ucb on Solaris (ucb = University of California, Berkeley):


Code:
bash-3.2$ uname -sr; /usr/ucb/ps -x
SunOS 5.10
   PID TT       S  TIME COMMAND
 18261 ?        S  0:00 /usr/lib/ssh/sshd
 18270 pts/4    S  0:00 -ksh
 18296 pts/4    S  0:00 bash
 18446 pts/4    O  0:00 /usr/ucb/ps -x

Code:
SunOS/BSD Compatibility Package Commands                   ps(1B)

NAME
     ps - display the status of current processes

SYNOPSIS
     /usr/ucb/ps [-aceglnrSuUvwx] [-t term] [num]

DESCRIPTION
     The ps command displays information  about  processes.  Nor-
     mally,  only  those  processes  that  are  running with your
     effective user ID and are attached to a controlling terminal
     (see    termio(7I))  are  shown.  Additional  categories  of
     processes can be added to the display using various options.
     In particular, the -a option allows you to include processes
     that are not owned by you (that do not have your  user  ID),
     and  the  -x  option allows you to include processes without
     controlling terminals. When you specify both -a and -x,  you
     get processes owned by anyone, with or without a controlling
     terminal. The -r option  restricts  the  list  of  processes
     printed to running and runnable processes.


Last edited by radoulov; 05-21-2012 at 12:18 PM..
# 6  
Thanks to both jlliagre & radoulov. I understand now.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Execute ssh command with additional terminal command to any remote user not working script

Hello i am having an issue with bash script and this is the code now=$(cat hosts1.txt | awk '{print $2;}') while read n ;do ssh root@$now 'useradd test1; echo -e "test1\ntest1" | passwd test1 && echo "test1 ALL=(ALL:ALL) ALL" >> /etc/sudoers' When i execute only part with cat, it... (8 Replies)
Discussion started by: tomislav91
8 Replies

2. AIX

I'm facing problem with rpm command, when running the command and appears this error:

exec(): 0509-036 Cannot load program /usr/opt/freeware/bin/rpm because of the following errors: 0509-022 Cannot load module /opt/freeware/lib/libintl.a(libintl.so.1). 0509-150 Dependent module /opt/freeware/lib/libiconv.a(shr4.o) could not be loaded. 0509-152 Member... (4 Replies)
Discussion started by: Ohmkar
4 Replies

3. Shell Programming and Scripting

Multiple command execution inside awk command during xml parsing

below is the output xml string from some other command and i will be parsing it using awk cat /tmp/alerts.xml <Alert id="10102" name="APP-DS-ds_ha-140018-componentFailure-S" alertDefinitionId="13982" resourceId="11427" ctime="1359453507621" fixed="false" reason="If Event/Log Level(ANY) and... (2 Replies)
Discussion started by: vivek d r
2 Replies

4. Shell Programming and Scripting

SH script, variable built command fails, but works at command line

I am working with a sh script on a solaris 9 zone (sol 10 host) that grabs information to build the configuration command line. the variables Build64, SSLopt, CONFIGopt, and CC are populated in the script. the script includes CC=`which gcc` CONFIGopt=' --prefix=/ --exec-prefix=/usr... (8 Replies)
Discussion started by: oly_r
8 Replies

5. UNIX for Dummies Questions & Answers

passing command output from one command to the next command in cshell

HI Guys, I hope you are well. I am trying to write a script that gets executed every time i open a shell (cshell). I have two questions about that 1) I need to enter these commands $ echo $DISPLAY $ setenv $DISPLAY output_of_echo_$display_command How can i write a... (2 Replies)
Discussion started by: kaaliakahn
2 Replies

6. UNIX for Advanced & Expert Users

unix command : how to insert text at the cursor location via command line?

Hi, Well my title isn't very clear I think. So to understand my goal: I have a script "test1" #!/bin/bash xvkbd -text blabla with xbindkeys, I bind F5 key in order it runs my test1 script So when I press F5, test1 runs. I'm under Emacs/Vi and I press F5 in order to have "blabla" be... (0 Replies)
Discussion started by: xib.be
0 Replies

7. Shell Programming and Scripting

Need help! command working ok when executed in command line, but fails when run inside a script!

Hi everyone, when executing this command in unix: echo "WM7 Fatal Alerts:", $(cat query1.txt) > a.csvIt works fine, but running this command in a shell script gives an error saying that there's a syntax error. here is content of my script: tdbsrvr$ vi hc.sh "hc.sh" 22 lines, 509... (4 Replies)
Discussion started by: 4dirk1
4 Replies

8. AIX

AIX:Command to get netaddress/subnet address command in IPv4/IP6

AIX:Command to get netaddress/subnet address command in IPv4/IP6 Can anybody help us with a command to retrieve netaddress/subnet address command in IPv4/IP6 on aix machine. net/subnet address is in the format 172.16.212.0(signifies all 255 machines in an IPv4 network) (2 Replies)
Discussion started by: rookie8278
2 Replies

9. Shell Programming and Scripting

assign a command line argument and a unix command to awk variables

Hi , I have a piece of code ...wherein I need to assign the following ... 1) A command line argument to a variable e.g origCount=ARGV 2) A unix command to a variable e.g result=`wc -l testFile.txt` in my awk shell script When I do this : print "origCount" origCount --> I get the... (0 Replies)
Discussion started by: sweta_doshi
0 Replies

10. SuSE

inconsistent ls command display at the command prompt & running as a cron job

Sir, I using the following commands in a file (part of a bigger script): #!/bin/bash cd /opt/oracle/bin ls -lt | tail -1 | awk '{print $6}' >> /tmp/ramb.out If I run this from the command prompt the result is: 2007-05-16 if I run it as a cron job then... (5 Replies)
Discussion started by: rajranibl
5 Replies

Featured Tech Videos