Script not executing


 
Thread Tools Search this Thread
# 1  
Script not executing

Hello,

I wasn't sure where to post this so I posted it here. I've used UNIX quite a bit, LINUX not so much. For some reason, my LINUX script will not execute if I type in the script name and press enter. I'm in the directory where the script is.

test.sh

However, when I use ". ./" it executes fine. I was wondering why this is and what I need to do to have it execute at the command prompt without the ". ./".

. ./test.sh

This is part of a bigger question and issue I'm having which I'm not looking to resolve here. I'm trying to install Informatica 9.1 onto a LINUX RedHat platform. The install script wouldn't run when I typed in install.sh. When I ran it with ". ./install.sh a number of error messages popped up and the install hung. I'm working with Informatica Support on this.

Regards, Jim
# 2  
Shouldn't that be
Code:
./test.sh

Or
Code:
/fullpath_to_script/test.sh

The reason your script won't execute as just test.sh is because the directory containing the script is not in $PATH . Your other system may have had . in $PATH (i.e. any current directory) which is a big security risk.
# 3  
Thanks

Thank you,

I didn't notice that this system when I did an "ls", did not have a '.' or a ".." directory. I do remember other systems I've worked on did have those directories. That certainly makes sense now.

Regards, Jim
# 4  
. and .. definitely exist in Linux too, though ls may not show them. They have the usual meaning, current folder and previous folder.
# 5  
You may be misunderstanding me about $PATH.

Try this command to show you the contents of the standard $PATH variable. It lists all the directories in order which the Operating System will search when looking for a program or executable script. If the variable $PATH contains . (current directory) then it will also look in whatever is the current directory.
Code:
echo "${PATH}"

The . and .. directories are always there.
Try:
Code:
ls -la

# 6  
Thanks for the help again...
This User Gave Thanks to jsanders For This Post:
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Executing Oracle script from UNIX Script

Hi, I am new to UNIX and want to execute oracle script from unix script. I have written below script but i am getting below error. #!/bin/bash file="/home/usr/control/control_file1" while read line do #$line=@$line #echo $line sqlplus tiger/scott@DB @$line exit #echo "$line" done... (3 Replies)
Discussion started by: vipin kumar rai
3 Replies

2. UNIX for Dummies Questions & Answers

Script dosent exits after executing the script

Hi i wrote a script which dosent exists after executing any help #!/bin/bash netstat -ptlen | grep 10000 if ; then echo "Hive Thrift server is running" exit 0 else echo "Hive Thrift server is down Trying to Bring up the service" | mail -s "ALERT" team@domain.com `nohup hive... (7 Replies)
Discussion started by: vikatakavi
7 Replies

3. Shell Programming and Scripting

executing one script from other

Script test #! /bin/csh -f echo checking the sset command if( -e /home/user/project/runtest/testdir/ts ) then echo ts script present set cmd = "/home/user/project/runtest/testdir/ts a 1 b 2 c 3" else echo script not present endif echo $cmd echo done script ts #!/bin/csh -f set... (1 Reply)
Discussion started by: animesharma
1 Replies

4. UNIX for Dummies Questions & Answers

Help with executing script

Dear All, I have a script on my USB and I want to execute it on set of files when I connect via ssh on the server ... I'm not able to define the path of the script located in the USB ... how can I use this script without copying/moving it into the directory I'm working on in the ssh mode ....... (6 Replies)
Discussion started by: pawannoel
6 Replies

5. Shell Programming and Scripting

SCRIPT NOT EXECUTING

HI All, The below shown script whcih is executing wrongly Actually i have three inputs from user FILE NAME :INPUTS CONFRIM FILE NAME :Y or N CONFIRM PATH :/ or . by depending on the user input the script have to execute the find command in the root path or in the home... (3 Replies)
Discussion started by: thelakbe
3 Replies

6. Shell Programming and Scripting

Variables of executed script available in executing script

Hi, I have a script get_DB_var.ksh which do a data base call and get some variables as below: sqlplus -silent $user/$pass@dbname <<END select col1, col2, col3 from table_name where col4=$1; exit; END Now I want to access all these variables i.e.... (9 Replies)
Discussion started by: dips_ag
9 Replies

7. UNIX for Advanced & Expert Users

Executing a shell script from windows;script present in unix

I need to execute a shell script kept in unix machine from windows. User id, password area available. For eg. There's a shell script wich moves all the logs kept in my home directory to a directory named LOGS. Now i need to get this done through windows; either using a batch file, or java... (4 Replies)
Discussion started by: rajneesh_kapoor
4 Replies

8. Shell Programming and Scripting

executing script

Hello ; I have a script myscript.sh. If I type at prompt myscript.sh I will receive ksh: myscript.sh: not found but if I type ./myscript.sh it works . What should I do to be able to run myscript just typing myscript.sh Many thanks before. (1 Reply)
Discussion started by: big123456
1 Replies

9. Shell Programming and Scripting

script not executing

test:/oracle/home $ ex_im1.sh ksh: exp_imp1.sh: not found $echo $SHELL /bin/ksh ex_im1.sh has rwxr--r-- permissions thanks (3 Replies)
Discussion started by: dreams5617
3 Replies

10. Shell Programming and Scripting

Executing Ps in script

Im Sorry to bother you guys butim totally new to Unix, so pls help me out if you can. This could be a silly question. I wanna run the command "ps" in script, but how should I be able to do so? Actually I have made a menu for the user to choose from...for example 1. Show all processes 2.... (1 Reply)
Discussion started by: Claude
1 Replies

Featured Tech Videos