Difference between two cmmands that did the same thing


 
Thread Tools Search this Thread
# 1  
Difference between two cmmands that did the same thing

Hello everybody,

Can you please help me unerstand the difference between:
Code:
# grep word_we_are_looking_for /directory/file

and
Code:
# more /directory/file |grep word_we_are_looking_for

I know that the result is the same.

Thank you for your help.
Moderator's Comments:
Mod Comment Please use next time code tags for your code and data
# 2  
the main difference is the usage of a pipe | ... (using more process...)
The rest, meaning the returned result should be the same...

look at :http://partmaps.org/era/unix/award.html
Useless Use of cat :http://partmaps.org/era/unix/award.html#cat
This is very close to your second line...
# 3  
Thanks for you answer. Do you mean the command with | consume more ressources ? if yes how many process are used by each command ?

Thanks
# 4  
the pipe takes an extra process...
# 5  
What do you mean by extra process ?
# 6  
You are running two programs to do the job of one. The 'more' does essentially nothing -- printing the file and feeding it into grep, even though grep is fully capable of reading files all by itself.

This is essentially the same problem as useless use of cat.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #936
Difficulty: Easy
The echo request ("ping") is an ICMP/ICMP6 message.
True or False?

7 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

awk to calculate difference of split and sum the difference

In the awk I am trying to subtract the difference $3-$2 of each matching $4 before the first _ (underscore) and print that value in $13. I think the awk will do that, but added comments. What I am not sure off is how to add a line or lines that will add sum each matching $13 value and put it in... (2 Replies)
Discussion started by: cmccabe
2 Replies

2. Programming

what is the main difference between difference between using nonatomic lseek and O_APPEND

I think both write at the end of the file ...... but is there a sharp difference between those 2 instruction ..... thank you this is my 3rd question today forgive me :D (1 Reply)
Discussion started by: fwrlfo
1 Replies

3. Ubuntu

need some help on this jolicloud thing??PLease help !!!!

i am not used to linux ubuntu... i get the same error code while booting from jolicloud.... can you help, please??????? i can't directly installed it because everytime i tried it, installation panel freezes, so i waited and it booted from live cd.... i tried to install jolicloud... (0 Replies)
Discussion started by: cemdede@hotmail
0 Replies

4. UNIX for Dummies Questions & Answers

Cannot do this simple thing

I think its a bash thing and it is really annoying me.. its difficult to explain the problem but I will try.. When I type a command on the shell prompt... then lets say I go back to the 2nd letter and correct a typo.. after that I cannot get the cursor beyond the last alphabet that I had... (4 Replies)
Discussion started by: tantric
4 Replies

5. OS X (Apple)

Ok another small thing if anyone knows...

Hi i wanna change the look of my terminal. For example i wanted a black background and like a cyan colored text so it stands out against the black. Is there anyway i can do this?. I am running Mac OSX if that helps any at all (2 Replies)
Discussion started by: Corrail
2 Replies

6. UNIX for Dummies Questions & Answers

Shortcut thing?

Hey, im new to Linux...totally new. I know there is a way to assign a type of variable or something to a directory, so instead of having to type "cd /var/www" etc, I could just assign a variable to the directory, so I could just do "cd $assignedvar" and it would be there...if you get what I... (0 Replies)
Discussion started by: mo0ness
0 Replies

7. UNIX for Dummies Questions & Answers

Dumb thing to do

I'm writing for a friend. He has a SPARC system at home that has Solaris 7 on it. He did not yet create a user on it and has not set the CONSOLE to allow the root user to log in remotely. Now, something happened and the system will not even boot to the Boot PROM. How can he get into the system... (4 Replies)
Discussion started by: danh
4 Replies

Featured Tech Videos