Visit The New, Modern Unix Linux Community


Grub won't let me add a disc


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Grub won't let me add a disc
# 1  
Grub won't let me add a disc

Newbie, so bear with.Smilie

Have a dual boot: XP and OpenSuse 12.1, both are on separate discs.

I want to add a further disc, on which to run AVLinux.

When I connect up the disc, Boot stalls, with Grub error number 22. And works OK if I again disconnect the disc.Smilie

Have completely erased all partitions on disc using Parted Magic: it shows as 100% unallocated. Boot order (in BIOS) set not to boot this ahead of the two already existing.

Why does it do this? What can I do about it?
# 2  
Sounds like the BIOS order is changing, regardless... Try swapping the cables and changing the order back in the BIOS itself.
This User Gave Thanks to Corona688 For This Post:
# 3  
Thanks for ever so prompt response. I will give that a go.

---------- Post updated 22nd Mar 2012 at 03:29 AM ---------- Previous update was 21st Mar 2012 at 09:38 PM ----------

Tried that, and still get number 22 error.

Grub seems to recognise this drive in preference to the others, no matter which channel I have it connected to, and irrespective of the boot order which I set in BIOS.

I have swapped out this HDD for a different unit, and alternate interface, (SATA in place of PATA) and system now boots OK.

I am no longer stuck, but from a learning point of view would still value knowing why this occurred, if anyone can tell me.
# 4  
The system is loading the boot sector from one disk, but grub is using the wrong boot order and can't find its files. Adding the disk to SATA seems to mess up the boot order for your BIOS no matter what, quite strange.
# 5  
Trying to think about this, (correct me if I am wrong) the BIOS component must be functioning correctly: for me to see such an error message, i.e.Master Boot Code being read from first (XP) drive, followed by execution then being passed to second (OpenSuse) drive from which Grub Boot is beginning execution.

With only two drives (1st is PATA, 2nd is SATA) Boot functions successfully.

When I add a third drive:

Works OK if added unit is a SATA Drive.
Error 22, if added unit is a PATA Drive!

So it appears that, in the last (3rd Drive PATA) arrangement, Grub ceases to search for its files on its own disc, searching the newly added disc instead!

I have tried looking in the on-line Grub Tutorial, but did not see anything to indicate why this should be happening. I would be grateful if anyone can give me a steer on where to look for more information.
# 6  
On second thought, it could be problems with /boot/grub/device.map

If it doesn't match the BIOS order anymore, it could end up deciding hd0 is the wrong drive.
This User Gave Thanks to Corona688 For This Post:
# 7  
Thanks again, looks like you've nailed it.

Googling Grub device map yielded: "GRUB will get the order wrong if you exchange the boot sequence between IDE and SCSI in your BIOS."

I seem to recall from previous OpenSuse (11.4) that it treats SATA as SCSI.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #408
Difficulty: Medium
The Cygwin distribution contains thousands of packages from the Open Source world including most GNU tools, many BSD tools, an X server and a full set of X applications.
True or False?

9 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Bash script won't run because hardware won't produce display

Can anyone offer any advice on how to modify the script below to work on a new system we have, that has no graphics capability? We admin the system through a serial RAS device. I've tried running the below script through the RAS and through an ssh -X session. It failed with something like "GTK... (3 Replies)
Discussion started by: yelirt5
3 Replies

2. UNIX for Dummies Questions & Answers

"/boot/grub/grub.conf" VS "/etc/grub.conf"

can someone please explain me the difference between these two files: "/boot/grub/grub.conf" and "/etc/grub.conf" .. (7 Replies)
Discussion started by: stunn3r
7 Replies

3. Red Hat

Can we specify which grub.conf to use in grub-install.

Hi, Can we specify which grub.conf to use while installing grub on RHEL. We are working on application which requires different grub configurations needed, depending on certain criteria we need to update grub with correct grub.conf. Can we use grub-install for this purpose? (4 Replies)
Discussion started by: successlin
4 Replies

4. Red Hat

Server won't boot up ... no GRUB menu

I dont know what the heck happen but one of our DBAs was working on a cluster for oracle. Rebooted the box and viola, the OS won't load. After the POST message, I get a blinking cursor on the upper left hand corner. Doesn't even say "GRUB" or anything, it just blinks. I tried going into rescue... (1 Reply)
Discussion started by: sdotsen
1 Replies

5. AIX

won't mount /usr...won't boot fully

Hello: NOOB here. I attempted to use smit mkcd. Failed on first attempt, not enough space. 2nd attempt tried to place iso on /usr, not enough space there. Cleanup ran for about 5 minutes after aborting. Now AIX won't boot. LCD display on 7029-6E3 says: 0517 MOUNT /USR. Attempted to boot from CD... (11 Replies)
Discussion started by: bbird
11 Replies

6. Solaris

Ultra 10 - Copying Files From Disc After Booting Up With Recovery Disc?

Hello, I'm still learning unix and I have what is probably a simple question but I can't seem to find the question to. I have an Ultra 10 Sparc Server running solaris 8 and the drive may have crashed (I hope not). Currently, it appears some files in the /etc folder are missing. I have a backup... (1 Reply)
Discussion started by: ideffects
1 Replies

7. UNIX for Dummies Questions & Answers

grub problem- keeps rebooting as soon as it tries to do grub

Hi, I installed solaris 10 a few weeks ago. It was working fine during the past two weeks. However, now when I start to load to the drive, I get this problem: The BIOS screen comes up like normal, then screen goes blank and a message "Grub loading stage 2" flashes real quick then the computer... (1 Reply)
Discussion started by: moesays
1 Replies

8. UNIX for Dummies Questions & Answers

Disc Needs Maintenance

Hello All Here I am using Sun V880 server which have discsuit pack of 8 discs with 2 sub mirrors each. Everything was fine for the last 1 year. Now I am getting problem of taking backup of the server. After analysis what I got that each 2nd submirrors are in NEEDS MAINTENANCE status. What... (5 Replies)
Discussion started by: ailnilanjan
5 Replies

9. UNIX for Dummies Questions & Answers

Disc Copy

Is there a disk copy utiliy for unix systems eg: I need to make a duplicate copy of a netraT1 to a netraT1 Thanks (1 Reply)
Discussion started by: SmartJuniorUnix
1 Replies

Featured Tech Videos