Help with NIS client


 
Thread Tools Search this Thread
# 1  
Help with NIS client

Hi All,

I have a new server on the network, I did configure the NIS. ypwhich is working and ypcat all are working. But when I log in as me, home directory is not coming up. I looked at other servers we have at work to see what's under /etc/fstab. I don't see anything for home directory.

Please advice is there is any other files other then /etc/fstab. you configure the NFS mount point?

Code:
 
Error msg. 
Could not chdir to home directory /home/xxx: No such file or directory

Working on Redhat 5.7 version.

Thanks.
# 2  
What is the OS

What is your OS? I don't think this is a NIS issue but a automount or autofs issue.

Look at these files:
/etc/default/autofs
/etc/vfstab
/etc/auto_master
/etc/auto_home
or
/etc/auto_misc
/sytems/filesystem/autofs
/etc/mnttab

Check the above files on a working system and compare them to the new system.

I hope this helps you out.
This User Gave Thanks to bitlord For This Post:
# 3  
Thanks. I did check on the above files and I don't see any mount point settings, in the above file locations. Using Redhat 4.0 E.S. When I reboot the server, I can see the file systems gets mounted correctly but not sure where the settings are coming from. Any other idea.

Thanks again.
# 4  
I would look at redhat's documentation. They have good documentation. I am currently looking at the info to setup home directories with LDAP. The link below should help.
System Administration Guide
I would also look on the centOS site. They also have great documentation.
This User Gave Thanks to bitlord For This Post:
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

10 More Discussions You Might Find Interesting

1. HP-UX

NIS Master and Client problem

I have a NIS Master server and NIS Clients. But when I started the service all the process and files that should be owne by root apper by the owner 0 This is an example 0 1709 1708 0 10:06:10 ? 0:00 /usr/sbin/nfsd 4 0 1710 1709 0 10:06:10 ? 0:00 /usr/sbin/nfsd 4 0 1708 1 0 10:06:10 ? 0:00... (2 Replies)
Discussion started by: GCSG
2 Replies

2. Solaris

Solaris 10 NIS client configuration

Hi, I have a Solaris 10 machine and trying to connect it to a Linux NIS Server. Up till now I have set up NIS so that it does find the NIS server and gets the user list. Automounter also mounts some directories from an NFS server. However, I can't get it to map the shadow passwords (they... (4 Replies)
Discussion started by: dop
4 Replies

3. Solaris

Problem with NIS client

Hi All, In my network infra, there is a NIS master server and many more NIS slave servers. Now, I want every client to set with master server and one possible slave server so that if master goes down, client could still get info from slave server. The servers will be listed on... (0 Replies)
Discussion started by: naw_deepak
0 Replies

4. Solaris

Solaris 10 NIS Client

Hi all, Recently i have implemented NIS functionality in solaris 10 and i have created server and client with user in server side by giving useradd -d /export/home/user1 -m -s /bin/sh user1 after that I went to /var/yp dir and give /usr/ccs/bin/make so that it will refelect to client... (2 Replies)
Discussion started by: esungoe
2 Replies

5. Solaris

NIS Client issues

Hey All! Today I am getting an error with my NIS client From what I understand, my server is running properly... on my client side.. online 2:01:12 svc:/network/nis/client:default # ps -ef |grep ypbind root 2745 1 0 02:01:12 ? 0:00... (12 Replies)
Discussion started by: Keepcase
12 Replies

6. Solaris

NIS - Client Not loggin in

Friends n Gurus I am creating an NIS farm(Solaris only) in my office. I have successfully configured the NIS master and slave servers and a few NIS clients. However i am not able to log into a few of my NIS clients. The commands "ypcat passwd" is displaying the NIS user. However when i try to... (5 Replies)
Discussion started by: Renjesh
5 Replies

7. Solaris

How to configure a NIS client bound to the NIS server in another subnet?

Hi, all. I have a Solaris client here needs to bind to NIS server in another subnet. Following is the configuration i made on the client, 1) edit /etc/inet/hosts to add an entry of the NIS server -- nserver01 2) execute `domainname` to set local NIS domain to the domain of the NIS server.... (1 Reply)
Discussion started by: sn_wukong
1 Replies

8. AIX

AIX NIS client

All, I have just started using AIX (Solaris admin here) and I need to setup my new AIX box as an NIS client. Where would I do this? Thanks for the help! -Kevin (2 Replies)
Discussion started by: kjbaumann
2 Replies

9. AIX

Use AIX as NIS client

Hi everyone. Has anyone here used AIX as a NIS client to a Linux server? If have configured this setup and cant get it to work. I have verifyed that the NIS server is working since other machines are able to connect to it and users to log in on other clients. On the AIX machine the users are... (0 Replies)
Discussion started by: sprellari
0 Replies

10. Solaris

Unregietred a nis+ client

Hi, How can I unregistered a nis+ client. I want it works without nis+. Bests regards (2 Replies)
Discussion started by: omainfroy
2 Replies

Featured Tech Videos