Visit The New, Modern Unix Linux Community

Grep Regexp not working correctly

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Grep Regexp not working correctly
# 1  
Grep Regexp not working correctly

Consider the following code:
grep -o -e '^STEAM_[0-5]:[0-5]:\d+$' workfile3.tmp

A sample format of a valid string for the regexp would be:

Here is an example line from the workfile3.tmp file:
465:L 01/02/2012 - 00:05:33: "Spartan1-1-7<8><STEAM_0:1:47539638><>" connected

No matter what I try it will not return that string. I have tried the -G flag, -E flag, and as you can see -e flag. Any ideas? Smilie
# 2  
Try this
 grep -o -e "STEAM_[0-5]:[0-5]:[0-9]\{1,10\}" input

\{1,10\} is range of number of digits expected after last ":"

This User Gave Thanks to Peasant For This Post:
# 3  
Worked wonders. Thanks man. Smilie

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #314
Difficulty: Easy
Pointers were not used in the original C programming language and were added later in in C++.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Are the brains of the UNIXoid working correctly?

Today I saw the topic. sum-even-numbers-1-100 At that time, it was already closed but not the point. Other thoughts came to mind. All newcomers to Haskell are afraid that when they study it, their brains will turn inside out. I did not notice anything like that. And all because the brains of all... (4 Replies)
Discussion started by: nezabudka
4 Replies

2. UNIX for Dummies Questions & Answers

vnc No Longer Working Correctly

Hello All, Yesterday, all day, I was using x11vnc and vncviewer to connect to a server. But today for some reason it is not working. I don't remember changing any settings or anything like that, but because it stopped working correctly I guess something has...? I'm issuing the exact same... (0 Replies)
Discussion started by: mrm5102
0 Replies

3. Shell Programming and Scripting

awk not working correctly

Hi I am attempting to right a script which will read a table and extract specfic information. LASTFAILEDJOB=/usr/openv/netbackup/scripts/GB-LDN/Junaid/temp_files/lastfailedjob cat /usr/openv/netbackup/scripts/GB-LDN/Junaid/temp_files/lastfailedjob 237308646 If i run the following... (5 Replies)
Discussion started by: Junes
5 Replies

4. Shell Programming and Scripting

rsync is not correctly working

We are using Red Hat linux system. I am transferring my rman backup files to another server. Here is the command i am using to transfer the files. /usr/bin/rsync -avpP --delete /xyz/xyz/ 99.99.999.99::db110bkp Here is the rsync version. >rsync --version rsync version 3.0.6 ... (1 Reply)
Discussion started by: govindts
1 Replies

5. UNIX for Dummies Questions & Answers

grep -A switch not working correctly with -m

egrep -A 7 -m 2 -h 'Date:|Time:' *.html this is showing only 2 line after the context of the 2nd found match. Is this a bug in grep? egrep -A 7 -m 2 -h 'Time:' *.html - this works correctly (2 Replies)
Discussion started by: zer0
2 Replies

6. Programming

Shell Implementation not working correctly

//save in/out int tmpin = dup(0); int tmpout = dup(1); //set initial input int fdin; if(_inputFile) { fdin = open(_inputFile, O_RDONLY | O_CREAT, S_IREAD | S_IWRITE); } else { //use default input fdin = dup(tmpin); } int ret; int fdout; for(int i = 0; i... (14 Replies)
Discussion started by: AirBronto
14 Replies

7. Shell Programming and Scripting

Variable not working correctly.

Hi, I have a script where I am trying to set a local variable using the following, MYVAR="$NAME"_"$NAME2".txt where say, NAME = one NAME2 = two so I want the output one_two.txt but what I am getting is, two.txt basically the $NAME2 is overwriting, what am I doing wrong? ... (3 Replies)
Discussion started by: walsh_j
3 Replies

8. Shell Programming and Scripting

if not working correctly

Anyone have an idea why this if statement does not work correctly? "" 18 lines, 386 characters #!/usr/bin/sh WARNING=80 CRITICAL=95 check_it() { if ] || ];then echo "YES ] || ]" else echo "NO ] || ]" fi } check_it 80.1 check_it 81.1 (3 Replies)
Discussion started by: 2dumb
3 Replies

9. Shell Programming and Scripting

RegExp negative match not working

or I don't know how to make it work ... Hello im trying to build regexp that will match me single string or function call inside of brackets for example I have : <% myFunction("blah",foo) %> or <% myVar %> and not match : <% if(myFunction("blah",foo)==1) %> or <% while(myvar < 3){... (2 Replies)
Discussion started by: umen
2 Replies

10. UNIX for Dummies Questions & Answers

Script not working correctly

I have a simple script that I want to run every 30 minutes but only when I execute it. I don't want it to be a crontab job. so i have for example date ls -l who sleep 1800 The first time it executes correctly but after the first time it nevers execute back again. It should execute after... (2 Replies)
Discussion started by: elchalateco
2 Replies

Featured Tech Videos