[Solved] syslog not accepting remote messages?


 
Thread Tools Search this Thread
# 1  
[Solved] syslog not accepting remote messages?

Hi,

I created central syslog server, but it's not accepting the messages from remote. Not sure why I can't start the service with -r options? Please help.

Code:
[root@nylog01 init.d]# service syslog restart
Shutting down kernel logger:                               [  OK  ]
Shutting down system logger:                               [  OK  ]
Starting system logger:                                    [  OK  ]
Starting kernel logger:                                    [  OK  ]


Code:
 
ps aufx |grep syslog
root      4428  0.0  0.0  61216   744 pts/2    S+   16:05   0:00          \_ grep syslog
avahi     2896  0.0  0.0  27404  1412 ?        Ss   11:20   0:00 avahi-daemon: running [nylog01.local]root      4422  0.0  0.0  14364   856 ?        Ss   16:05   0:00 syslogd -m 0


cat /etc/init.d/syslog

Code:
 
#!/bin/bash
#
# syslog        Starts syslogd/klogd.
#
#
# chkconfig: 2345 12 88
# description: Syslog is the facility by which many daemons use to log \
# messages to various system log files.  It is a good idea to always \
# run syslog.
### BEGIN INIT INFO
# Provides: $syslog
### END INIT INFO
# Source function library.
. /etc/init.d/functions
RETVAL=0
start() {
        [ -x /sbin/syslogd ] || exit 5
        [ -x /sbin/klogd ] || exit 5
        # Source config
        if [ -f /etc/sysconfig/syslog ] ; then
                . /etc/sysconfig/syslog
        else
                SYSLOGD_OPTIONS="-m 0 -r "
                KLOGD_OPTIONS="-2"



On the syslog file I do have as -r but when I start it, it ignores the -r and keeps going to m options?

---------- Post updated at 05:39 PM ---------- Previous update was at 04:17 PM ----------

I found the answer. We need to update /etc/sysconfig/syslog

settings is

Code:
 
SYSLOGD_OPTIONS="-r "

# 2  
Thanks for the update
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Science: Mathematics
Difficulty: Medium
The proof for the Chinese Remainder Theorem used in Number Theory was NOT developed by its first publisher, Sun Tzu.
True or False?

9 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Syslog Messages from Remote Server are not writing to Log File Anymore

Hello All, Server: SUSE Linux Enterprise Server 11.3 (x86_64) Syslog-ng Version: syslog-ng 2.0.9 We have configured a Cisco router to send it's log messages to this server listed above. This has been working just perfectly for the last couple months, but we had never setup the log... (9 Replies)
Discussion started by: mrm5102
9 Replies

2. Linux

How to push Tomcat logs to remote syslog server?

I found a script for automatically push tomcat logs to syslog server which is locate in same server. How do I change it to push logs to remote server? log4j.rootLogger=INFO, WARN, console, file, SYSLOG log4j.appender.file=org.apache.log4j.RollingFileAppender log4j.appender.file.append=true... (2 Replies)
Discussion started by: heshandh
2 Replies

3. UNIX for Dummies Questions & Answers

[Solved] on remote server

Hi, on HP-UX what is the syntax for ls -l more tail -100 on a file which is on a remote server ? Thank you. Please use code tags next time for your code and data. (2 Replies)
Discussion started by: big123456
2 Replies

4. Red Hat

Remote syslog

CentOS 5.7, sysklogd 1.4.1-46 I added "-r" to /etc/sysconfig/syslog and restarted the syslog service. With tcpdump, I can see that other devices are sending traffic to UDP 514, but nothing is showing up in /var/log/messages, which is where Googling suggests they'll end up without changing... (2 Replies)
Discussion started by: jnojr
2 Replies

5. Shell Programming and Scripting

[Solved] Know the existance of a file on remote server

In a Korn shell, I want to test whether a file exists on a remote shell. If I use ssh <Remote server> ls abc It gives file proper result, but unable to capture in the script. Any help? Thanks Please use next time code tags for your code and data (3 Replies)
Discussion started by: Soham
3 Replies

6. UNIX for Dummies Questions & Answers

chmod on a remote server -solved

hello, I am trying to copy a file over to a set of aix servers and then set the file permissions, owner, group etc and all of this logged in as sudo. I was able to copy the file over using rcp - i know its not secure or not best way to copy - but unable to execute chmod on the remote server as... (0 Replies)
Discussion started by: in5ane
0 Replies

7. AIX

Forwarding AIX syslog/errorlog to remote SQL DB

Due to a project I'm currently tasked with I'm spending my time trying to find a way to forward the syslog to a remote, in this case Red Hat, server and squeezing it into a SQL DB. Rsyslog is doing this job quite nicely for most of our test-servers, but I couldn't find any reliable information on... (1 Reply)
Discussion started by: Skleindl
1 Replies

8. Shell Programming and Scripting

Accepting A-Za-Z

Is there a way accept A-Za-z0-9 from the user from a parameter? EX. I want to take the parameter from the user even if its hEu or H3y and store it as a parameter ( $1 ) (18 Replies)
Discussion started by: puttster
18 Replies

9. UNIX for Dummies Questions & Answers

Why can't I send messages to a remote domain

Hi there, I rent two servers hosted by the same provider: OVH. On server1, I use the mail command to send alert emails to my personal address and it works fine. On server2, which is newly instaled, I tried the following command and got this answer: Is there any other package that I need to... (2 Replies)
Discussion started by: chebarbudo
2 Replies

Featured Tech Videos