Unable to reduce the size of volume group?


 
Thread Tools Search this Thread
# 15  
Quote:
Originally Posted by frappa
Sorry, I meant
Code:
parted /dev/xvdb1 unit s print
parted /dev/xvdb5 unit s print

Code:
# parted /dev/xvdb1 unit s print
Error: Can't have a partition outside the disk!
Information: Don't forget to update /etc/fstab, if necessary.

# parted /dev/xvdb5 unit s print
Error: Unable to open /dev/xvdb5 - unrecognised disk label.
Information: Don't forget to update /etc/fstab, if necessary.

# 16  
Hi pinga123,

it seems like it's time to start playing with fdisk (a useful but dangerous utility), but I *strongly* advise you to do further operations only on a clone system, not the original one (don't know oracle vm, but I think it gives you the chance to create a clone system in some way).

The concept is that, with partitions on /dev/xvdb unmounted and lvm turned off, the current partitions on the disk may be deleted and recreated with the correct cylinder end value.
There's a similar procedure showed on 'http://justlinux.com/forum/archive/index.php/t-147711.html'.

I never tried such a thing by myself, so I have no tested procedures or assurance of success, that's why I advise you to operate on cloned machines to see what happens.

Maybe some other user in the forum may have some insightful suggestions.

see ya
fra
# 17  
In your situation the only sensible quick approach was to create new smaller Logical Volumes then format and mount them, then copy your data to the new LVs, and then umount and remove the old LVs and adjust fstab to match the new arrangement.

Personally I would have used a backup device and made two independent backups of my data partitions before reformatting the PV to the new arrangement and restoring the backup.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

10 More Discussions You Might Find Interesting

1. Red Hat

Shrink ext4 filesystem and reduce the size of a Logical Volume in Linux

Hello guys, I would like to ask you kindly if you don't know some quick and safe method how to shrink ext4 filesystem and reduce the size of a Logical Volume in Linux, please? Thank you very much. (2 Replies)
Discussion started by: los_bandidos
2 Replies

2. AIX

Restvg does not assign the correct PP size to volume group

hello, i am running an AIX6.1 machine and i am trying to restore a volume group that i backed up using mkvgdata command from another server. although i checked file .data and i make sure that PP size for this volume group is 128, when i run restvg command to restore it, it fails because it... (2 Replies)
Discussion started by: omonoiatis9
2 Replies

3. AIX

/usr/sbin/extendvg: Unable to extend volume group

Dear Expret, Help me about my issue, I trying add new disk to volume Group but error: step add new disk to volume group. 1. ~Change a Volume Group Add a Physical Volume to a Volume Group Remove a Physical Volume from a Volume Group Reorganize a Volume Group... (6 Replies)
Discussion started by: williamen
6 Replies

4. AIX

Unable to extend volume group(VG)

Would some help me on this below I am trying to extend file system on AIX and however unable to extend the file system. 0516-306 extendvg: Unable to find physical volume 20 in the Device Configuration Database. 0516-321 extendvg: Physical volume u01-lv is not configured. 0516-792... (15 Replies)
Discussion started by: murali969
15 Replies

5. HP-UX

Increase Size of a Volume Group

Hi I have hp-ux 10.20 I have have my operating system VG of 7 GB in a 36Gb disk. So I have like 29GB of unused disk space. There is any way to increase my VG size, or to add another VG in the same disk so I can use all the disk space? Another question, what is the maximun size that a VG can ... (10 Replies)
Discussion started by: pmoren
10 Replies

6. UNIX for Dummies Questions & Answers

Unable to deactivate a Volume Group

We want to deactivate a VG but failed, because one of the LVs created there is busy. When we are trying to unmount the LV, it is telling "not mounted" and if I execute mount command it will be informing us "already mounted". dmsetup info is indicating "Open Count = 1". Please help me, how we... (5 Replies)
Discussion started by: atanubanerji
5 Replies

7. AIX

Volume Group - PP Size

Hi Friends- We know that the Max PP size in a Normal VG and Big VG is 1 GB and in case of scalable VG it is 128 G. My Questions: 1) What is the min PP size allowed for Normal VG, Big VG and Scalable VG? 2) Why is the max PP Size in Normal and Big VG is 1 G and 128 G in... (1 Reply)
Discussion started by: deshaipet
1 Replies

8. AIX

Volume Group Size

Hello, Can somebody please help. I'm able to view volume groups by using the command "lsvg", how can I view what space is available to that particular volume group Many Thanks (3 Replies)
Discussion started by: ugxd14
3 Replies

9. Solaris

How to reduce the size of a logical volume in solaris 9

Hi, I have the following problem. I just have a new machine with mirroring. The logical volume for /opt is dimensionned to 75 GB which is to much. I want a volume of 10 GB. How can I reduce the size ? I tried to reduce the size of the slice from 75 GB to 10 GB, but the size of the logical volume... (6 Replies)
Discussion started by: aribault
6 Replies

10. UNIX for Advanced & Expert Users

How to check size of Volume Group

Did anyone knows how to check size/usage of a Volume Group in AIX 4.3.3? (4 Replies)
Discussion started by: s_aamir
4 Replies

Featured Tech Videos