Stop the process

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Stop the process
# 1  
Old 11-10-2011
Stop the process

I have the following log file running since yesterday and its consuming so much of the disk space.
-rw-rw-r-- 1 dev dba 4543237120 Nov 10 09:00 load_run_file1_0.1111091224.lg

How do i kill this process. I don't have any idea of stopping this. Any help would be really appreciated.


---------- Post updated at 09:11 AM ---------- Previous update was at 09:03 AM ----------

As a result, whenever am checking the logs of the other files. All i see is the 0 byte files. Please find the list of the log files below:
-rw-rw-r-- 1 dev dba 0 Nov 10 09:00 load_file2_0.1111100900.lg
-rw-rw-r-- 1 dev dba 0 Nov 10 09:06 LOAD_file2_6017.lg

Does the process which was running since yesterday causing the other files from mal-functioning . Please shed some light on this.


Moderator's Comments:
Mod Comment Final reminder to use code tags. The next time you log in you will be asked to accept the rules again.

Last edited by Scott; 11-10-2011 at 10:30 AM.. Reason: Code tags
# 2  
Old 11-10-2011
If you're out of space, maybe.

Have you tried truncating the big log file?

: > /path/to/hugefile

Don't delete it, do that.
# 3  
Old 11-10-2011
May be am running out of space..
ksh: /usr/bin/1234/load_run_file1_0.1111091224.lg: cannot execute

Last edited by bobby1015; 11-10-2011 at 11:15 AM..
This User Gave Thanks to bobby1015 For This Post:
# 4  
Old 11-10-2011
Copy and paste the entire line in the codeblock of Coronas post. The first characters are not some prompt but the "commands" that do the truncate.
Login or Register to Ask a Question

Previous Thread | Next Thread

8 More Discussions You Might Find Interesting

1. Red Hat

Can't stop/restart postfix - pid associated with another process

This issue could happen to any other service but in this case its commssioning Postfix - it seems i can't stop postfix as the PID relates to another service - i've delete the 'master.lock' but to no available - any ideas, memeory commands etc ? thanks in advance ps. the serve is in Production so... (2 Replies)
Discussion started by: stevie_velvet
2 Replies

2. UNIX for Dummies Questions & Answers

How to stop debug in the mid of process?

Hi Gurus, I am debugging a script. it loops filelist. since the list a very long. when debugging, I only can see the last a few lines. is there any way to stop debuger in the mid of process. the command I used for debugging is: ksh -x scriptName Thanks in advance (7 Replies)
Discussion started by: ken6503
7 Replies

3. Shell Programming and Scripting

Stop and start a process every X hours

Hi, I have a parallelized Mathematica program that spans across 8 MathKernels processes running at 100% and one MathKernel (highlighted in blue) running at < 10% that controls the other 8. They look like this on the cluster: (2 Replies)
Discussion started by: giovform
2 Replies

4. Shell Programming and Scripting

How to stop the process in shell scripting?

Hi all, I have tried the below code to execute. #! /bin/bash date1=`date -d "today 08:00:00" +%s` date2=`date -d "today 08:01:00" +%s` path=/home/user01/red/IDC/sample cd $path java Cspsamp 7025 rd1 rd1 "5022=Query|5026=109378|4=627|5=E:VD|5042=$date1|5049=$date2"... (5 Replies)
Discussion started by: aish11
5 Replies

5. Shell Programming and Scripting

Process running? Stop it

I have this "process keepalive" script: #!/bin/bash PIDFILE=/tmp/ PHPSCRIPT=/home/www/ echo 'Checking php process from PID file' if ; then PID=`cat $PIDFILE` if ps ax | grep -v grep | grep $PID > /dev/null then echo "php process still... (4 Replies)
Discussion started by: LukasB
4 Replies

6. Shell Programming and Scripting

how to stop the process that is running continously

Hi there, I have written a script to check daily process, each script is in a different directory. Now the first process is running fine, when it goes to the next directory the process doesn't executes. cd result/logs ref=month_1888.log echo $ref>> $logfile cd /max/tot/first... (3 Replies)
Discussion started by: NehaKrish
3 Replies

7. AIX

a process that never stop

Dears all i have an AIX box in which i am facing a problem with a process as below: /usr/dt/bin/dtexec -open 0 -ttprocid and each time i am killing this process with "kill -9" then it run again after a while. any ideas or solutions will be appreciated. (13 Replies)
Discussion started by: TheEngineer
13 Replies

8. Shell Programming and Scripting

Stop / kill the process individually

Hi , I have a situation, where I have 10 indivudal processess started by similar instance.I say similar instance because each of them being started as a new thread: Say I've following unix process running process1_ADAP process2_ADAP process3_ADAP Current scenario: Now I have SHUTDOWN... (5 Replies)
Discussion started by: braindrain
5 Replies
Login or Register to Ask a Question

Featured Tech Videos