SSH from MacOS X or PPC Debian to SUSE # Odd terminal chars # Eventual scripting

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers SSH from MacOS X or PPC Debian to SUSE # Odd terminal chars # Eventual scripting
# 1  
Old 11-04-2011
SSH from MacOS X or PPC Debian to SUSE # Odd terminal chars # Eventual scripting

Well. I was recently given access to my work's machine via SSH. I'm pretty sure it's a SUSE machine, uname -a gives
Linux machinename #1 SMP Fri Sep 4 01:28:03 UTC 2009 i686 i686 i386 GNU/Linux

I'm not doing anything all that exciting, mostly data entry stuff.

We connect to the machine from inside the office using PowerTerm which I would prefer not to use if I can help it. In PowerTerm we specify the terminal type to be SCO-ANSI but all other settings (port numbers, security type, etc) appear to be ones that I am used to seeing.

When I connect via SSH using iTerm, Apple's Terminal/X11, or Debian's terminal I get odd behavior like the screen not refreshing and keyboard mismatching-- eg if I type "05" the screen will echo " =14;12C=10;12C"

The actual program I am using on the remote machine is written in COBOL. Behavior outside of the program in question appears to be normal, eg I can use standard UNIX commands and keyboard translation is normal. I have access to the usual home documents like .profile and .bashrc

I would eventually like to script some of the more mundane tasks but first is there something I can do to fix the keyboard issues?
# 2  
Old 11-14-2011
I haven't made much progress on this. The X11 that comes installed on Mac OS X 10.6.8 seems to work the best, but there is what looks like a line break mismatch. I have tried
export TERM=scoansi

But it didn't seem to change anything. Any thoughts?
# 3  
Old 11-14-2011

For most Linux boxes, you should be able to find out what it is with:
cat /etc/issue

which produces on an SuSE machine:
Welcome to openSUSE 11.4 "Celadon" - Kernel \r (\l).

Are you entering "05" from the keyboard or the keypad ?

cheers, drl
# 4  
Old 11-14-2011
OK thanks.
cat /etc/issue

Welcome to SUSE Linux Enterprise Server 10 SP3 (i586) - Kernel \r (\l).

The keypress transliteration thing only happens when connecting with iTerm or Debian terminal and it is not a keypad press. The line break thing seems to be in all cases.
# 5  
Old 11-14-2011

The most common problem I run into is "locale". I set mine to "C". For example:


I use Gnome terminal:
gnome-terminal GNOME Terminal 2.30.2

and, between that and the locale setting above I generally have no trouble with chararacter sets -- even to HP and AIX boxes ... cheers, drl
# 6  
Old 11-14-2011


What does "C" mean?

---------- Post updated at 04:53 PM ---------- Previous update was at 04:47 PM ----------

So the usual sequence of events is this:
Open X11, iTerm, PowerTerm, etc
export TERM=scoansi


Code:> programname

Is that correct? I can't imagine I'd set my TERM after logging in right? Just making sure.
# 7  
Old 11-14-2011
Originally Posted by pagrus
What does "C" mean?
See The GNU C Library - Locales and Internationalization for a brief explanation.

For TERM settings I use TERM=vt100, because that is a very "vanilla" setting. What is the reason you use scoansi ?

cheers, drl
Login or Register to Ask a Question

Previous Thread | Next Thread

7 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Shell script to split data with a delimiter having chars and special chars

Hi Team, I have a file a1.txt with data as follows. dfjakjf...asdfkasj</EnableQuotedIDs><SQL><SelectStatement modified='1' type='string'><! The delimiter string: <SelectStatement modified='1' type='string'><! dlm="<SelectStatement modified='1' type='string'><! The above command is... (7 Replies)
Discussion started by: kmanivan82
7 Replies

2. Shell Programming and Scripting

Terminal running bash/rsync script does not close with exit (MacOS High SIerra)

Hello, I am running a bash script to do an rsync back on a computer running MacOS High Sierra. This is the script I am using, #!/bin/bash # main backup location, trailing slash included backup_loc="/Volumes/Archive_Volume/00_macos_backup/" # generic backup function function backup {... (12 Replies)
Discussion started by: LMHmedchem
12 Replies

3. Shell Programming and Scripting

shell scripting to determine special chars in file

Hi, I need all your help to achieve the below functionality. I have a big 2 GB file and inside the file we need to identify, whether having a comma(,) or pipe(|) or tab or fixed position or semicolon(;) delimiter. If any of those delimiter found need to replace the file with pipe(|)... (1 Reply)
Discussion started by: lkeswar
1 Replies

4. Debian

How to exit debian server terminal?

I have an situation that are quite strange to me. I am not able to exit the server terminal and enter back into my home computer terminal by the command exit like I used to be able to exit the server terminal with before. I end up into my root shell again without even typing the root password like... (6 Replies)
Discussion started by: Jonathan Sander
6 Replies

5. SuSE

SFTP with Suse 9.3 need help with Update ssh

Hi eryone, I'm new here. Since I'm a graphic designer and not an admin, I need to learn a lot from the first step, so please be patient with me. ;-) Most of my skills are self taught with howtos, so there might be some lack of wisdom in basics. I've setup a Suse-System (9.3) with a few upload... (3 Replies)
Discussion started by: rezent
3 Replies

6. Programming

is it SUSE or RHEL or Debian. How to detect programmatically?

Hi Gurus, I want to programmatically detect what Linux flavour I have in my m/c, detailed OS-name and its version, e.g. is it RHEL, SUSE, Debian etc. ---------------------------------------------------------------- Flavour OS-Nname version... (4 Replies)
Discussion started by: krishnamurthig
4 Replies

7. Shell Programming and Scripting

Help with scripting APT / dpkg in Debian 4

Hello, I am attempting to write a (bash) shell script that will do some basic reporting based on the APT utilities and dpkg. I need the following in the report: Packages installed (COLUMNS=200 dpkg -l | grep '/^ii/' > packages_installed) Packages not installed I suppose that I can do ... (0 Replies)
Discussion started by: orspain
0 Replies
Login or Register to Ask a Question

Featured Tech Videos