Visit Our UNIX and Linux User Community


setserial not working on linux running on Beagleboard (ARM development board)


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers setserial not working on linux running on Beagleboard (ARM development board)
# 1  
Old 10-30-2011
setserial not working on linux running on Beagleboard (ARM development board)

Hi,

I'm trying to develop an application to work with serial infra-red module, but I'm having difficulties to even get my module started. My HW is Beagleboard, which has 1 UART serial port, normally used for console, which I have disabled (I re-created the boot.scr, without the console arguments), and I have modified the getty config, not to try to attach to ttyO2.
On 3.x omap kernels, the serial port is now called ttyOx instead of ttySx, though I guess that doesn't really matter ? I guess the port and irq are the most important things..

During boot, I can see following information regarding the configuration:
Code:
[    0.000000] Kernel command line: console=tty0 root=/dev/mmcblk0p2 rootwait ro vram=12MB omapfb.mode=dvi:1280x720MR-16@60 fixrtc buddy=none mpurate=auto
[    0.000000] console [tty0] enabled
[    0.768524] omap_uart.0: ttyO0 at MMIO 0x4806a000 (irq = 72) is a OMAP UART0
[    0.768768] omap_uart.1: ttyO1 at MMIO 0x4806c000 (irq = 73) is a OMAP UART1
[    0.769012] omap_uart.2: ttyO2 at MMIO 0x49020000 (irq = 74) is a OMAP UART2
[    0.769226] omap_uart.3: ttyO3 at MMIO 0x49042000 (irq = 80) is a OMAP UART3

When system tries to load the lirc module (for infra-red) I get this
complain about IRQ being busy:
Code:
[   12.396392] lirc_serial: IRQ 74 busy

Now, I'm not sure now why that is still happening, as I think nobody should be connected to ttyO2 anymore. But anyway, around internet people say I should release the UART manually, and I try it with setserial, with strange reply:
Code:
ubuntu@omap:/etc$ sudo setserial /dev/ttyO2 uart none
Cannot set serial info: Invalid argument

If I try without sudo, I get "Permission denied"

Also strangely, when I try to look at the port status:
Code:
ubuntu@omap:/etc$ sudo setserial -g /dev/ttyO[0-3]
/dev/ttyO0, UART: undefined, Port: 0x0000, IRQ: 72
/dev/ttyO1, UART: undefined, Port: 0x0000, IRQ: 73
/dev/ttyO2, UART: undefined, Port: 0x0000, IRQ: 74
/dev/ttyO3, UART: undefined, Port: 0x0000, IRQ: 80

Shoudn't there be something in those port addresses ?
Does it matter that "MMIO" is used ? Normally IO port seems to be indeed 0x**** format, now the address for serial port is much higher (0x********)

Any ideas how I should proceed ?

Last edited by julumme; 10-30-2011 at 11:16 AM.. Reason: -
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #1002
Difficulty: Medium
During her lifetime, Grace Hopper was awarded over 100 honorary degrees from universities across the world for her work in computer science.
True or False?

9 More Discussions You Might Find Interesting

1. Programming

IDE's for the ARM processor on Linux

Hello everyone. I am running Debian on an ARM7 Device (aka my android phone). Everything is great. Works well. I would love to use it for Development. Mainly my interests are in Web Development, and Java development. So far the only useful IDE for debian arm is Netbeans. Which is pretty... (0 Replies)
Discussion started by: CDevelop
0 Replies

2. Hardware

Xenomai On ARM board EXYNOS 4210 ODROID-PC

Hi I am trying to port xenomai on exynos 4210 arm board. With some research I have found a way to port the board on the exynos board but the problem is that on the exynos-4210 website they have provided a patched version of linux-3.0.15 kernel for implementing on the board. On this kernel I am... (1 Reply)
Discussion started by: mohitjandwani
1 Replies

3. Programming

Running c code in ARM QEMU

I created and Compiled a C program to run in QEMU for ARM. When I run the program using the command #qemu-arm -L /home/arm-2010.09/arm-none-linux-gnueabi/libc ./test it gives me the following error: If 'qemu-arm' is not a typo you can use command-not-found to lookup the package that contains... (0 Replies)
Discussion started by: rupeshkp728
0 Replies

4. What is on Your Mind?

Raspberry Pi - An ARM GNU/Linux box for $25. Take a byte!

Raspberry Pi An ARM GNU/Linux box for $25. Take a byte! FAQs What's a Raspberry Pi? The Raspberry Pi is a credit-card sized computer that plugs into your TV and a keyboard. It's a capable little PC which can be used for many of the things that your desktop PC does, like spreadsheets,... (5 Replies)
Discussion started by: Neo
5 Replies

5. UNIX for Advanced & Expert Users

Trace "free(): invalid next size (normal)" error on arm-linux board

Hi guys, i'm running a program on samsumg 6410 arm cpu board. it caused an "free(): invalid next size (normal)" fail. i try to use gdb for remote debugging: 1, start gdb server on board: gdbserver 192.168.1.20:1234 ./HostAP Process ./HostAP created; pid = 499 Listening on port... (8 Replies)
Discussion started by: ss1969
8 Replies

6. Programming

When a process is down - how to get a coredump in arm board?

Running a multi-threaded program in my arm board one day or more ,The process down . In order to get a coredump to analysis of the stack , . I use commands ulimited -c unlimited . but when the process down . no coredump But I write a test #include <stdio.h> int main(void){ ... (14 Replies)
Discussion started by: aobai
14 Replies

7. Linux

How to drive a LCD on ARM based linux System

Hello sir, I am Vijay Manohar. I am a writing a device driver for LCD frame buffer device. In this , LCD has been mapped at physical address 0x3000000. Now I want to implement mmap entry point. I have two questions regarding this Can I use this physical address as one of the parameters to... (0 Replies)
Discussion started by: VijayManohar
0 Replies

8. Linux

jsp not working on linux running tomcat server

hey there we cant seem to get jsp to load pages properly on linux running tomcat 4 server. everytime we run .jsp files, the source code comes up instead of the actual file contents. any suggestions?? cheers mile1982 (1 Reply)
Discussion started by: mile1982
1 Replies

9. Linux Benchmarks

P4 2.6C Asus P4C800 M/board on Gentoo Linux

Here is my bench result. I also have a suspect file-copy result (giving me an index of 0.0) which would significantly drop the overall average. Anyway, if someone comes up with a reason as to why this may be, please let me know. Notes ... (0 Replies)
Discussion started by: greg32
0 Replies

Featured Tech Videos