trying to remove a directory on my usb drive connected to my mbpro

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers trying to remove a directory on my usb drive connected to my mbpro
# 1  
Old 09-29-2011
trying to remove a directory on my usb drive connected to my mbpro

I have a mbpro that has my backup drive (a usb drive) and I've put some directories into the trash folder on it. I'm trying to remove the directory with the rm -r command. When I do that, I get this asking me this:

override rwxrwxrwx [filename]

(It's a keynote directory that has some fonts that were downloaded from some site).

I tried answering 'yes' or 'y' but when I try just 'y' I get an error message, and when I try "yes" i get a loop if the letter 'y' down the left side of the screen. Can someone tell me what's going on and what I can do to just delete these files from my usb drive?
# 2  
Old 09-29-2011
Please check how is usb drive mounted (read-write, read-only?), mount will tell you that.
Are you deleting those as root or user ? What is the ownership of files you are trying to delete ?
Have you tried -f option with rm ?
# 3  
Old 09-29-2011
It would be helpful if you post the exact command and the output from the Terminal application.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

Usb external drive

Hi Guys I am using RHEL5 O/S. We have mounted the usb external hard drive to the server as root. I want the user oracle to be able to write into this external hard drive. How do i do that ? Please Help!!! (1 Reply)
Discussion started by: Phuti
1 Replies

2. Shell Programming and Scripting

Unix server to Hard-drive connected on the machine

Hi, I have an external hard drive connected to my iMac. I am logged into a Linux_x86_64 server. Now, if I want to download files directly to the hard drive, is there a way to do it. Currently, I am chasing cyberduck to download content to the hard drive. (3 Replies)
Discussion started by: jacobs.smith
3 Replies

3. Red Hat

USB drive going offline

Hello all, I have a USB drive mounted on a linux RHEL 4 server which goes offline every now n then. Here are some logs : --------------------------------------------- # lsusb Bus 005 Device 001: ID 0000:0000 Bus 004 Device 001: ID 0000:0000 Bus 003 Device 001: ID 0000:0000 Bus 002... (1 Reply)
Discussion started by: sunny_a_j
1 Replies

4. Solaris

USB Drive for Solaris

I have a T2000 server running solaris 10, it has 4 USB ports. I want to extend the storage capacity by attaching an external USB drive and mounting it as an other mount point. How do I do that, the following link gives information about USB in Solaris OS, ... (1 Reply)
Discussion started by: Tirmazi
1 Replies

5. AIX

How to mksysb to a tape drive connected to a different LPAR?

I have 2 LPARs running AIX 5.3. Both are on the same VLAN. One LPAR, which I'll call LPAR2, has a 4mm SCSI tape drive connected to it, while LPAR1 does not have a tape drive connected. I am able to take mksysb backups of LPAR2 to the tape drive since it's directly connected. However, I need to... (2 Replies)
Discussion started by: need2bageek
2 Replies

6. Filesystems, Disks and Memory

Cannot use USB diskette drive

I would be extremely grateful for any help on the following matter. Under AIX 5.1 and for years I have been using perfectly well a USB 3.5" disketted drive. But since yesterday, after a power failure disconnected my e-server, I have been unable to use the drive. Whatever <operation> I try to... (0 Replies)
Discussion started by: ahjchr
0 Replies

7. Solaris

mounting usb drive

hi, first of all, i would really like to know how to find out where my usb is in the system. if i "cd to /dev/usb i have a hub0 to hub4 and hid0 -- hid5 .. how do i know where my usb is? and i guess once i find out which one my usb is at, i can do something like "mount /dev/usb/xxx /tmp" ... (5 Replies)
Discussion started by: k2k
5 Replies

8. SCO

mounting USB floppy drive /Flash drive in OSR 6.0

Can anybody help me out to mount USB flash /floppy drive in sco openserver 6.0 . (5 Replies)
Discussion started by: sureshdrajan
5 Replies

9. Solaris

USB flash Drive

Hello all.. I have a Verbatim 2 GB flash drive. I also have Solaris 10 running on my workstation. If I am in the Windows environment, it detects the flash drive. But when I plug it while I am in solaris, nothing happens. How will solaris 10 detect my flash drive? What do I have to do? any... (4 Replies)
Discussion started by: vr76413
4 Replies

10. Filesystems, Disks and Memory

Tape Drive Connected to a Sun Ultra 10/Solaris 2.7

I have a Sun Ultra 10/Solaris 2.7 with a differential SCSI card connected to a Supter DLt1 Tape Drive. When I boot the machine, and I do a probe-scsi-all in the very beginning of the boot process. It shows up correctly. If I wait for the boot process to proceed and then I do a probe-scsi-all, I get... (1 Reply)
Discussion started by: brv
1 Replies
Login or Register to Ask a Question