-atime not working as expected

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers -atime not working as expected
# 8  
Old 09-29-2011
The files themselves were not accessed (opened). I used finder to navigate to the folder then selected each file to see the details... is that changing the atime? That would mean folder access changes contained files access time...?
# 9  
Old 09-30-2011
Reference post #1. You should be using "-mtime" which references the same timestamp as "ls -l".

As others imply, the "-atime" timestamp is rarely of any use because it can be changed by backup software or by the very action of searching.
# 10  
Old 09-30-2011
$ find . -type f -mtime 20 -exec ls -ltr {} \;

# 11  
Old 09-30-2011
Originally Posted by canon273
The files themselves were not accessed (opened).
Clearly, something did access them. You saw their atimes yourself, when you did ls -lu.

For the third time: finder is known to mess up atimes. It does it when it indexes the system, not just when you browse. If you want to use atimes, you'll have to tell finder not to index those files.

Your script is not finding those files because their atimes are very, very recent. YOu can see their atimes yourself in one of your own posts.

Originally Posted by Methyl
Reference post #1. You should be using "-mtime" which references the same timestamp as "ls -l".
He states clearly in his OP that he's looking for the time a file was last read and not the time it was last modified.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

awk gsub not working as expected

Hi Experts, Need your kind help with gsub awk. Below is my pattern:"exec=1_host_cnt=100_dup=4_NameTag=targetSrv_500.csv","'20171122112948"," 100"," 1"," 1"," 4","400","","", " aac sample exec ""hostname=XXXXX commandline='timeout 10 openssl speed -multi 2 ; exit 0'"" ","-1","-1","1","... (6 Replies)
Discussion started by: pradyumnajpn10
6 Replies

2. UNIX for Advanced & Expert Users

Test -e not working as expected (by me)

I ran into the following and still do not understand entirely the rationale behind this. If someone could explain why things are as they are I'd be thankful. The following was tested on AIX 7.1 with ksh88, but i suspect that to be ubiquitous. In an installation routine i had to create a set of... (6 Replies)
Discussion started by: bakunin
6 Replies

3. Shell Programming and Scripting

Script not working as expected

Hi, I have prepared a script and trying to execute it but not getting expected output. Could you please help and advise what is going wrong. "If else" part in below script is not working basically. I am running it on HP-UX. for i in slpd puma sfmdb do echo "******\t$i\t*******" echo... (10 Replies)
Discussion started by: sv0081493
10 Replies

4. UNIX for Dummies Questions & Answers

Nohup not working as expected

Hi. I am trying to start a script on my router that will execute even if i log off. To execute the script I write: nohup ./dslconnection > dslstat.out 2>&1 & It starts the job: 21968 admin 1604 S /bin/ash ./dslconnection The problem is that when I log back in the job has been... (6 Replies)
Discussion started by: sebcou
6 Replies

5. Shell Programming and Scripting

echo is not working as expected

for i in `cat /export/home/afahmed/Arrvial_time.txt` do echo $i echo $i | awk '$3 < $D { print $4 }' >> dynamic_DF.txt; done When i echo, its echo as Nov 15 02:24 /export/home/pp_adm/inbound//wwallet_20111115.txt where i expect it to be Nov 15 02:24... (7 Replies)
Discussion started by: afahmed
7 Replies

6. Shell Programming and Scripting

Why this is not working in expected way?

total=0 seq 1 5 | while read i ; do total=$(($total+$i)) echo $total done echo $totalThis outputs: 1 3 6 10 15 0whereas I am expecting: 1 3 6 10 15 15My bash version: (4 Replies)
Discussion started by: meharo
4 Replies

7. Red Hat

FTP on Linux is not working as expected

Hi, I need to write a Linux shell script which will perform an FTP operation to another server. main.sh will contain - ftp -nd Dest.IP.address < ftpScript.sh Contents of ftpScript.sh is given below - user userid passwd prompt lcd /vidya/Input cd vidya/Output mput *.* close ... (1 Reply)
Discussion started by: vidyak
1 Replies

8. UNIX for Dummies Questions & Answers

Redirection not working as expected

Portion of my script below : if ; then NUMBEROFFEILDS=`cat ${BASE_SCRIPT_LOC}/standardfilecleanup.lst|grep -w ${db_file_path}|awk -F: '{print NF}'` COUNT=4 while ; do awk_var="$"`echo $COUNT` file_name1=`cat ${BASE_SCRIPT_LOC}/standardfilecleanup.lst|grep -w... (1 Reply)
Discussion started by: findprakash
1 Replies

9. Shell Programming and Scripting

ls not working as expected within ksh

Hi, I use the command ls a\b\c\*.txt from the command line on HP UNIX and it works fine - It lists all files matching *.txt in the a\b\c directory When embeded in a ksh script `ls a\b\c\*.txt` it does not work - I get *.txt not found (even though there are files) I tried... (10 Replies)
Discussion started by: GNMIKE
10 Replies

10. Shell Programming and Scripting

which not working as expected

Hello. Consider the following magic words: # ls `which adduser` ls: /usr/sbin/adduser: No such file or directory # Hmmm... Then: # ls /usr/sbin/adduser /usr/sbin/adduser # Now what? Unforunately this little sniippet is used in my debian woody server's mysql pre install script.... (2 Replies)
Discussion started by: osee
2 Replies
Login or Register to Ask a Question