Linux server not showing the GCC

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Linux server not showing the GCC
# 1  
Old 09-28-2011
Linux server not showing the GCC


How can gcc is missing in linux ?i think we dont need to install it separately , can anyone please clarify

when i issue a gcc command my terminal displays

"If 'gcc' is not a typo you can run the following command to lookup the package that contains the binary:
command-not-found gcc
bash: gcc: command not found "

but cat /proc/version displays (gcc version 4.3.4 [gcc-4_3-branch revision 152973]

i have checked /usr/bin for gcc but nothing listed ,is there any path to set for gcc
# 2  
Old 09-28-2011
Most distributions don't install gcc by default. What you're seeing in /proc/version is the compiler and version the kernel was built with, which doesn't mean that the same compiler is installed on your system.
This User Gave Thanks to pludi For This Post:
# 3  
Old 09-28-2011
thanks pludi. i was in wrong assumption
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Server showing high Sys% CPU usage

Hi Fellas, Not sure how I can dig in even further but we notice that one of our DB servers is showing high Sys% CPU usage even though when I execute the following command : I can see that postgres is the only one using the CPU. So if anyone can advise me what would be the best way to... (3 Replies)
Discussion started by: arizah
3 Replies

2. AIX

VSwitch not showing up on VIO Server

Want to run this by you all before opening a PMR with IBM Support. It's been a few weeks since I have done this so I can't be 100% sure of how I think it worked in the previous version. We upgraded our HMC's yesterday to 7.7.9 SP2 in hopes of fixing some issues we were having. Today I needed... (4 Replies)
Discussion started by: juredd1
4 Replies

3. HP-UX

HP-UX server showing high memory utilization

Hi All, I am using HP-UX 11i v1(B11.11) servers for my work and its memory (RAM) utilization is consistenly 80% for the last one year. Though I am not facing any issues with this high memory utilization I just want to know the below queries: 1) Is it the default behavior of HP-UX systems? 2)... (20 Replies)
Discussion started by: ssk250
20 Replies

4. Red Hat

Not showing ifcfg eth0....redhat enterprise Linux 6.2

Hello, I'm using dell inspiron 14R laptop and I installed Redhat enterprise 6.2 on this. After successfully installation i did not found any network interface on this. when i'm trying to load/add qeth driver . The driver is not found showing this message. Bash: lsmod | grep qeth Bash:... (4 Replies)
Discussion started by: dearsumon
4 Replies

5. Red Hat

Server uptime is showing 0hr but server not rebooted

Hi One of our server is showing the uptime 0hr 5mints there is no log in /var/log/messages there is no log in command "last" kernel version is 2.4.9 (RH2.1 AS) What could be the reason for this. is this issue is related to uptime counter reached max how to verify this. Best Regards KVK (4 Replies)
Discussion started by: venikathir
4 Replies

6. Red Hat

User unable to login to the server, Showing blank screen

Hi All, Facing the login problem. i try to login to the system by the normal user. But when i logged in with the correct username and password, it takes me to the blank (black screen) screen instead of the command line prompt. Only the cursor is blinking ... Please help me out what is... (3 Replies)
Discussion started by: abhay1983
3 Replies

7. UNIX for Dummies Questions & Answers

Why Linux is not showing file in use ?

Hi i have written a infinite loop which writes to a file log.txt while do echo " file in use " >> log.txt done i have started this process in one terminal , from another terminal i issued cp command cp log.txt log2.txt i was expecting a File in use message but didnt ? i have... (6 Replies)
Discussion started by: rakeshkumar
6 Replies

8. Programming

GCC Compiler for SCO Open Server 5.0.7

If only SCO UNIX was as easy as Debian :mad: I intend to compile some c scripts but realized that I hadn't installed GCC on my SCO UNIX, after trying to install the package from a CD (Development Kit) and failing (Something to do with the License) ... I decided to download a Media image from... (2 Replies)
Discussion started by: itmon
2 Replies

9. SuSE

Linux gcc

Hi all, I am trying to create 64-bit shared libraries on Power PC "ppc64" architecture SuSe Linux 10 machine using gcc compiler. I am using "-m64" as an option for gcc to create 64-bit libraries which needs pam module. As we specify -m64 the compiler should look for all 64-bit... (0 Replies)
Discussion started by: vyshu2112
0 Replies

10. Linux

Linux GCC

Ok, i got a problem... I am trying to get the preinstalled Gcc running on my redhat linux 9 from The problem is, gcc wont load or sumthin I cannot seem to get it running from "run program" in the menu. I also tried to check /usr/bin to see if it was even there.... Seems like it... (7 Replies)
Discussion started by: gearshifter
7 Replies
Login or Register to Ask a Question