Visit The New, Modern Unix Linux Community

TFTP setup

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers TFTP setup
# 1  

ok, I configured inetd.conf so that the tftp string
is not commented out, but I cannot get the process to start.
I'm running Solaris 5.8 and need some help.
Cabletron said that it's process is 3485, i tried to kill it, it's the wrong process. I started inetd again and still can't kill it.
i created a a directory in etc called tftp (/etc/tftp)
Any ideas? it's not up and running
# 2  
When you say "its not up and running", do you mean tftp or inetd? If you modify your inetd.conf you need to restart inetd. Find its process number using ps(1) and then do a:
kill -HUP <I>Process_ID</I>

Test it by typing:
tftp <I>hostname</I>
get <I>filename</I>

where filename is some file you have avilable in the tftp directory. See the tftpd man page for more information.
# 3  
I mean that Tftp is not running, i can use the internet just fine, i think that is the qualification for Inetd to be working, i guess I could be wrong.
I read that inetd's process ID is 3845, i try to kill it and well, it won't die...i also trie kill -HUP inetd that too does not work
i'm not sure if I installed it right, I made a tftp directory /tftp out of / and how do I make that the default tftp directory.

# 4  
Please upload a copy of your inetd.conf file.
# 5  
#ident "@(#)inetd.conf 1.44 99/11/25 SMI" /* SVr4.0 1.5 */
# Configuration file for inetd(1M). See inetd.conf(4).
# To re-configure the running inetd process, edit this file, then
# send the inetd process a SIGHUP.
# Syntax for socket-based Internet services:
# <service_name> <socket_type> <proto> <flags> <user> <server_pathname> <args>
# Syntax for TLI-based Internet services:
# <service_name> tli <proto> <flags> <user> <server_pathname> <args>
# IPv6 and inetd.conf
# By specifying a <proto> value of tcp6 or udp6 for a service, inetd will
# pass the given daemon an AF_INET6 socket. The following daemons have
# been modified to be able to accept AF_INET6 sockets
# ftp telnet shell login exec tftp finger printer
# and service connection requests coming from either IPv4 or IPv6-based
# transports. Such modified services do not normally require separate
# configuration lines for tcp or udp. For documentation on how to do this
# for other services, see the Solaris System Administration Guide.
# You must verify that a service supports IPv6 before specifying <proto> as
# tcp6 or udp6. Also, all inetd built-in commands (time, echo, discard,
# daytime, chargen) require the specification of <proto> as tcp6 or udp6
# The remote shell server (shell) and the remote execution server
# (exec) must have an entry for both the "tcp" and "tcp6" <proto> values.
# Ftp and telnet are standard Internet services.
ftp stream tcp6 nowait root /usr/sbin/in.ftpd in.ftpd
telnet stream tcp6 nowait root /usr/sbin/in.telnetd in.telnetd
# Tnamed serves the obsolete IEN-116 name server protocol.
name dgram udp wait root /usr/sbin/in.tnamed in.tnamed
# Shell, login, exec, comsat and talk are BSD protocols.
shell stream tcp nowait root /usr/sbin/in.rshd in.rshd
shell stream tcp6 nowait root /usr/sbin/in.rshd in.rshd
login stream tcp6 nowait root /usr/sbin/in.rlogind in.rlogind
exec stream tcp nowait root /usr/sbin/in.rexecd in.rexecd
exec stream tcp6 nowait root /usr/sbin/in.rexecd in.rexecd
comsat dgram udp wait root /usr/sbin/in.comsat in.comsat
talk dgram udp wait root /usr/sbin/in.talkd in.talkd
# Must run as root (to read /etc/shadow); "-n" turns off logging in utmp/wtmp.
uucp stream tcp nowait root /usr/sbin/in.uucpd in.uucpd
#Tftp service is provided primarily for booting. Most sites run this
# only on machines acting as "boot servers."
tftp dgram udp6 wait root /usr/sbin/in.tftpd in.tftpd -s /tftpboot
# Finger, systat and netstat give out user information which may be
# valuable to potential "system crackers." Many sites choose to disable
# some or all of these services to improve security.
finger stream tcp6 nowait nobody /usr/sbin/in.fingerd in.fingerd
#systat stream tcp nowait root /usr/bin/ps ps -ef
#netstat stream tcp nowait root /usr/bin/netstat netstat -f inet
# Time service is used for clock synchronization.
time stream tcp6 nowait root internal
time dgram udp6 wait root internal
# Echo, discard, daytime, and chargen are used primarily for testing.
echo stream tcp6 nowait root internal
echo dgram udp6 wait root internal
discard stream tcp6 nowait root internal
discard dgram udp6 wait root internal
daytime stream tcp6 nowait root internal
daytime dgram udp6 wait root internal
chargen stream tcp6 nowait root internal
chargen dgram udp6 wait root internal
# RPC services syntax:
# <rpc_prog>/<vers> <endpoint-type> rpc/<proto> <flags> <user> \
# <pathname> <args>
# <endpoint-type> can be either "tli" or "stream" or "dgram".
# For "stream" and "dgram" assume that the endpoint is a socket descriptor.
# <proto> can be either a nettype or a netid or a "*". The value is
# first treated as a nettype. If it is not a valid nettype then it is
# treated as a netid. The "*" is a short-hand way of saying all the
# transports supported by this system, ie. it equates to the "visible"
# nettype. The syntax for <proto> is:
# *|<nettype|netid>|<nettype|netid>{[,<nettype|netid>]}
# For example:
# dummy/1 tli rpc/circuit_v,udp wait root /tmp/test_svc test_svc
# Solstice system and network administration class agent server
100232/10 tli rpc/udp wait root /usr/sbin/sadmind sadmind
# Rquotad supports UFS disk quotas for NFS clients
rquotad/1 tli rpc/datagram_v wait root /usr/lib/nfs/rquotad rquotad
# The rusers service gives out user information. Sites concerned
# with security may choose to disable it.
rusersd/2-3 tli rpc/datagram_v,circuit_v wait root /usr/lib/netsvc/rusers/rpc.rusersd rpc.rusersd
# The spray server is used primarily for testing.
sprayd/1 tli rpc/datagram_v wait root /usr/lib/netsvc/spray/rpc.sprayd rpc.sprayd
# The rwall server allows others to post messages to users on this machine.
walld/1 tli rpc/datagram_v wait root /usr/lib/netsvc/rwall/rpc.rwalld rpc.rwalld
# Rstatd is used by programs such as perfmeter.
rstatd/2-4 tli rpc/datagram_v wait root /usr/lib/netsvc/rstat/rpc.rstatd rpc.rstatd
# The rexd server provides only minimal authentication and is often not run
#rexd/1 tli rpc/tcp wait root /usr/sbin/rpc.rexd rpc.rexd
# rpc.cmsd is a data base daemon which manages calendar data backed
# by files in /var/spool/calendar
# Sun ToolTalk Database Server
100083/1 tli rpc/tcp wait root /usr/dt/bin/rpc.ttdbserverd rpc.ttdbserverd
# UFS-aware service daemon
#ufsd/1 tli rpc/* wait root /usr/lib/fs/ufs/ufsd ufsd -p
# Sun KCMS Profile Server
100221/1 tli rpc/tcp wait root /usr/openwin/bin/kcms_server kcms_server
# Sun Font Server
fs stream tcp wait nobody /usr/openwin/lib/ fs
# CacheFS Daemon
100235/1 tli rpc/tcp wait root /usr/lib/fs/cachefs/cachefsd cachefsd
# Kerberos V5 Warning Message Daemon
100134/1 tli rpc/ticotsord wait root /usr/lib/krb5/ktkt_warnd ktkt_warnd
# Print Protocol Adaptor - BSD listener
printer stream tcp6 nowait root /usr/lib/print/in.lpd in.lpd
# GSS Daemon
100234/1 tli rpc/ticotsord wait root /usr/lib/gss/gssd gssd
# AMI Daemon
100146/1 tli rpc/ticotsord wait root /usr/lib/security/amiserv amiserv
100147/1 tli rpc/ticotsord wait root /usr/lib/security/amiserv amiserv
# OCF (Smart card) Daemon
100150/1 tli rpc/ticotsord wait root /usr/sbin/ocfserv ocfserv
dtspc stream tcp nowait root /usr/dt/bin/dtspcd /usr/dt/bin/dtspcd
100068/2-5 dgram rpc/udp wait root /usr/dt/bin/rpc.cmsd rpc.cmsd
# 6  
tftp dgram udp6 wait root /usr/sbin/in.tftpd in.tftpd -s /tftpboot

Please upload the results of:

ls -ld /tftpboot

And also:

ls -l /usr/sbin/in.tftpd

# 7  
# ls -ld /tftpboot
lrwxrwxrwx 1 root other 9 Dec 5 11:02 /tftpboot -> /etc/tftp

# ls -l /usr/sbin/in.tftpd
-r-xr-xr-x 1 root bin 22604 Jan 5 2000 /usr/sbin/in.tftpd

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #785
Difficulty: Medium
The TRS-80 Model 100 was a desktop-style computer introduced in 1983.
True or False?

10 More Discussions You Might Find Interesting

1. Linux

tftp will not start.

I have setup nimol on a Fedora 9 machine. Nimol is installed and correctly configured and I have a client rs6000 (43p) declared in the dhcpd.conf file. all is running correctly and tftp is installed. I am monitoring /var/log/messages when I start the 43p and see the dhcp request come in and a reply... (0 Replies)
Discussion started by: johnf
0 Replies

2. AIX

NIM server setup on etherchannel setup environment

I know that IBM's official stance is that NIM does not work on etherchannel environment, but has anyone able to get around it? I'm working on a p5-590 LPAR system, and the NIM master and clients are all on the same frame. Any help is appreciated. (1 Reply)
Discussion started by: pdtak
1 Replies

3. UNIX for Dummies Questions & Answers

TFTP not found

Hi, I'm trying to run the tftp client on tsch shell and I get command not found, but on bash tftp ran fine, can anyone help me on how to run it on tsch? Thanks (1 Reply)
Discussion started by: wsn
1 Replies

4. UNIX for Dummies Questions & Answers

tftp troubleshooting

Hi I am trying to do a network install of Solaris 10 08_07 onto a Sunfire T2000. I have configured all my network-boot-arguments on the client server (named sundb1). I have installed my image of Solaris on my install server (sun1). But when I try to install using # boot net -s I get the... (0 Replies)
Discussion started by: Bobby76
0 Replies

5. UNIX for Dummies Questions & Answers

enabling TFTP

ive been trying to enable a tftp service on a unix box using the command atftpd --daemon but when i scan the open ports using nmap it doesnt show that port 21 as up does anyone know the reason... ive tried /etc/init.d/atftpd start , it didnt work if i type atftpd by it self it gives me a set... (2 Replies)
Discussion started by: ratamahatta
2 Replies

6. UNIX for Dummies Questions & Answers


Is it possible to copy files between two computers with TFTP.And how? (1 Reply)
Discussion started by: bericica
1 Replies

7. Linux

tftp question

RH 7.2 I am attempting to get tftp working but I'm having a problem. On the server, xinetd has libwrap options compiled in. I have a deny all policy in my hosts.deny file and the following entries in my hosts.allow file: in.tftpd:. But...when I attempt to tftp from... (1 Reply)
Discussion started by: jalburger
1 Replies

8. Solaris

tftp daemon error

Hi everyone, I am currently receiving an error on my console that reads something like: <host> tftpd: socket (delay): Protocol not supported I have done so much research into tftpd, i've looked everywhere to find out what this might be caused by...unfortunately i have Solaris 8, so there... (5 Replies)
Discussion started by: myscsa2004
5 Replies

9. IP Networking

TFTP question

I have been hearing that this protocol offers faster throughput rate than FTP, is it true? If so, are there any compromise in reliability on data being sent? How do I set up a TFTP transfer instead of a FTP to download? Thanks (3 Replies)
Discussion started by: ho_k
3 Replies

10. UNIX for Dummies Questions & Answers


Hi, Setting up print queue, using SMIT on AIX And I have an option saying do I wish to make this a BOOTP/TFTP server. What exactly does this do? Thanks (3 Replies)
Discussion started by: maverick
3 Replies

Featured Tech Videos