SFTP Coding issue

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers SFTP Coding issue
# 1  
Old 08-26-2011
SFTP Coding issue


I am trying to SFTP file from source_path to Destination_path. For this I wrote the below script:

cd $source_path

sftp $user_name@$target_server
cd $destination_path
put $filename

After connecting to target_server via sftp, pwd should be target server home path but it is $source_path.

Can anyone explain this?
# 2  
Old 08-26-2011
Is the home directory of the user the same on both the source and target machines?
Try cd /tmp, before running your script.
I tried your example, and the results I got were what you expected.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

SFTP issue

I'm trying to transfer a 1 GB file using sftp process. The process always gets disconnected in between (may be after 20%) file transfer when it runs from a batch script. If i do it in interactive mode, it works.. I checked with account admin to see the timeout option if any, but didn't help..... (2 Replies)
Discussion started by: Aswin Pillai
2 Replies

2. Shell Programming and Scripting

SFTP issue

Hi, I am trying to connect to a windows server via sftp from a user A and my job did log into it via user B. So I uses the following command to connect to teh new server. B>sftp -o IdentityFile=/pathtofile/id_rsa a@windows_server and it worked. But I don't want to use private key. Can we... (6 Replies)
Discussion started by: George1234
6 Replies

3. Solaris

Passwordless sftp issue

Hello Experts, I am trying to setup passwordless sftp from one of linux box to solaris box. I have generated key-pair and below is the permissions of the respective files. drwx------. 2 sftpuser sftpuser 4096 Dec 17 23:57 .ssh drwx------. 2 sftpuser sftpuser 4096 Dec 17 23:57 .... (16 Replies)
Discussion started by: sai_2507
16 Replies

4. Red Hat

sftp issue

Hi experts, While trying to sftp from one the red hat linux box it is giving following error. Status: Connecting to Response: fzSftp started Command: open "prodbill@" 22 Command: Pass: *********... (2 Replies)
Discussion started by: sai_2507
2 Replies

5. Shell Programming and Scripting

Issue with sftp

Hi Friends, I have created a shell and which will sftp file1 from serverA to serverB. In sftp prompt on serverA it is showing the file1 is available on serverB. where as when connected to ServerB it is not showing the file1. How come this. ServerA sftp> ls hsstest.dmp sftp> pwd Remote... (9 Replies)
Discussion started by: sriramis4u
9 Replies

6. UNIX for Advanced & Expert Users

Issue with SFTP from different server by

Hi , I have 2 servers , say Server A and Server B . ssh keys have been exchanged for unix account sftpuser(created on server A) in such a way that A shell script (Script1.Sh) written on Server A can PULL flat files from Server B and save them on server A . Now I am able to execute... (4 Replies)
Discussion started by: MrActionHero
4 Replies

7. Solaris

Urgent need help - issue sftp

hi experts, i have a problem with my sftp which install on sparc sun solaris os version 5.9, i have install this packages below on my server : libgcc-3.3-sol8-sparc-local openssl-0.9.8d-sol8-sparc-local zlib-1.2.3-sol8-sparc-local openssh-4.5p1-sol8-sparc-local and i... (2 Replies)
Discussion started by: bucci
2 Replies

8. AIX

SFTP issue

Hi!! SFTP5.0 is not working thru automatically pushing files, but manual file transfer is happening fine... If anyone knows,Pls share the reason. Regards, Senthil (3 Replies)
Discussion started by: senthil_seera
3 Replies

9. UNIX for Dummies Questions & Answers

SFTP script issue

Please excuse this post if it is in the wrong area. We are in the process of rewriting our ftp scripts to use sftp. Unfortunately I have been unable to come up with a solution for the following line in my ftp script: mls ALL_$DT.txt all_tmp.txt The mls command is not available in under sftp... (0 Replies)
Discussion started by: sdhalepaska
0 Replies

10. AIX

SFTP Issue with ssh

Hello all, hopefuly this is the right place to post this. I am having an issue with a new sftp process on an AIX box. I created id_rsa.pub file and sent it to the person who runs the sftp process. He added the key to the authorized_Users (I only have phone contact with him and its an outside... (7 Replies)
Discussion started by: dbridle
7 Replies
Login or Register to Ask a Question