Problem with crontab file

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem with crontab file
# 1  
Old 08-08-2011
Problem with crontab file

I have a crontab file called /var/spool/cron/root with these contents. When I use the command, crontab -l, these are the contents which are displayed.

1	*	*	*	*	run-parts /etc/cron.hourly
2	4	*	*	*	run-parts /etc/cron.daily
22	4	*	*	7	run-parts /etc/cron.weekly
42	4	1	*	*	run-parts /etc/cron.monthly
10	0	*	*	*	run-parts /etc/cron.daily2
10	12	*	*	*	run-parts /etc/cron.daily2
1,16,31,46	*	*	*	*	/usr/local/psa/admin/sbin/backupmng >/dev/null 2>&1
0	1	*	*	1	/usr/local/psa/libexec/modules/watchdog/cp/secur-check
0	1	*	*	1	/usr/local/psa/libexec/modules/watchdog/cp/send-report weekly
10	1	*	*	*	/usr/local/psa/libexec/modules/watchdog/cp/clean-sysstats
15	1	*	*	*	/usr/local/psa/libexec/modules/watchdog/cp/pack-sysstats day
15	1	*	*	1	/usr/local/psa/libexec/modules/watchdog/cp/pack-sysstats week
15	1	1	*	*	/usr/local/psa/libexec/modules/watchdog/cp/pack-sysstats month
15	1	1	*	*	/usr/local/psa/libexec/modules/watchdog/cp/pack-sysstats year
20	1	*	*	*	/usr/local/psa/libexec/modules/watchdog/cp/clean-events
0	3	*	*	7	/usr/local/psa/libexec/modules/watchdog/cp/clean-reports

I have a couple of questions, the first is pretty simple... I hope:

1. With regards to the '##run-parts' line at the top, does this mean that I do not need 'run-parts' in the command for the top six cronjobs?

2. I changed the crontab file from another one to this one. In the previous file, I entered an incorrect email address in the MAILTO field. Even though I have changed the crontab file and confirmed it is changed by using crontab -l, I am getting emails through saying:

Hi. This is the qmail-send program at
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

Sorry, no mailbox here by that name. (#5.1.1)

Sorry, no mailbox here by that name. (#5.1.1)

How can I check to see if there is another file crontab is using? I am thinking that there may be two running which are conflicting with each other?

Thanks in advance.


Last edited by pludi; 08-08-2011 at 06:19 AM..
# 2  
Old 08-08-2011
How did you change the file? If you edited it directly, that's incorrect. Try crontab -e.
# 3  
Old 08-10-2011
Originally Posted by jpradley
How did you change the file? If you edited it directly, that's incorrect. Try crontab -e.
I made crontab point to a different file. (Can't remember exactly how I did this but, by using crontab -l, I can see it worked).

Whenever I edit the crontab I do use crontab -e however.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

crontab problem

online* 22:25:22 svc:/system/cron:default cron service not able to start i tried to disble it is not working. showing online* status. thanks (1 Reply)
Discussion started by: sunnybee
1 Replies

2. Shell Programming and Scripting

Problem with crontab

Hi, I have one script which takes data from table and spools it into a file. When i am running manually all is fine but while trying same script thru crontab the spooled file is not getting generated..... :confused: The mail part is working fine....only prob is the spooled file. Please... (15 Replies)
Discussion started by: fidelis
15 Replies

3. UNIX for Dummies Questions & Answers

Problem with my crontab file, using mysqldump

My crontab file tells cron to run a certain shell script at 10:30 AM every day. The shell script backs up my database with mysqldump and then runs a sed script that does some editing of the backup file. I have programmed the shell script to write an error message to a file I have in my home... (1 Reply)
Discussion started by: Ultrix
1 Replies

4. UNIX for Dummies Questions & Answers

Crontab problem!

Hi All, i added a sh script to crontab, it run but there is sqlplus expression that generate a spool file(gun.lst). this expression didnt run. Summary, 1- my main script is that i added it to Cron via "crontab -e" command 2- There is "sqlplus username/password@serverA @umt.sql"... (6 Replies)
Discussion started by: temhem
6 Replies

5. AIX

Problem with crontab

Hi, Can anyone let me know the functionality of the following command in Unix crontab ;l Thanks, Wajith.M (3 Replies)
Discussion started by: Wajith
3 Replies

6. Shell Programming and Scripting

Crontab problem

Hi all, I made few changes to the script (under the directory mentioned in crontab) scheduled under crontab and the problem is that crontab doesnt pickup those changes and somehow runs the old copy of the script from somewhere. Any help would be appreciated. (8 Replies)
Discussion started by: vinoo128
8 Replies

7. Shell Programming and Scripting

CRONTAB problem

Hi i was working on an Unix server/ While logging out i used to type the command exit and log out. Yesterday when i was logging out i got an message saying "YOU HAVE STOPPED JOBS". i have not done anything other than giving exit. What could the reason the message was displayed. I thought i had... (3 Replies)
Discussion started by: venkidhadha
3 Replies

8. UNIX for Advanced & Expert Users

crontab problem

hi all while using crontab -e im receiving 754 as output im unable to add a entry in crontab crontab -l is working fine OS: sun5.8 can some one please assist me (4 Replies)
Discussion started by: NIMISH AGARWAL
4 Replies

9. UNIX for Dummies Questions & Answers

Problem with crontab

I am trying to schedule a job to run through cron that checks for high CPU usage. The 'top' command is run and the output is logged to a file. A calculation is done in the file to check if CPU runs above 80%. If this happens an email is sent out. The problem I am having is that when I run this... (4 Replies)
Discussion started by: shehnaaz
4 Replies

10. UNIX for Dummies Questions & Answers

crontab problem

Hi, I trying to include a script in my crontab as user. I used "crontab -e" to include my script there but does not seem to work. If I understand correctly it is set to run at 11:20 every day, correct? Can anybody identify any error? <pre> #Sun Microsystems Inc. SunOS 5.7 Generic... (19 Replies)
Discussion started by: guest100
19 Replies
Login or Register to Ask a Question