accidentally umount -a

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers accidentally umount -a
# 1  
Old 07-05-2011
accidentally umount -a

Hi all,

I accidentally unmounted filesystems using umount -a command.

How to recover from this. Please help. Thanks in advance!

when i try to use mount -a i got the following output.

[root@lnx ~]# mount -a
mount: /dev/vg00/lvol05 already mounted or /opt busy
mount: /dev/vg00/lvol07 already mounted or /u01 busy
mount: /dev/cciss/c0d0p1 already mounted or /boot busy

following is the /etc/fstab file

[root@lnx ~]# more /etc/fstab
/dev/vg00/lvol00        /                       ext3    defaults        1 1
/dev/vg00/lvol02        /var                    ext3    defaults        1 2
/dev/vg00/lvol05        /opt                    ext3    defaults        1 2
/dev/vg00/lvol03        /usr                    ext3    defaults        1 2
/dev/vg00/lvol04        /tmp                    ext3    defaults        1 2
/dev/vg00/lvol06        /home                   ext3    defaults        1 2
/dev/vg00/lvol07        /u01                    ext3    defaults        1 2
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/vg00/lvol01        swap                    swap    defaults        0 0

below is the df command output

[root@lnx ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
                      9.7G  404M  8.8G   5% /
                      9.7G  320M  8.9G   4% /var
                       20G  1.4G   18G   8% /usr
                      9.7G  151M  9.1G   2% /tmp
                      9.7G  195M  9.0G   3% /home

# 2  
Old 07-05-2011
There is a corresponding mount -a.
# 3  
Old 07-05-2011
Hi Corona688,

I got the following error when i used mount -a

[root@lnx ~]# mount -a
mount: /dev/vg00/lvol05 already mounted or /opt busy
mount: /dev/vg00/lvol07 already mounted or /u01 busy
mount: /dev/cciss/c0d0p1 already mounted or /boot busy

I even tried to mount them manually but got the same error saying

mount: /dev/vg00/lvol05 already mounted or /opt busy

# 4  
Old 07-05-2011
Very odd.

How about cat /proc/mounts?

You could try rebooting of course.
# 5  
Old 07-05-2011
Hi Corona688,

Thanks for prompt response.
Rebooting the server solved the problem.
Thanks again.
This User Gave Thanks to lramsb4u For This Post:
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

SFTP - accidentally removing unprocessed records

I have an automated sftp process running on a Linux server that is securely connecting to an insurance company server whereby the insurance company places work assignments into a directory on their windows server (running VanDyke Vshell). My unattended (background) process runs every minute.... (8 Replies)
Discussion started by: jeffvansan
8 Replies

2. AIX

Oracle ASM accidentally messed with my hdisk

I have AIX 5.3 with oracle 10g ( test server). While trying to create RAW disk for Oracle ASM I have accidentally messed with rootvg (hdisk0 & hdisk1) When I do # lspv hdisk0 0516-066 : Physical volume is not a volume group member. Check the physical volume name specified. ... (4 Replies)
Discussion started by: George_Samaan
4 Replies

3. Shell Programming and Scripting

Accidentally removed a script

I accidentally rm a script (typo) and it doesn't even show up in the trash. Is there any way I can recover? (3 Replies)
Discussion started by: stevenswj
3 Replies

4. Solaris

Accidentally did a unlink inet

I was trying to remove a symbolic link of /etc/hosts to /etc/inet/hosts well i forgot the command and in the /etc directory i did unlink inet and now i can not get into inet and it does not exist in /etc 1) what do i do to fix the inet directory 2) how do i link /etc/hosts to... (1 Reply)
Discussion started by: deaconf19
1 Replies

5. UNIX for Dummies Questions & Answers

HELP! Accidentally downloaded .gz file non-binary

Let me start by saying I am at a VERY beginner level in terms of UNIX/FTP/etc. Someone loaded a file onto a server for me and zipped it using gzip. I accidentally downloaded the file without using "binary". I now have a "filename.txt.gz" sitting on my computer that I need to unzip. Is... (2 Replies)
Discussion started by: UDcc123
2 Replies

6. Solaris

I may have accidentally redefined one of the outputs...

I get unexpected results when doing ls -al | more and ls -al | grep. When I do not pipe the output, it comes to the screen just fine, and there is output! When I pipe to another command, I either get nothing, or else I get a strange dump. Which of the outputs have I accidentally affected?... (2 Replies)
Discussion started by: joang
2 Replies

7. Solaris

changed shell of the root accidentally

Hi All, I have changed the shell of the root accidentally to /sbin/bash :mad: How do I change that? :( To change that I need to go to ok prompt I think, and there I need to mount the root file system in order to make changes to the respective file. Can any one please suggest how do I do... (4 Replies)
Discussion started by: pintu_asim
4 Replies

8. UNIX for Advanced & Expert Users

umount help

hi all, I inherit a Solaris7 system with /home mounted via a share from the NFS server. When I look at mnttab, there are two entries mounted under /home. Let's say they are server:/home/a and server:/home/b. I would like to maintain /home/a but not /home/b. However, I just don't know where... (4 Replies)
Discussion started by: andrec
4 Replies

9. UNIX for Advanced & Expert Users

Accidentally deleting directory/files

Hi, I accidentally deleted a big directory with all its sub-directories and bunch of source code files which I have been developing for about 2 years... What will I do now, how can I retrieve my files, directory hierarchy back ??? If anyone, please HELP ! ! ! ... (4 Replies)
Discussion started by: milhan
4 Replies

10. UNIX for Dummies Questions & Answers


:confused: Twofold question for you unix "guru's" 1) When attempting to use the umount command I get a message stating that the partition that I want to unmount is busy. Is there another command that I need to use prior to the umount command to clear the partition of activity????? ... (2 Replies)
Discussion started by: rod23
2 Replies
Login or Register to Ask a Question