Visit The New, Modern Unix Linux Community

New kernel won't boot

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers New kernel won't boot
# 1  
New kernel won't boot

I compiled new kernel in linux 10.04 called linux-, it runs alongside the other kernel, but when I want to boot it I get an error message saying:

Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/sda5 does not exist.

After making the modules and headers
I made the initrd.img with
update-initramfs -v -c -k

And renamed it with
mv /boot/initrd.img- /boot/initrd.img-

The new menu entry is:
title Xenomai 2.5.1
root (hd0,0)
kernel /boot/vmlinuz- root=/dev/hda1 ro
initrd /boot/initrd.img-

Till then all seems well. But still the kernel won't run

To start make bzImage I had to screw around with the menuconfig, amongst others disabling Xenomai because it would otherwise not work.

Here is some boot info, could someone help me out please?

============================= Boot Info Summary: ===============================

=> Windows is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

File system: vfat
Boot sector type: Dell Utility: FAT16
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:

sda2: __________________________________________________________________________

File system: ntfs
Boot sector type: Windows XP
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files:

sda3: __________________________________________________________________________

File system: ntfs
Boot sector type: Windows Vista/7
Boot sector info: No errors found in the Boot Parameter Block.
Operating System: Windows Vista
Boot files: /boot.ini /bootmgr /Boot/BCD
/Windows/System32/winload.exe /ntldr /NTDETECT.COM
/wubildr /wubildr.mbr

sda4: __________________________________________________________________________

File system: Extended Partition
Boot sector type: -
Boot sector info:

sda5: __________________________________________________________________________

File system: ntfs
Boot sector type: Windows Vista/7
Boot sector info: According to the info in the boot sector, sda5 starts
at sector 2048.
Operating System: Windows XP
Boot files: /ubuntu/winboot/wubildr /ubuntu/winboot/wubildr.mbr
/ubuntu/disks/root.disk /ubuntu/disks/swap.disk

sda5/Wubi: _____________________________________________________________________

File system: ext4
Boot sector type: -
Boot sector info:
Operating System: Ubuntu 10.04.2 LTS
Boot files: /boot/grub/menu.lst /boot/grub/grub.cfg /etc/fstab

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1                  63       240,974       240,912  de Dell Utility
/dev/sda2             241,664    21,213,183    20,971,520   7 NTFS / exFAT / HPFS
/dev/sda3    *     21,213,184   215,773,175   194,559,992   7 NTFS / exFAT / HPFS
/dev/sda4         226,013,184   488,394,751   262,381,568   f W95 Extended (LBA)
/dev/sda5         226,015,232   488,394,751   262,379,520   7 NTFS / exFAT / HPFS

"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/loop0       90d6c7a5-b740-4f76-aa95-a3698b79e05b   ext4       
/dev/sda1        07D8-0303                              vfat       DellUtility
/dev/sda2        76A4535AA4531BC5                       ntfs       RECOVERY
/dev/sda3        EC8A61468A610F00                       ntfs       
/dev/sda5        66D07AECD07AC23B                       ntfs       NieuwVolume

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/loop0       /                        ext4       (rw,errors=remount-ro)
/dev/sda5        /host                    fuseblk    (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)

================================ sda3/boot.ini: ================================

;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(4)\WINDOWS="Microsoft Windows XP Professional" /NOEXECUTE=OPTIN /FASTDETECT


======================== sda5/Wubi/boot/grub/menu.lst: =========================

title Xenomai 2.5.1
root (hd0,0)
kernel /boot/vmlinuz- root=/dev/hda1 ro
initrd /boot/initrd.img-


Last edited by pludi; 05-28-2011 at 06:57 PM..
# 2  
There is no "linux 10.04", presumably 10.04 is a revision of some distribution or other.

If it can't find sda5, that means it's either not finding your disk because you didn't compile in the right disk controller drivers, or the device's name changed from sda to hda.
# 3  
Appologies, I ment Ubuntu 10.04, still bit of a noob here Smilie
I retried to recompile, after clean, mrporper, olconfig I did a new menuconfig. Now I think I enable as much as possible and set the proccesor family up better (maybe this will do anything good), but it's still quite confusing where to look as I have hardly any idea what those conigurations mean. After a lot of hassle I solved the ipipe_o error, but now it goes on about this;

  CC      arch/x86/xenomai/hal-common.o
arch/x86/xenomai/hal-common.c: In function ‘rthal_latency_above_max’:
arch/x86/xenomai/hal-common.c:333: error: implicit declaration of function ‘die_nmi’
make[1]: *** [arch/x86/xenomai/hal-common.o] Error 1
make: *** [arch/x86/xenomai] Error 2

I know If I disable Xenomai altogether it should compile, but I think that got me in a mess earlier. Could you please advise on proper config settings?

Last edited by pludi; 05-30-2011 at 06:24 PM..
# 4  
I couldn't tell you, I've never needed to build xenomai. The "proper settings" also depend on your system. You'd also need to build it with the options ubuntu expects, too. Don't suppose you have the configuration for your old kernel handy?
# 5  
Got it, I needed to compile it in a virtual machine Qemu.
This User Gave Thanks to mdop For This Post:

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #66
Difficulty: Medium
IT and cybersecurity risk management is based on the intersection of these three areas, criticality, vulnerability, and threat.
True or False?

10 More Discussions You Might Find Interesting

1. Linux

Unload kernel module at boot time (Debian Wheezy 7.2, 3.2.0-4-686-pae kernel)

Hi everyone, I am trying to prevent the ehci_hcd kernel module to load at boot time. Here's what I've tried so far: 1) Add the following line to /etc/modprobe.d/blacklist.conf (as suggested here): 2) Blacklisted the module by adding the following string to 3) Tried to blacklist the module... (0 Replies)
Discussion started by: gacanepa
0 Replies

2. SCO

SCO UNIX Won't Boot

Our system is not booting up properly. It keeps going to this screen: Enter Run Level (0-6, s or S): I tried to hit all nos# 0-6 is just goes to hung state. Tried s or S & it brings me to single user mode. I've checked the file systems & found out that all three had 98%. I tried to... (86 Replies)
Discussion started by: jedimaster
86 Replies

3. UNIX for Dummies Questions & Answers

Custom kernel compiling, won't boot, and errors.

First of all, I'd like to preface this post by relaying that I have considerable experience with FreeBSD but I'm a Linux newb. I've been attempting to compile linux- from source and I'm having some problems and have a few newb questions... a) First of all, my kernel won't boot, it fails... (0 Replies)
Discussion started by: urbanriot
0 Replies

4. AIX

won't mount /usr...won't boot fully

Hello: NOOB here. I attempted to use smit mkcd. Failed on first attempt, not enough space. 2nd attempt tried to place iso on /usr, not enough space there. Cleanup ran for about 5 minutes after aborting. Now AIX won't boot. LCD display on 7029-6E3 says: 0517 MOUNT /USR. Attempted to boot from CD... (11 Replies)
Discussion started by: bbird
11 Replies

5. UNIX for Dummies Questions & Answers

Linux won't boot

I'm trying to install Fedora 9 on a Dell OptiPlex GX300 machine. The instalation runs properly, but when the computer restarts after the instalation, it simply won't boot, like there's no OS installed. I tried diffrent Linux distributions, but nothing works. This are the partitions, maybe it's... (12 Replies)
Discussion started by: teis
12 Replies

6. Solaris

Ultra 60 won't boot

I just was given an Ultra 60 that I'm trying to get started so that I can re-load the system with Solaris 10. I can't seem to get the system to boot past the initial memory check. I've tried to do an Stop-A to get to the eeprom, but can't do that. My next step is to try to send a break from the... (0 Replies)
Discussion started by: zosojohnny
0 Replies

7. Solaris

Cloned drive won't boot ?

Solaris system version 6 I cloned the drive using the DD command. Using the format command and examining the partitions, all looks the same as the original drive. Problem: When I attach the cloned drive as the master, and only drive in system, it will not boot. Error messages: ... (9 Replies)
Discussion started by: HikerLT
9 Replies

8. Solaris

cannot find boot device and won't boot off cdrom

I'm running solaris 2.5.1. My main development server is DEAD, i can't even boot off the cdrom, it powers up, acts like it is starting the boot process but then says cannot find boot device. I've done the search here on this site and saw the other posts, but at the ok prompt it won't even let me... (3 Replies)
Discussion started by: kymberm
3 Replies

9. AIX

server won't boot

Hi all , i was trying to upgrade firmware on machine 7028-6E4 and it failed . Now machine does not boot anymore , i can not get SMC menu either ... What are my options ? Thanks, Rahim (1 Reply)
Discussion started by: rahim
1 Replies

10. Solaris

Solaris (9) won't boot!

Hi, I've just bought an Ultra 60 running solaris 9 (or so I've been led to believe). When I start up, it looks for a (presumably) domain/network to hook up to and the following messages are displayed: Boot device: net file and args: Network link setup failed Please check cable and try... (3 Replies)
Discussion started by: alarmcall
3 Replies

Featured Tech Videos