Simple Problems to Solve!

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Simple Problems to Solve!
# 1  
Old 02-28-2011
Data Simple Problems to Solve!


I'm pretty poor at using UNIX but I'm learning. Please help me with these simple problems! Much appreciated!

1. I've changed my shell from bash to csh but I prefer bash. How do I change back? I've tried using chsh -s but it's not working!

2. I'm trying to download TopCat. I've done this successfully and set an alias but when I try to load it I get the following error:
"Exception in thread "main" java.awt.HeadlessException
    at java.awt.GraphicsEnvironment.checkHeadless(
    at java.awt.Window.<init>(
    at java.awt.Frame.<init>(
    at java.awt.Frame.<init>(
    at javax.swing.JFrame.<init>(

I have Java 1.6 running and the website says you need 1.5 or higher.

3. I am trying to use the ZHTools package for DS9. I have been following the online installation guide and I have got to stage 5 where I need to 'make' the file. I get the following errors:
"making in ./src/ds9
make[1]: Entering directory `/pool/zhtools-3.0.4/src/ds9'
make[1]: Leaving directory `/pool/zhtools-3.0.4/src/ds9'
making in ./src/util/src
make[1]: Entering directory `/pool/zhtools-3.0.4/src/util/src'
f95  -e -O -DF95 -xlang=f77  -I/pool/zhtools-3.0.4/include -DZHDATA="''" -c -o dataenv.o dataenv.F
f95: language lang=f77 not recognized
f95: language lang=f77 not recognized
f95: dataenv.F: linker input file unused because linking not done
f95  -e -O -DF95 -xlang=f77  -I/pool/zhtools-3.0.4/include  -c -o sort2.o sort2.f
f95: language lang=f77 not recognized
f95: language lang=f77 not recognized
f95: sort2.f: linker input file unused because linking not done
ar cruv /pool/zhtools-3.0.4/lib/libzhtools.a abs_path.o       first3w.o      newunit.o      sort3.o ad_rad.o       fixstring.o      no.o          sort4.o atrousimg.o       fk45z.o      none.o      splitwords.o atrousstep.o       floodfill.o      norm.o      splitwords_char.o atrousstep_0.o       floor.o      o_f_i.o      strbcat.o ccorr2d.o       fmin.o      open_fits.o      strcat.o check_cl.o       fourn.o      poi.o          strchr.o check_naxis.o       fscanf_.o      poidev.o      strcmp.o cl_or_read_par.o   ft_printerr.o  poiprob.o      strcpy.o cmplx_mult.o       ft_same_f.o      prebn.o      strlow.o conv_gauss.o       g_cl.o      prec.o      strncat.o conv_mex.o       g_i_size.o      preces.o      strncmp.o conv_rect1.o       g_image.o      quanc8.o      strncpy.o conv_rect1_1D_d.o  g_num_p.o      r_f_i.o      strrchr.o cr_f_i.o       g_p_or_a.o      r_f_i_u.o      strstr.o crmvblk.o       g_p_v.o      ran1.o      svbksb.o daf2r.o           g_p_v_d.o      ran2.o      svdcmp.o dafin.o           gamma.o      ranref.o      svdfit.o dataenv.o       gammpq.o      readwrite.o      svdksb.o dcc2s.o           gasdev.o      real_path.o      svdvar.o dcs2c.o           idchf.o      rearrange.o      symlnk.o dd2tf.o           idistance.o      refvec.o      symlnk_c.o deuler.o       if_peak.o      replace_char.o  system1.o dfltin.o       imsmo.o      resize_img.o      system2.o diffr_w8.o       indexx.o      rlft2.o      toupper.o dmxv.o           isanum.o      rlft3.o      u_wants_clob.o dr2af.o           isanum_c.o      rmblanks.o      w_f_i.o dr2tf.o           isfits.o      saoimage.o      w_f_i_h.o dranrm.o       lastasci.o      scanf_.o      w_f_i_h_u.o dsep.o           lfblnk.o      select.o      w_f_i_h_u_wcs.o dtf2d.o           load_par.o      setran.o      whereiseq.o dtf2r.o           locate.o      show_c1.o      worldpos.o epb2d.o           lowstring.o      show_i2.o      wt_ferrmsg.o epj.o           marith.o      show_i4.o      xcopynoscale.o epsmach.o       mcarith.o      show_r4.o      xcopyscale.o exiterror.o       mcopy.o      show_r8.o      xcpnsclps.o fact.o           min_max.o      simplx2.o      yes.o fcecho.o       move_ext.o      simplx28.o      zeroin.o fcstln.o       msarith.o      simplx3.o      zhhelp.o fileenv.o       mset.o      sort.o      zhhelp_c.o finis.o           mtrx_smult.o   sort2.o
ar: abs_path.o: No such file or directory
make[1]: *** [/pool/zhtools-3.0.4/lib/libzhtools.a] Error 1
make[1]: Leaving directory `/pool/zhtools-3.0.4/src/util/src'"

Thanks for your help!


Last edited by fpmurphy; 02-28-2011 at 10:30 AM.. Reason: code tags please!
# 2  
Old 02-28-2011
1. I've changed my shell from bash to csh but I prefer bash. How do I change back? I've tried using chsh -s but it's not working!
$ chsh -s bash

If that does not work check /etc/shells. Maybe bash is not listed there
This User Gave Thanks to fpmurphy For This Post:
# 3  
Old 02-28-2011
Great, thanks for your help. It seems to have worked. I needed to use chsh -s /bin/bash Smilie

Any ideas with 2 or 3?
Login or Register to Ask a Question

Previous Thread | Next Thread

7 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Can't solve a simple SSH/scp issue.. Please help.

Disclaimer: I tried searching but wasn't able to get to the answer so please don't flame. Scenario: I have a root script that generates a file on box1 and then needs to scp it over to box2 using user1. Both boxes are running open-ssh. root@locat-host# scp /tmp/file1 user1@box2:/tmp/file1 ... (10 Replies)
Discussion started by: denissi
10 Replies

2. Shell Programming and Scripting

Help making simple perl or bash script to create a simple matrix

Hello all! This is my first post and I'm very new to programming. I would like help creating a simple perl or bash script that I will be using in my work as a junior bioinformatician. Essentially, I would like to take a tab-delimted or .csv text with 3 columns and write them to a "3D" matrix: ... (16 Replies)
Discussion started by: torchij
16 Replies

3. Shell Programming and Scripting

simple problems in awk

Dear All, I have the following awk script. #!/bin/bash sh stdev.cmd data.file | awk '{print $2}' > read d < echo $d awk '{print $1,$2- $f}' new > newz The script runs "stdev.cmd" and output a file "" and the value of the... (2 Replies)
Discussion started by: Yacob_123
2 Replies

4. UNIX for Dummies Questions & Answers

I'm having problems with a simple for loop on a newline

for i in `seq 1 10 ` ; do printf $i '\n'; done gives me this: 1234567891064mbarch ~ $ (output followed by bash prompt) :( I've tried so many ways to create a newline at the end. Does anyone have any ideas.. Thanks in advance. Sorry (7 Replies)
Discussion started by: 64mb
7 Replies

5. Shell Programming and Scripting

Problems with simple script in cygwin

Hello! I have somo problems with simple scripts like this: #!/bin/bash echo -n "Enter your name and press : " read var_name echo "Your name is: $var_name" When I try to run it, this error occurs: ':not a valid identifier var_name. Why?? (I work in cygiwin) Is there anybody out... (10 Replies)
Discussion started by: blianna
10 Replies

6. Shell Programming and Scripting

Problems using join for simple database lookup

I am trying to get a script working that will perform a simple database lookup using the join command. Here are the two files that I am trying to join: % cat lookup1.txt Number_1 Other_data_a Number_5 Other_data_b Number_8 Other_data_c Number_10 Other_data_d % cat... (2 Replies)
Discussion started by: JasonHamm
2 Replies

7. Red Hat

Help me to solve problems of installation

Hi everyone, I have just installed Linux redhat 9.0, Unfortunately i met a error, it annonced as following when i pressed ENTER at the first step on installation and then i stoped: PCI: 00:13.2 PCI cache line size set incorrectly (64 bytes) by BIOS/FW PCI: 00:13.2 cache line size too... (3 Replies)
Discussion started by: RobertPh
3 Replies
Login or Register to Ask a Question

Featured Tech Videos