DNS Name Server Problem on Linux


 
Thread Tools Search this Thread
# 1  
DNS Name Server Problem on Linux

I'm very new to all of this, so I apologize in advance if my post comes off incoherent, or terms aren't used correctly Smilie

Using Fedora Core 2, I set up am internal DNS name server. After setting up the named.conf, and the localhost files I was able to correctly resolve my host name through nslookup and dig. For a while, this actually worked!

However, in order for named to run at startup, I linked it into etc/rc5.d. From then on, I can't resolve my host name.

I'm sure named is running, because I see it in the process list. I've also checked var/log/messages for some sort of error, but everything looks fine there.

Any suggestions?

-skeet
# 2  
Whats with your /etc/resolv.conf and /etc/nsswitch.conf ?
# 3  
Might also be worth posting the (abbreviated...) contents of /etc/named.conf

Cheers
ZB
# 4  
Problem solved, thanks

Thanks for the replies, but I got it.

I guess since this was an internal name server, I had to specify to dig and nslookup to quiery the local name server, instead of going out and trying to resolve this domain name on the internet.

So that problem was solved, thanks for the posts, though.

-skeet
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #515
Difficulty: Easy
A variable's type (or data type) is the characterization of the data that it represents.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

DNS client added to DNS server but not working

Hi, We have built a new server (RHEL VM)and added that IP/hostname into dns zone configs file on DNS server (Solaris 10). Reloaded the configuration using and added nameserver into resolv.conf on client. But when I am trying nslookup, its not getting resolved. The nameserver is not able to... (8 Replies)
Discussion started by: snchaudhari2
8 Replies

2. Linux

How to create master+forwarder dns server in Linux?

Hi Team I have created one new dns server in lab and its working properly. Earlier we were using another dns server for lab pc's as 10.20.30.xx. which is outside the lab premises. now issue with newly created as its not resolving query as previous. I am told by some to use forwarder option for... (2 Replies)
Discussion started by: boby.kumar
2 Replies

3. IP Networking

Configuring DNS Server in Linux Redhat

Can someone help with a detail step-by-step oh how to configure DNS server on Linux Server. - I need to have 3 IP addresses map to a single hostname. for clients I'm a Linux rookie. Thanks Oscar (1 Reply)
Discussion started by: FrankOscar
1 Replies

4. Emergency UNIX and Linux Support

Help with Ubuntu Linux Server Password Problem...

Hi all, I have no root access enabled on our linux server due to safety issues. We use sudo. When I change my password using passwd command, I sometimes get issues where I can't log back in. Pam_Tally disables due to trying my password too many times. So someone in my group has to reset... (7 Replies)
Discussion started by: zixzix01
7 Replies

5. UNIX for Advanced & Expert Users

DNS server choice: Windows DNS vs Linux BIND

I'd like to get some opnions on choosing DNS server: Windows DNS vs Linux BIND comparrsion: 1) managment, easy of use 2) Security 3) features 4) peformance 5) ?? I personally prefer Windows DNS server for management, it supports GUI and command line. But I am not sure about security... (2 Replies)
Discussion started by: honglus
2 Replies

6. UNIX for Dummies Questions & Answers

Problem with new linux server

Hi all, We have migrated from a unix solaris server to a linux server. When we run the same pieces of code, they are behaving very differently. Some of the problems I am facing are - cat filename | read var1 var2 echo "var1 var2" works in unix, but returns null values in linux. ... (4 Replies)
Discussion started by: novice1324
4 Replies

7. Solaris

Solaris DNS Client For Microsoft DNS Server

hey guys, how to add soalris box as a microsoft DNS Client ? and how to register in the microsoft DNS ?? i managed to query from the DNS server after adding /etc/resolve.conf and editing /etc/nsswitch.conf but i need to register the soalris server (dns Client) into Microsoft DNS automatically.... (3 Replies)
Discussion started by: mduweik
3 Replies

8. Linux

ftp problem from linux to windows2000 server

Hi All, I was trying to ftp multiple files from my windows to my linux box, everything gets transfered but unfortunately some of them are corrupted. I found out that some of the files are in Ascii and some are binary, but since most of the files I'm trying to send are Ascii...the big ones... (2 Replies)
Discussion started by: 3rr0r_3rr0r
2 Replies

9. UNIX for Dummies Questions & Answers

Problem to ping Linux server

I want to access window file system through Samba. when i ping Window machine through linux machine it connect, but in reverse case it shows "Request time out". could any one suggest what problem may be. (1 Reply)
Discussion started by: sonirajesh
1 Replies

10. UNIX for Dummies Questions & Answers

Linux Managed Server, Mapping Dns To Directory

Ok, so I am new at this stuff. I have just created a new directory in my linux root server and I am trying to have that specific directory linked with my domain name. Make sense? Any help would be sweeeeet! Thanks (0 Replies)
Discussion started by: zapmedia
0 Replies

Featured Tech Videos