unresolved symbol ???

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers unresolved symbol ???
# 1  
Old 10-07-2004
Network unresolved symbol ???

when I make ncftp

I just get problems like ...

/usr/lib/dld.sl unresolved symbol:inet_ntop (code)

does anybody know what is the problem and how to solve this?

# 2  
Old 10-07-2004
I can tell you what it menas but not the exact fix.

dld is opening shared library(ies), and it is expecting to find
inet_ntop in that library. It is not in there.

When the file was linked originally that symbol was available, now it is not. Either the path to the shared library is pointing to a differnet shared library file, or the shared library file itslef has changed since it was linked.

As a guess, you probably need to use LD_LIBRARY_PATH to point to where the correct library lives, or move the inet shared libraries someplace else.

ldd <filename> will show you what libraries the image file is trying to access as shared.
# 3  
Old 10-08-2004
ldd ncftp
sh. file not found.

there isn't a command like that..perhaps different unix versions.

also there isn't a file called "inet_ntop"...I think the program is


but no problem anymore, have another program that works fine. thx...
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Solaris

/usr/lib/passwdutil.so.1: symbol __nsl_fgetspent_r: referenced symbol not found

deleteing post (0 Replies)
Discussion started by: dshakey
0 Replies

2. AIX

Unresolved symbols

Hello experts , i have some strange problem, i wanted to create a shared object in AIX 5.3 for which i have compiled all my .cxx to .o which worked fine and then i created the .so from them , but when i do nm -Bo sample.so , i have many unresolved symbol, including printf... (0 Replies)
Discussion started by: vin_pll
0 Replies

3. UNIX for Advanced & Expert Users

database connection (unresolved sqlcxt)

i have a little pro*c code (as shown below) to connect an oracle database. (in unix solaris platform) in the preprocessor compilation step everything is ok. but when i try to compile the code using cc i get the error below: ld: Unresolved: sqlcxt i think there is a problem while linking... (3 Replies)
Discussion started by: gfhgfnhhn
3 Replies

4. HP-UX

Unresolved symbol problem

Hi I am trying to make an executable which has informix esqlc and .per files. I am using informix version 9.3. The make is successful, but when i execute, i get an error message /usr/lib/dld.sl: Unresolved symbol: ibm_lib4gl_loadint4 (code) from RVprnrecvr Abort(coredump) I searched for... (4 Replies)
Discussion started by: venkatakrishnan
4 Replies

5. Programming

unresolved symbol on AIX 5.2

Hi, want to port an executable from AIX 5.3 to AIX 5.2. This seems to be no problem, when i build one executable. But in another case i have to link one library statically and the rest is loaded at runtime. This works for AIX 5.3 but on AIX 5.2 i get the following error ... (2 Replies)
Discussion started by: pm_user
2 Replies

6. Programming

How To Find Unresolved symbol in shared library?

1 . I use Digital Unix V4.0F 2 . I compile a programe which use a shared library . But when I run it( prog.out) , the shell told me that "Fatal Error : /sbin/loader : unresolved symbol in lib3cZap.so" But When I compile proj.out and lib3cZap.so , the compiler said nothing . And I ls -l... (1 Reply)
Discussion started by: chenhao_no1
1 Replies

7. Programming

Unresolved Symbol on HP UX & oracle7

Hi everyone, I have a problem. I do not succeed to linking the oracle7's library for my .so and a Unresolved Symbol :sqlcxt error returns me when I call program. this is my makefile. cc -Ae -I/usr/include/curses_colr -L/usr/lib -DUSE_TERMIOS -D_FILE64 -DDYNAMIC_LIBRARIES_SUPPORTED... (2 Replies)
Discussion started by: luckycs
2 Replies

8. Programming

c++ unresolved symbol

I have this problem: # make gcc -g -D_REENTRANT -DDISABLE_MJPEG=1 -I. -o encmain.o -c encmain.cc ld: 0711-317 ERROR: Undefined symbol: std::string::_Rep::_S_max_size collect2: ld returned 8 exit status but from /usr/local/include/g++v3/bits/basic_string.h : namespace... (0 Replies)
Discussion started by: thalex
0 Replies

9. UNIX for Dummies Questions & Answers

timer_gettime unresolved error

I have used get_time() in my program but when I try to compile it it is giving the following error: ld: Unresolved: timer_gettime (5 Replies)
Discussion started by: basavaraj_m
5 Replies
Login or Register to Ask a Question

Featured Tech Videos