egrep -e not working...!


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers egrep -e not working...!
# 1  
MySQL egrep -e not working...!

Smilie fedora core 2 version 2.6.8-1.521 gnu/linux
the last version of redhat that I was working with linux 8.0 a special version that came with a book.. on this version and on spider tools linux 0.9 the second version I worked with.. when i envoked egrep -e from file1 to file2 I would get the needed results..
forinstance (its been a while so I forgot how i did this on the linux 0.8 and 0.9 but I am sure that it doesn't work at all on this version )
file one has a list of inodes;;;

ex,.
file 1

4636438
3938489
3737473
3883498
3409099

i could just load up the command line with something like this and i would get all the info I need and had...

ls -ali -R /home/$user/Filesystem1 | egrep -e file 1
and this would give me all the feed back in
ls -ali form......

I have tried all the different possibilities and I am getting no result.. is this because I am making a mistake, or is it the posix that i am working with... or is it a different command on this version..
would appreciate the feedback..
thanx moxxx68Smilie
ps .. all the inodes are in directories beneath the Filesystem1 slocate//
# 2  
CPU & Memory

Smilie sorry my mistake I just tried it again in a different format and it worked..
the format is
egrep -e file 1 | ls -ali -R /etc/etc/etc

no need for answer..
unless some one can point out another way to use this...
which I am not sure of..
how and what would i use ;;;; egrep -e file1 file2
sorry!
thanx moxxx68Smilie
# 3  
Data need help with egrep -e file1 file2

Smilie egrep -e file1 | ls -ali -R works but still not that good..
the real problem is making egrep -e file1 file2 work I can't seem to make it work :

file 1
2732058 -rw-rw-r-- 1 moxxx68 moxxx68 5057 Sep 18 08:01 ./databaseI/Quantum.unix/jotter.a/jotter.b/component_infusion.txt-2
2731333 -rwsr-s--T 1 moxxx68 moxxx68 4496 Sep 4 15:13 ./databaseI/Quantum.unix/jotter.a/jotter.b/jotter.c/jotter.d/matrix_profusion.txt-2
2732086 -rw-rw-r-- 1 moxxx68 moxxx68 6589 Sep 21 05:12 ./databaseI/Quantum.unix/jotter.a/jotter.b/jotter.c/concpt_fusion.txt-3
2731590 -rwsr-s--T 1 moxxx68 moxxx68 3563 Sep 3 21:26 ./databaseI/Quantum.unix/jotter.a/jotter.b/jotter.c/concpt_fusion.txt-2
2731983 -rwxr-x--T 1 moxxx68 moxxx68 3322 Sep 12 07:52 ./databaseI/Quantum.unix/jotter.a/unix_cofusion.fle-2
2732045 -rw-rw-r-- 1 moxxx68 moxxx68 6785 Sep 15 23:12 ./databaseI/Quantum.unix/jotter.a/unix_cofusion.fle-3
2731287 -rwsr-s--T 1 moxxx68 moxxx68 2502 Sep 3 15:12 ./databaseI/Quantum.unix/Capacity/composite2/procedural_essentials.fls-3
2731269 -rwsr-s--T 1 moxxx68 moxxx68 3225 Sep 2 06:45 ./databaseI/filesys/quarx_logic1/mechanisms.nts-3
2732090 -rw-rw-r-- 1 moxxx68 moxxx68 3817 Sep 22 12:07 ./databaseI/level1/level2a/level3/consistency_log.loc-2
2731455 -rwsr-s--T 1 moxxx68 moxxx68 4110 Sep 4 11:15 ./database4/run_level3/unix_programm.fls-2
2732005 -rw-rw-r-- 1 moxxx68 moxxx68 4572 Sep 14 15:32 ./database4/run_level3/core_managmnt/core_text1/substructures.E-1
2732088 -rw-rw-r-- 1 moxxx68 moxxx68 3358 Sep 22 21:54 ./database4/run_level3/core_progs.E-1
2731696 -rwxr-xr-x 1 moxxx68 moxxx68 5389 Sep 8 21:46 ./database4/run_level3/unix_programm.fls-3
2731460 -rwsr-s--T 1 moxxx68 moxxx68 4522 Sep 1 22:02 ./databaseii/logbase1/section.a/method3/VPD_mangment.fle-1
2731467 -rwsr-s--T 1 moxxx68 moxxx68 1760 Sep 3 15:56 ./databaseii/logbase1/section.a/method1/potentials1/logical_iosphere.loc-4
2731579 -rwxr-x--T 1 moxxx68 moxxx68 2525 Sep 12 08:14 ./databaseii/text2/mainstream.nts-3
2732009 -rwsr-s--T 1 moxxx68 moxxx68 4802 Sep 12 08:03 ./databaseii/text2/mainstream.nts-2
2730938 -rwsr-s--T 1 moxxx68 moxxx68 10287 Sep 2 17:43 ./databaseii/text3/coordinates/mainframe1/logg_pad.fle-3
2731516 -rwsr-s--T 1 moxxx68 moxxx68 353 Sep 2 15:26 ./databaseii/text3/coordinates/mainframe1/logg_pad.fle-2
2731536 -rwsr-s--T 1 moxxx68 moxxx68 58 Sep 2 08:47 ./databaseii/text3/coordinates/mainframe3/mainframe_function.fle-2
2732098 -rw-rw-r-- 1 moxxx68 moxxx68 3967 Sep 23 06:11 ./databaseii/text3/coordinate_unix.nts-1
2730944 -rwsr-s--T 1 moxxx68 moxxx68 4790 Sep 3 19:51 ./databaseii/text1/Ntpad.nts-3
2731564 -rwsr-s--T 1 moxxx68 moxxx68 3063 Sep 3 16:56 ./databaseii/logbase2/section.c1/standardized_text.txt-3
2731986 -rwsr-s--T 1 moxxx68 moxxx68 3385 Sep 6 00:35 ./databaseii/logbase2/functional_unix.txt-2
2732043 -rw-rw-r-- 1 moxxx68 moxxx68 2251 Sep 16 09:11 ./databaseii/logbase2/functional_unix.txt-3
2731913 -rwsr-s--T 1 moxxx68 moxxx68 1722 Sep 4 18:35 ./databaseV/objectivity1/notePd.nts-4
2731398 -rwsr-s--T 1 moxxx68 moxxx68 5118 Aug 28 03:40 ./databaseV/objectivity1/notePd.nts-3
2731961 -rw-rw-r-- 1 moxxx68 moxxx68 5620 Sep 17 21:07 ./databaseV/objectivity3/command_line.nts-2
2732051 -rw-rw-r-- 1 moxxx68 moxxx68 5547 Sep 17 17:08 ./database3/quadrant.b/co_management.loc-3
2731205 -rw-rw-r-- 1 moxxx68 moxxx68 5557 Sep 16 13:01 ./database3/quadrant.d/logg.nts-3
2732037 -rw-rw-r-- 1 moxxx68 moxxx68 1968 Sep 16 16:59 ./database3/quadrant.a/matrix.txt-3
2730935 -rwsr-s--T 1 moxxx68 moxxx68 6768 Sep 3 23:22 ./database3/quadrant.a/matrix.txt-2
2731993 -rw-rw-r-- 1 moxxx68 moxxx68 2216 Sep 14 18:10 ./database3/matrix.d/expansion_analysis.E-1

file2

2732058
2731333
2732086
2731590
2731983
2732045
2731287
2731269
2732090
2731455
2732005
2732088
2731696
2731460
2731467
2731579
2732009
2730938
2731516
2731536
2732098
2730944
2731564
2731986
2732043
2731913
2731398
2731961
2732051
2731205
2732037
2730935
2731993


according to what I understand egrep -e file2 file1 or file1 file2 should give the same results of file1.. this does not work.\
any one have any suggestions... what I am trying to do is lock away a certain file and keep inodes on a different apparetus (this one) using a usbdevice i should be able to retrieve the data without a trace of the information on this computer..
if anyone can explain any of what i may be trying to do with the egrep -e command in a more easily understood manner.. i would appreciate it..
thanx moxxx68..
ps.. to NEO i hope you don't have hackers on your site I feel a little uneasy showing some of my data but i have no other way of showing an example of what I am talking about..
thanx thanx moxxx68
:
i have a feeling that I have the wrong inode numbers due to the way I created log1

find . -type f -mtime -30 -exec ls -ali -R | awk '$10 !~/foo|bak|gz|temp|swp/ && $10 ~ /-[1-4]/'
would this give me a different set of inodes than on the filesystem..
Smilie


Last edited by moxxx68; 09-26-2004 at 06:53 AM..
# 4  
Moxxx68, I was wondering why you mentioned fedora on this forum. Doesn't the fedora project fall under the category of linux? One way or the other, I'm happy to help.Just explain the terms a little clearer and maybe I can give you an answer.





ComputekwesSmilie Smilie
# 5  
Question egrep -e file1 file2 does not work..

Smilie on this version of linux I am having a harder time with the command than I was having with linux 0.8 or 0.9 (redhat).. according to what I know I should be able to extract all the information from file1 to file2 which has only a portion of the file using egrep -e command.. like sed -f
or awk -f ;
sed -f file2 file1 ( will giive a script to file)
awk -f file2 file1 (will give relative commands to a file)
egrep -e file2 file1 ( will extract data from file 1 to file 2 as long as file 2 has data that is relevant to file1)
this is not worklng..
I am wondering if this is because of the version of the linux I am using, something I am doing wrong, or is this a different command option on this linnux flavor... and if it is what is it?
thanx moxxx68Smilie
ps .. i mentioned the flavor and version to calrify the actual software that I am using.. just in case that has something to do with it.. and also because usually in a situation where matters are a little unclear the first question is what type of software are you working with etc etc,,,

Last edited by moxxx68; 09-26-2004 at 04:21 PM..
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #583
Difficulty: Easy
Buffered input/output is used because I/O operations can slow the system down.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Disk Space Utilization in HTML format working in one environment and not working on the other

Hi Team, I have written the shell script which returns the result of the disk space filesystems which has crossed the threshold limit in HTML Format. Below mentioned is the script which worked perfectly on QA system. df -h | awk -v host=`hostname` ' BEGIN { print "<table border="4"... (13 Replies)
Discussion started by: Harihsun
13 Replies

2. UNIX for Beginners Questions & Answers

Egrep command is not working for me

my file is below REREGISTER is something to Failed to create the request Failed to create the request in not easy I know how REREGISTERcommand i run is egrep 'REREGISTER|Failed|to|create|the|request' test1 expected output REREGISTER is something to Failed to create the request i should... (2 Replies)
Discussion started by: mirwasim
2 Replies

3. Shell Programming and Scripting

Automating pbrun /bin/su not working, whenever manually it is working using putty

I am trying to automate a script where I need to use pbrun /bin/su but for some reason it is not passing thru the pbrun as my code below. . ~/.bash_profile pbrun /bin/su - content c h 1 hpsvn up file path I am executing this from an external .sh file that is pointing to this scripts file... (14 Replies)
Discussion started by: jorgejac
14 Replies

4. Shell Programming and Scripting

Egrep

Hi I am trying to run CMD that combining EGREP and PERL in multiple files cat *07:00.22-12-13.txt | egrep" NAME| perl -ne 'print if /^sid9/ .. /^!/' " I need the see the NAME and the text from sid9 to ! how can I use the EGERP in parallel to the PERL ? This is one file Qqq... (2 Replies)
Discussion started by: sharong
2 Replies

5. Shell Programming and Scripting

Egrep not working with -f option

Hi, I am trying to find out patterns in file 1 using patterns stored in file 2. Following is the code FILE1=inputfilename FILE2=blacklist blacklist 1203 97715555 20afEOF egrep -f $FILE2 $FILE1 but the above code is not working either using egrep or grep. Just for your... (10 Replies)
Discussion started by: siramitsharma
10 Replies

6. Shell Programming and Scripting

matching a regex using egrep not working

Hi, I'm trying to validate if a string matches a regular expression, but it is not working. Am I missing something? Do I need to scape any of the characters? if echo 'en-GB' | egrep '({1,8})(-{1,8})*' >/dev/null; then echo Valid value fi Thanks in advance (6 Replies)
Discussion started by: skrtxao
6 Replies

7. UNIX for Dummies Questions & Answers

help on egrep

HI, I have two files filea, fileeb filea z283110z67 xx65686377 xx654681zz xx652836xx xx653881zz xx65480z11 xx654z5466 xx65510000 xx65670000 xx656z0000 xx656z1822 fileb (3 Replies)
Discussion started by: krao
3 Replies

8. UNIX for Dummies Questions & Answers

search ")" with egrep - egrep: syntax error

Hi Guys, we have a shell script which basically query the Database which retrieves huge data and use the data with "egrep" . Now there is some data which contains characters like "abc)" and the same is used like below : "egrep (.+\|GDPRAB16\|GDPR/11702 96 abc)\|$ temp.txt" now while... (7 Replies)
Discussion started by: sagarjani
7 Replies

9. Shell Programming and Scripting

help on egrep

Hi there, How many multiple values can be in egrep for seraching? i am giving more values but i am getting the error like Unknown error. My input in extended to 2nd line. my command is like below. egrep -i -h... (2 Replies)
Discussion started by: arund_01
2 Replies

10. UNIX for Dummies Questions & Answers

Egrep cheat sheet anywhere? Looking for meaning of egrep -c

Hi I've been searching google and have not found what egrep -c means. Does anyone know where I can get a cheat sheet or what that -c means? thanks, Linda (2 Replies)
Discussion started by: leelm
2 Replies

Featured Tech Videos