Visit Our UNIX and Linux User Community

Permissions issue with webserver and svn

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Permissions issue with webserver and svn
# 1  
Old 01-05-2011
Permissions issue with webserver and svn

Update: Please anybody can give some help ?

I've an issue with files ownerships.

I have a drupal website and the "files" folder needs to be owned by "www-data" in order to let the users to upload files with php.

However I'm now using svn and I need all folders and files to be owned by my ubuntu user in order to work.

Files have 775 permissions, so both user and group have full access to the files.

I've added my ubuntu user to www-data group but it still doesn't work. I dunno why.
I've tried to change the group to my ubuntu user group but it still doesn't work.

I've also tried to set my ubuntu user as owner, and www-data as group, but in this case the webserver php script cannot anymore upload files into the folder (and this is again strange because the group has full privilegies).


Last edited by aneuryzma; 01-05-2011 at 07:51 AM..
# 2  
Old 01-08-2011
Not sure to understand your issue, but, if you suspect permission problems, su to the user and try to write at that directory.
su - www-data ; cd /path ; touch test_www-data
su - ubuntu; cd /path ; touch test_ubuntu

if both works, the problem is elsewhere.
Btw, why do you want both to write at the same dir?

Last edited by Scott; 01-08-2011 at 08:18 AM.. Reason: Code tags

Previous Thread | Next Thread
Test Your Knowledge in Computers #590
Difficulty: Easy
In a linear search algorithm, the input size is the number of elements in the collection (n) divided by 2.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Making post down hook script for svn regarding sending emails after an file is committed in svn

Hi Folks , I am asking this question but i apologise please if this is not the correct forum , I have to develop a shell script that i want to place in at hooks/post-commit , that is basically i have to develop a post hook script and the main functionality of that script would be lets say if... (0 Replies)
Discussion started by: sunsun06060606
0 Replies

2. Shell Programming and Scripting

Svn export issue

Hi all, When i do "svn export <URL of the specific file in svn>" it gives me file which is of older version instead of a file which is of latest or current working version. On the other hand, "svn co <URL of the directory in svn>" It gives me latest version committed files and... (0 Replies)
Discussion started by: nnsjw702
0 Replies

3. Solaris

Permissions issue

Hello, I'm having an issue with a directory that is used to forward Windows logs. I have a user account on Windows servers that uses SCP to put logs on my Solaris 10 server. A appliance called LogLogic then takes the logs from my server and stores them. I need to have have group read so the... (8 Replies)
Discussion started by: bitlord
8 Replies

4. Shell Programming and Scripting

Issue with svn update using cron job.

I want to update svn code using a nightly job using cron, i have created a job in cron as, 30 17-19 * * 1-5 /home/saprab/ <branch> <svnusername> <svnpassword> >> <logfile> 2>&1 : =============== #!/bin/bash branch=$1 svnuser=$2 svnpass=$3 cd ${branch}... (2 Replies)
Discussion started by: bhavesh.sapra
2 Replies

5. Solaris

How to integrate SVN client to SVN server repository.

Hi, I am new to SVN configuration on Solaris 10.I have installed SVN client version 1.7. bash-3.00# ./svn --version svn, version 1.7.4 (r1295709) compiled Mar 2 2012, 12:59:36 Here my requirement is how to integrate svn client to One of the SVN server repository. My repository... (0 Replies)
Discussion started by: muraliinfy04
0 Replies

6. UNIX and Linux Applications

SVN user permissions trouble

I am trying to add a user to my SVN server that can only access one of about a dozen repositories I have set up. Here are the files that I think need changed and what I have set them to. No matter what I try with these files I am unable to see the results I am after. In the end I want this new... (0 Replies)
Discussion started by: benn600
0 Replies

7. Red Hat

SVN subversion performance issue.

Hello to everyone, I am having svn performace issue. Whenever i am doing svn checkout it's slower on one machine than other Xen machine. I will try to explain what is goin on here. I have 3 machine and all three running linux (Centos 5) Machine A is running Svn server. Machine B... (6 Replies)
Discussion started by: email-lalit
6 Replies

8. Linux

permissions issue

We are trying to run a program on a Red Hat ES3 machine that works fine under root user but not as any other user. I believe its getting denied access to the USB ports (which this program needs), Does anyone know how i can open up access to the USB ports on a machine to all users. Thanks, Frank (0 Replies)
Discussion started by: frankkahle
0 Replies

9. HP-UX

Issue with setup.hp file for webserver

Hi All, I have an issue in writing the shell script to install a webserver on UNIX system. My shell script look something like this. ------------------------------------------------------------ echo "start of the script" #! /bin/sh cd /home/path echo | setup.hp -is:javaconsole -console... (1 Reply)
Discussion started by: vishalm
1 Replies

10. Filesystems, Disks and Memory

group permissions/webserver

Hi, there is one strange situation with directory permissions that I run into every now and then, and now I face it a gain with a webserver. Situation (example): drwxrwsr-x 14 user www-data 4096 Jul 28 11:06 . drwxr-xr-x 2 www-data www-data 4096 Jul 28 11:06 subdir -rwxr-xr-x 1... (3 Replies)
Discussion started by: doozer
3 Replies

Featured Tech Videos