Compiling gcc to compile make to compile yaboot

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Compiling gcc to compile make to compile yaboot
# 1  
Old 01-02-2011
Compiling gcc to compile make to compile yaboot

I have just installed OpenBSD on a 333MHz PPC iMac G3. It has a 6GB HDD that has been partitioned as 1GB MacOS 8.5.1, 3GB MacOS X 10.3.9, 2GB OpenBSD 4.8. I now need to install a bootloader so that my computer can recognize the OpenBSD partition at startup. I have been trying to install yaboot-1.3.16. The INSTALL instructions that came with yaboot say that the fastest way to install yaboot is to run "make install". When I try to do this from the Terminal in MacOS X I am given the error message "-bash: make: command not found". So I downloaded GNU Make 3.82 from and tried to install it according to it's INSTALL instructions which say to "`cd' to the directory containing the package's source code and type `./configure' to configure the package for your system." This is what I get:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... config/install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... no
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/make-3.82':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

So from here I decided to get the Xcode Tools disc that came with the MacOS X install discs and install gcc. Due to space constraints on my HDD I can't install all of the Developer Tools that are on the Xcode Tools disc so all that was installed is gcc. So after all this I tried to install Make 3.82 again and still get the same error message listed above. I checked the config.log for details as it says to do, but at my novice level it makes no sense to me. At this point I'm just hoping that someone can give me an easy solution that will allow me to choose which OS I'd like to boot into at startup.

Thanx in advance.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Programming

I can't compile (gcc) in Solaris 11.3 non global zone

I can't compile anything, the final make error says "Command failed for target `install-recursive'", but I am not able to identify the root cause of that error, I tried with cc, gcc 4.5, also gcc 5.2, using make, using gmake 3.82, ld 5.11, gld 2.31... and I am totally stuck yet... please help, to... (4 Replies)
Discussion started by: sugar222
4 Replies

2. Red Hat

How to compile httpd using gcc in RHEL?

Hi All, I am trying to compile httpd2.2.19 in RHEL5.5 using gcc version 4.1.2. This is first time I am trying to compile httpd in RHEL. I ran configure with below option ./configure --prefix=/usr/local/apache --enable-rewrite --enable-ssl=shared... (0 Replies)
Discussion started by: kalpeer
0 Replies

3. SuSE

Can't compile or install GCC

Hi all! I have posted in the Shell Programming Scripting Forum for a problem with the use of shc and so on... You can read it complete here: shell-programming-scripting/148510-problems-using-shc.html I think the problem is: that there aren't compiler installed on the SuSe 10.2 server,... (4 Replies)
Discussion started by: Magius
4 Replies

4. AIX

Compile gcc on AIX 5.2

I'm trying to compile gcc 3.4.6 on AIX 5.2 but I get this error: bison -t --name-prefix=java_ -o java/parse.c java/parse.y M4sugar requires GNU M4. Install it before installing M4sugar or set the M4 environment variable to its path name.make: *** Broken pipe gcc -c -g -O2 -DIN_GCC -W... (7 Replies)
Discussion started by: untamed
7 Replies

5. Programming

New to C/gcc compiler - compile error.

I am new to comiling c/c++ programs with gcc compilier unix - AIX version 5.3 gcc compiler version - 4.0.0 My makefile. # makefile 1.0 08/20/98 #CC = cc CC = gcc ESQL = esql CFLAGS = -Wall DBSLIB= DBSLIB=-L${INFORMIXDIR}/lib/esql -L${INFORMIXDIR}/lib `esql -libs` ALL = hds_near... (9 Replies)
Discussion started by: anish
9 Replies

6. Programming

How to compile a c program by using gcc

Hi all, Yeasterday I try to compile c program by using cygwin. I just find an errors the fist one is concerinig about the end of the line. To summit my Assignment which is the day after tommorow I have to compile my c program by using just gcc. If any one know what do I have to... (5 Replies)
Discussion started by: Bell
5 Replies

7. Shell Programming and Scripting

who to compile needed libs with Make

Hello all my project is contains 2 directories, 2 directories are building library and one for the executable that using the libes from the other 2 Now what im doing is compiling first the 2 libs directories and then the main directory. But I will like to automate the process and to be able ... (0 Replies)
Discussion started by: umen
0 Replies

8. AIX

RS/6000 gcc compile large file error

hi, everybody£º i have a question, pls help me¡£ OS : RS/6000 AIX 4.3.3 cPU : Powerpc,POWER3 compiler : gcc 3.2.3 source file £º 8M OS kernel : 32 bit (selecting at installing operating system, the hardware support 64 bit) when i compiling the large source file (8 M), i... (3 Replies)
Discussion started by: q30
3 Replies

9. Programming

Error in compile C by gcc

Hi all, I compile my c program and get following result hrnpfc01.c:1387: stray '\' in program hrnpfc01.c:1387: parse error before `,' hrnpfc01.c:1388: stray '\' in program hrnpfc01.c:1388: parse error before `,' hrnpfc01.c:1396: stray '\' in program hrnpfc01.c:1396: parse error before... (4 Replies)
Discussion started by: zico
4 Replies

10. Programming

How to compile using gcc...

I need to know how to make a binary with gcc. I know how to create an obj file, but I'm not quite sure what to do about the linking part. I've gotten this far "gcc -c somefile.c somefile.o" then I'm left with an object file, but I don't see any linking command line options. Does anyone know how... (4 Replies)
Discussion started by: lilprogrammer
4 Replies
Login or Register to Ask a Question

Featured Tech Videos