Login or Register to Ask a Question and Join Our Community


Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers apm...??
# 1  
Old 09-14-2004
Question apm...??

I have a HP pavillion laptop and gnu\linux feodra core 2 2.6.8-1.521 version of red hat.. and it does not support apm.. when I enter apm on the command line it gives prompt... "kernel does not support apm"..
also there is an acpi for the battery which controls the suspend and standby also the minutes(info).. to activate this its telling me something about that the acpi is still in developement and and should only be activated with extreme care.. does anyone know what is going on with apm.. and what fedora is talking about with the acpi... and how should I acativate one or the other.. (no man pages for acpi!!)
thanx moxxx68
# 2  
Old 09-14-2004
To enable acpi on my SuSE 8.2 laptop (Kernel 2.4.20) I had to recompile the kernel to incorporate acpi support. Then it worked like a charm.

# 3  
Old 09-14-2004
MySQL to Zazzybob!!

Smilie I felt a little ruthless and I have back ups of my data so I activated acpi anyway... it made a few errors here and there but when I turned off my computer and turned it back on everything was back to normal.. !! also how do you recompile the kerlnel ??????
thanx moxxx68
# 4  
Old 09-14-2004
Recompilation of the Kernel has been discussed many times within the Linux forum on this site.

If that doesn't help, STW and ye shall find.

Also, do not be "scared off" when people mention recompiling the kernel. As long as you have a bit of experience, and select options carefully, there's not a great deal to it. Be sure you read up on it thoroughly before hand. Also, keep a backup of your current kernel whilst you test your new kernel - that way you can roll back if it all goes up the creek.

# 5  
Old 09-15-2004
MySQL to Zazzybob... will do!

Smilie thax for the input.. infact one of my main goals for the coming year 2005 (the second year of unix for me) is to acquire someknow how into accessing the kernel and the operating system.. so far I have managed to get into shell scripting, c programming and and some device file usage and that has worked out pretty well.. on top of the first three aplications that I learned to use, sed, grep and awk.. . if there is information on this site about recompiling the kernel and other such subjects I will probably find it..
thanx for the tip moxxx68Smilie
# 6  
Old 09-16-2004
Fedora should have a pretty well-rounded palette of modules. Try just typing 'modprobe apm' before you type 'apm'.
# 7  
Old 09-16-2004
Bug to Karma..

Smilie i typed in modprobe apm and all that I got was a message that there is no such command.. could it be that I need to update my software.. and would I use the installation disk or the download sites that are available on google.. infact I read something to the extent of modprobe today on google linux acpi,,,, I did'nt quite understand everything so I book marked the page.. but according to the notes that I read acpi is the new version of apm on most linux software that is still in developmental stages and apparatnly is not stable.. but I think I have the right page to try and recompile the kernel as Zazzybob suggested.. but I would sincerely appreciate your opinion too. my question to you is could or can I download the modprobe rpm(??) and if i did could I go about configuring the acpi that way. not too be too longwinded but I would rather use apm as my laptop manager.. what do you think..?
any suggestions appreciated thanx moxxx68..Smilie Smilie
Login or Register to Ask a Question

Previous Thread | Next Thread

2 More Discussions You Might Find Interesting

1. BSD

NetBSD 6.1.2: apm and admd not found

I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system? Is it necessary to recompile the default amd64 kernel to use apm? Or is there a new method for power management and suspend/resume? (2 Replies)
Discussion started by: bsdx
2 Replies

2. UNIX for Dummies Questions & Answers

Warning: cannot connect to APM

After installation of SCO Openserver 5.0.7 following warning messegae show at the time of Loading Kernel hd(40) unix.bss warring: cannot connect to APM, error 0x0008 system loaded press <return> to start can any one please help me to solve this issue thanks and best regards hafeez (0 Replies)
Discussion started by: hafizurr
0 Replies
Login or Register to Ask a Question

Featured Tech Videos