can not mount fs

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers can not mount fs
# 1  
Old 12-20-2010
can not mount fs

Hey guys,

i have a computer (from a friend) with win xp home. now he can not boot the system and i want to try to fix it. I don't know what he did but windows says all the time "hal.dll is missing" and so on...
I tried windows restore and helping cons but it's not working.

Now I try to work with knoppix.
fdisk says:
/dev/hda1 * 1      5829 46821411   7 HPFS/NTFS
/dev/hda2    5830 6475   5188995   f W95 Erw. (LBA)
/dev/hda5    5830 6475   5188963+ e W95 Fat16. (LBA)

I try to mount hda5 with:
mount -t vfat /dev/hda5/ /home/knooppix/tmp/

but it says wrong fs type, bad option...

What can I do to mount it?
Thx for helping

Last edited by Yogesh Sawant; 12-23-2010 at 08:13 AM.. Reason: added code tags
# 2  
Old 12-20-2010
hda5 is FAT16. That is a windows 95 drive....

try something like what you already have
mount -t vfat /dev/hda1 /home/win

where "/home/win" is an already exisiting knoppix directory. Although the error you are getting says the FAT16 filesystem is already broken. Can you boot from a windows disk and then try chkdsk on hda5? Is hda5 configured as the boot disk for the system?
# 3  
Old 12-20-2010
Sry I forgott one more information...
There is one more strange thing...

The HDD looks like:

How can it happen?

@jim mcnamara: I tried mount.... but it's the same problem.

Also I tried boot chkdsk in C:\Windows with the result that there is an error. All the others (Windows.x) were fine. HDA1 is configured as the boot disk

Last edited by Yogesh Sawant; 12-23-2010 at 08:12 AM.. Reason: added code tags
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

How to create a new mount point with 600GB and add 350 GBexisting mount point? IN AIX

How to create a new mount point with 600GB and add 350 GBexisting mount point Best if there step that i can follow or execute before i mount or add diskspace IN AIX Thanks (2 Replies)
Discussion started by: Thilagarajan
2 Replies

2. Shell Programming and Scripting

Script to mount nas-share using generated credentials (mount EC 13,32)

Heyas At home i have 1 nas with 3 shares, of which i used to mount 2 of them using a script with hardcoded password and username in it. EDIT: Turns out, its not the script, but 'how i access' the nas share.. (-o user=XY,password=... VS. -o credentials=...). Figured about credential files,... (0 Replies)
Discussion started by: sea
0 Replies

3. UNIX for Dummies Questions & Answers

mount -o

Hi guys. I read the man page for mount command but i didn't understand why we use -o option. could someone help?:D (1 Reply)
Discussion started by: majid.merkava
1 Replies

4. IP Networking

Can't see home folder on one NFS mount but can in another mount on another share

Hello, I have a few Ubuntu 9.10 laptops I'm trying to learn NFS sharing with. I am just experimenting on this right now, so no harsh words about the security of what I'm playing with, please ;) Below are the configs /etc/exports on host /home/woodnt/Homeschool... (2 Replies)
Discussion started by: Narnie
2 Replies

5. UNIX for Advanced & Expert Users

mount -t cifs permission denied by mount -t smbfs works fine

I am having trouble mounting with cifs, but mounting the exact same command with smbfs works fine. The share is on another samba server and is set to full public guest access. # mount -t cifs //servername/sharename /mnt/temp -o password="" mount error 13 = Permission denied Refer to the... (3 Replies)
Discussion started by: humbletech99
3 Replies

6. Shell Programming and Scripting

how to mount my xp FS?

Hi all, I would like to know how to use the format command? I mean i essentially want to mount my windows drives here... For which i needed to know there readings!!! When i tried to do format i was offered one disk(obviously),that was c1d0 i selected that... and choose partitions (twice... (1 Reply)
Discussion started by: wrapster
1 Replies

7. UNIX for Dummies Questions & Answers

mount -o llock -F nfs vs mount -F nfs

Hi, We encountered NFS issue (solaris) especially running on Oracle application. Problem such as forms hang when close button is click, concurrent job shows running status all time. Understand we need to use mount -o llock -F nfs instead of mount -F nfs to eliminate? this problem.. Can... (1 Reply)
Discussion started by: KhawHL
1 Replies

8. UNIX for Dummies Questions & Answers


Hey, need to mount the following below, and new ish to unix.. what is the process.. thanks :b: # format Searching for disks...done AVAILABLE DISK SELECTIONS: 0. c1t0d0 <SEAGATE-ST973401LC-0001 cyl 51057 alt 2 hd 4 sec 702> /pci@1d,700000/scsi@4/sd@0,0 (5 Replies)
Discussion started by: blb
5 Replies

9. UNIX for Dummies Questions & Answers

how to mount?

how do i mounbt a floppy drive in FreeBSD i tryed mount /flp does not work i'm on a laptop (2 Replies)
Discussion started by: amicrawler
2 Replies

10. UNIX for Dummies Questions & Answers

how to mount a hotswap scsi drive on a solaris 2.6 netra box using the mount command?

Hi... question is this: How do I mount an LVD hotswap scsi drive in bay #2 on a netra using the mount command? volmgt doesn't seem to mount it and/or I don't know how to view the drives data if it's formatted which it may not be. This drive is not new out of the box so I'm not sure. ... (4 Replies)
Discussion started by: soulshaker
4 Replies
Login or Register to Ask a Question

Featured Tech Videos