Visit Our UNIX and Linux User Community


Secondary DNS not working


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Secondary DNS not working
# 1  
Old 11-27-2010
Secondary DNS not working

hi guys

I am doing some testing for DNS
I got a master DNS(192.168.2.10) and I setup a slave DNS(192.168.2.11) but when I shutdown the Master DNS my linux client cannot resolve using the slave
any idea way?
This is the named.conf
Code:
options
{
    query-source    port 53;   
    directory "/var/named";
    dump-file         "data/cache_dump.db";
    statistics-file     "data/named_stats.txt";
    memstatistics-file     "data/named_mem_stats.txt";
    listen-on { 192.168.2.10; 127.0.0.1; };
};

logging
{
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };   
};

view "internal"
{
    match-clients        { localnets; };
    match-destinations    { localnets; };
    recursion yes;

    zone "training.com" {
        type master;
        notify yes;
        allow-query { any; };
        file "data/training.com.db";
    };

    zone "2.168.192.in-addr.arpa" {
        type master;
        notify yes;
        allow-query { any; };
        file "data/2.168.192.zone.db";
        };
   
    zone "." {
    type hint;
    file "data/named.ca";
    };
};

Data files

Code:
training.com.db
$TTL    86400
@       IN      SOA     masterdns.training.com root.training.com. ( 
                        2009111914 ; Serial number needs to be increase when zone changes
                        28800      ; Refresh
                        14400      ; Retry
                        3600000    ; Expire
                        86400 )    ; Minimum
                IN       NS  masterdns.training.com.
                IN       A   192.168.2.10 ; 
masterdns       IN       A   192.168.2.10 ; 
secondarydns    IN       A   192.168.2.11 ;
www             IN       A   192.168.2.10 ; 

2.168.192.zone.db
$TTL    86400
@       IN      SOA     masterdns.training.com root.training.com.  (
                                      2009111914 ; Serial
                                      28800      ; Refresh
                                      14400      ; Retry
                                      3600000    ; Expire
                                      86400 )    ; Minimum
          IN    NS    masterdns.training.com.
10        IN    PTR   training.com. ;
10        IN    PTR   masterdns ;
11        IN    PTR   secondarydns ;

Slave DNS
Zone Configuration
Code:
zone "training.com" {
        type slave;
        notify yes;
        allow-query { any; };
        file "data/sec.training.com.db";
        masters { 192.168.2.10; };
    };

    zone "2.168.192.in-addr.arpa" {
        type slave;
        notify yes;
        allow-query { any; };
        file "data/sec.2.168.192.zone.db";
        masters { 192.168.2.10; };

any idea?

thanks a lot
# 2  
Old 11-27-2010
please post contents of /etc/resolv.conf. ensure that both servers are listed in there.
This User Gave Thanks to frank_rizzo For This Post:
# 3  
Old 11-28-2010
yes both are listed

so that means my conf above looks OK?
# 4  
Old 11-28-2010
Did you check the slave to insure it was caching the master data correctly?
This User Gave Thanks to Neo For This Post:
# 5  
Old 11-28-2010
please confirm that your using the same named.conf configuration except for the zone configuration.

does this query work while both nameservers are online?

Code:
dig +trace @192.168.2.11 unix.com a

This User Gave Thanks to frank_rizzo For This Post:
# 6  
Old 11-28-2010
just a moment guys I am doing some more troubleshooting before answering
thanks meanWhile

---------- Post updated at 07:40 PM ---------- Previous update was at 05:21 PM ----------

thanks a lot guy

you gave me some ideas and I recreate the configuration

Slave is working fine Smilie

now one last question

I am using for this

my masterdns resolve google.com
ping google.com is OK

now how can I go the same for my DNS clients....
how can my DNS query and transfer Internet sites to my local DNS clientes?

thanks a lot
# 7  
Old 11-28-2010
Quote:
Originally Posted by kopper
you gave me some ideas and I recreate the configuration

Slave is working fine Smilie
what did you do to fix the issue? please post so others can learn from it.


Quote:
Originally Posted by kopper
now one last question

I am using for this

my masterdns resolve google.com
ping google.com is OK

now how can I go the same for my DNS clients....
how can my DNS query and transfer Internet sites to my local DNS clientes?

thanks a lot

not sure what your asking.
This User Gave Thanks to frank_rizzo For This Post:
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #434
Difficulty: Medium
jQuery is a vanilla JavaScript library designed to simplify DOM-oriented client-side HTML scripting along with offering cross-browser compatibility.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

DNS client added to DNS server but not working

Hi, We have built a new server (RHEL VM)and added that IP/hostname into dns zone configs file on DNS server (Solaris 10). Reloaded the configuration using and added nameserver into resolv.conf on client. But when I am trying nslookup, its not getting resolved. The nameserver is not able to... (8 Replies)
Discussion started by: snchaudhari2
8 Replies

2. Proxy Server

IPtable rules for DNS/http/https traffic for specific hosts only, not working.

Hi there, I have a VPS and am working on a little side project for myself and friend which is a DNS proxy. Everything was great till recently. My VPS IP has been detected by some botnet or something, and I believe SMURF attacks are occuring. The VPS provider keeps shutting down my VPS... (3 Replies)
Discussion started by: phi0x
3 Replies

3. Solaris

DNS Primary and Secondary

hi there, i using salaris 10 as my DNS server. i have 2 dns server primary and secondary. if primary dns server i edit/update, the other secondary dns server must be sync too. How can i configure if dns server (primary) can sync the secondary? (1 Reply)
Discussion started by: tappetmus
1 Replies

4. Emergency UNIX and Linux Support

DNS flush is not working

I have a Linux machine and it seems DNS cache is not getting clear on it. It is still showing old values, even after changing in DNS server by Network team. I did /etc/init.d/nscd restart But still it is showing old values on this server. On my rest of servers in environment, nslookup is showing... (7 Replies)
Discussion started by: solaris_1977
7 Replies

5. Red Hat

Split DNS not working with Bind-9.7

Hi All, Distros of machines : RHEL6 Bind Vesrion : Bind-9.7-3.2 I am trying to set up a test DNS for my home network. I have two rhel 6 machines A and B. Machine A has 2 NICs and is acting as a router also, one NIC is facing intranet and the otehr is facing intranet. On machine A i have... (0 Replies)
Discussion started by: Rohit Bhanot
0 Replies

6. Red Hat

DNS not working

Hi, I have installed RHEL5 as a new build and need get it to resolve to the internet. At the moment I get following: # dig www.google.com ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5 <<>> www.google.com ;; global options: printcmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status:... (9 Replies)
Discussion started by: Duffs22
9 Replies

7. Solaris

dns client not working

Hi All, I have configured linux server as local dns server (practice level). I have given the IP and hostname details in /etc/hosts -bash-3.00# cat /etc/hosts # # Internet host table # ::1 localhost 127.0.0.1 localhost 192.168.1.78 dummy.set.com loghost 192.168.1.57 cent.set.com #... (3 Replies)
Discussion started by: vaibhav.kanchan
3 Replies

8. Linux

Secondary groups not working with NFS (+LDAP)

Im using LDAP for groups and NFS for home dirs. My problem is as follows: I only have a few groups, so it's not the problem everyone else had. When I've mounted a disk over NFS, I need to have my primary group in order to read in the groups I'm a member of. Secondary groups is not working. ... (0 Replies)
Discussion started by: velmont
0 Replies

9. Solaris

OS Problems -no DNS & SSH not working

I just installed Solaris 6/10 without any problems but I didn't connect the network cable when I installed it. Here are my problems: -I can access webpages using IP addrsses but not with domain names -ssh is installed but it is not running ('ps -e | grep sshd' didn't show it) I have been... (4 Replies)
Discussion started by: kungpow
4 Replies

10. UNIX for Dummies Questions & Answers

Secondary DNS question

I have the primary set up, but cannot get the secondary box to answer a query. Here is the message I get: > nslookup dfwnet1 10.26.38.41 *** Can't find server name for address 10.26.38.41: Non-existent host/domain *** Default servers are not available 10.26.38.41 is the IP of the secondary... (3 Replies)
Discussion started by: 98_1LE
3 Replies

Featured Tech Videos