Visit Our UNIX and Linux User Community


ssh trust issue


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers ssh trust issue
# 1  
Old 10-29-2010
ssh trust issue

Hi, i am setting up ssh trust setup between two servers where SVRA is a solaris box and SVRB is a Red Hat Linux.

It is asking for the password all the time.

I have copied over the SVRA:/home/nagios/.ssh/id_dsa.pub as authorized_keys on
to SVRB:/dat01/home/nagios/.ssh/
Code:
-bash-3.00$ ssh -vvv SRVB.test.com

debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug3: start over, passed a different list publickey,gssapi-with-mic,password
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/nagios/.ssh/identity
debug3: no such identity: /home/nagios/.ssh/identity
debug1: Trying private key: /home/nagios/.ssh/id_rsa
debug3: no such identity: /home/nagios/.ssh/id_rsa
debug1: Offering public key: /home/nagios/.ssh/id_dsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
nagios@SVRB.test.com's password:

In order to test the SVRA, i have copied SVRA:/home/nagios/.ssh/id_dsa.pub to a solaris machine SVRC directory /home/nagios/.ssh/aithorized_keys and i can login without a password.

Please let me know where i am wrong in my first set up.

Thanks for your help in advance.

Last edited by Scott; 10-29-2010 at 07:57 PM.. Reason: Code tags
# 2  
Old 10-30-2010
Be sure to add public key correctly (no additional chars (spaces or whatelse) )
# 3  
Old 10-30-2010
This may be a version 1 vs version 2 sshd problem. By taking the least common denominator approach try using rsa keys to start with. By default systems are supposed to fall back to ssh v1, but that can be prevented in the sshd.conf file.

Did you place the public key in a file: authorized_keys in the .ssh directory, where .ssh has correct protections -- 700?
# 4  
Old 11-01-2010
Yes, the .ssh directory has 700 permission.
# 5  
Old 11-01-2010
And did you try rsa keys?
Does the home directory have at most 750? -- the one where the .ssh directory lives?
 

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Ssh issue

Hi All, I am trying to connect between two system , I am facing the issue with -SSH-t-l userid systemname exit ( this is the syntax) It suppose to ask for password , but it throws the error as mentioned below Error is received disconnect from system and remote login for the... (1 Reply)
Discussion started by: sudhainit
1 Replies

2. Shell Programming and Scripting

SSH Trust Testing

Hi, I want test the ssh trust between two host. It works fine if the trust is working fine but if the trust is not working fine it gets stuck. #!/bin/sh >/users/test/ssh.txt for i in `cat /users/test/host.txt`; do ssh test@$i uname -a >> /users/test/ssh.txt test=`cat... (0 Replies)
Discussion started by: Abhayman
0 Replies

3. Solaris

SSH issue

Hi guys. I just installed Solaris 10 and want to enable ssh on it So that i can remotely use it from another location. I read a post on this forum an it was written that SSH is enabled by default. I did a ps -ef | grep ssh and nothing showed up meaning that it isnt running. I even tried... (11 Replies)
Discussion started by: Junaid Subhani
11 Replies

4. Solaris

SSH issue

Facing a SSH issue while creating passwordless login. unix> ./create_ssh In the program, you will be asked and providing 1. SSH private key filename (twice) 2. key passcode (twice) Enter private key filename: id_ss81dev ld.so.1: ssh-keygen: fatal: relocation... (5 Replies)
Discussion started by: flinders1323
5 Replies

5. Solaris

ssh issue

I'm having a problem with an ssh server "SSH-2.0-Sun_SSH_1.1.2" on solaris 10. when i do try to connect from windows using puTTY the server refuse's the connection . when i try to connect using telnet from the same windows machine it accepts the connection and i got the following bannar... (32 Replies)
Discussion started by: h@foorsa.biz
32 Replies

6. Shell Programming and Scripting

ssh2-keygen trust issue

I have two systems SysA & SysB having the same userid sharing the home directory via NFS mount. I need to know the steps to setup ssh trust between these two systems given that both share the home dir. I have tried all the steps to generate the keys & then creating identification &... (2 Replies)
Discussion started by: deo_kaustubh
2 Replies

7. Shell Programming and Scripting

Please Help: How to Call SSH Trust from Cron job.

Hi All, I am tring to excute a SSH trust command from a script which is invoked by crontab. Details: Crontab file contains the following line: 15 00 * * * /users/dummy_user/dummy_script1.sh dummy_script1.sh contains the following line: SSH -1 server_2... (4 Replies)
Discussion started by: suman82
4 Replies

8. UNIX for Advanced & Expert Users

An issue with SSH

Hey Guys! I got two PCs at my place. In the beginning, one of my PCs had RHEL3( say PC1 ) and one had RHEL4 ( say PC2 ). I was able to ssh from PC1 to PC2 and vice-versa. But recently I've upgraded PC1 from RHEL3 to RHEL4. Now when i am trying to ssh from PC2 to PC1, it is not allowing... (1 Reply)
Discussion started by: chakri.penguin
1 Replies

9. SuSE

ssh-keygen trust problem

OK, this is the problem. I have 2 machines TestA ( Suse 9.0 ) TestB ( Mandrake 10 ) and one of our guys wants to scp from TestA to TestB without the password prompt appearing. Sounds simple so far.... Ok, I haven't used ssh-keygen before, so I create identical logins to test what I'm doing...... (4 Replies)
Discussion started by: PaulC
4 Replies

10. UNIX for Advanced & Expert Users

ssh issue

Im using the default ssh program on a solaris 9 system to connect to another server. When connecting to the other host it make me type my password in 3 to 4 times before letting me in. Is anyone familar with this? (4 Replies)
Discussion started by: meyersp
4 Replies

Featured Tech Videos