Problem when I try to Install a Client VPN Cisco


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem when I try to Install a Client VPN Cisco
# 1  
Old 10-18-2010
Problem when I try to Install a Client VPN Cisco

Hi Gurus of UNIX, I have a problem when I try to install a software VPN Cisco in Laptop (HP530).
I do the following procedures:
Part 2 - VPN Client Compilation

  1. We will now set up the vpn client. As there is no official Cisco VPN Client for OpenSolaris X86 available, we will use vpnc.
  2. Install gnu make first:
    # pkg install SUNWgmake
  3. Download the current vpnc client from http://www.unix-ag.uni-kl.de/%7Emass...c-0.5.3.tar.gz
  4. Gunzip and untar it to eg. /opt/build/vpnc-0.5.3
  5. Edit the Makefile (my preferences)
    PREFIX=/opt/vpnc
    ETCDIR=/opt/vpnc/etc
  6. In the Makefile also replace all occurences of install with ginstall
  7. Edit tunip.c and remove the non-posix compliant "| LOG_PERROR" on line 1061. The line should look like:
    {{openlog("vpnc", LOG_PID, LOG_DAEMON);}
  8. We have to change all hardcoded paths in config.c
    Line 156: return "/opt/vpnc/etc/ssl/certs";
    Line 176: return "/opt/vpnc/etc/vpnc-script";
    Line 181: return "/var/run/vpnc.pid";
    Line 459: asprintf(&realname, "%s%s%s", index(name, '/') ? "" : "/opt/vpnc/etc/", name, add_dot_conf ? ".conf" : "");
  9. Edit vpnc-disconnect to point to the correct pid file
    Line 3: pid=/var/run/vpnc.pid
  10. Now we can compile and install the vpnc client. Compiling with SunStudioExpress is left as an exercise for the reader Image
    # make
    # make install
This tutorial is from
Accessing a Cisco VPN with OpenSolaris - Vathorstweb
when I put the command:
#make
appear the following error
andres@opensolaris:/opt/build/vpnc-0.5.3# make install
make: Fatal error in reader: Makefile, line 36: Unexpected end of line seen

Any Guru can help me please
Regardless
Andres
# 2  
Old 10-18-2010
No ./configure with this one? Maybe that is why you had to change so many paths.

Is that the only makefile? There is usually one per directory in these OS makes.

Hopefully, make in your PATH is gmake?

I have seen this error porting stuff, but I cannot remember offhand which flavor of dust-busting made it go away.

Check for hidden characters, ^M, etc with cat -v.
 
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. IP Networking

Cisco 3750 Switch ASA VPN Routing

Hi,I want connect my ASA 5510 firewall to a 3750 switch with RIP routing. Unfortunately,I am having issues passing the VPN subnet through rip to the 3750.I don't understand how the routing table is populated on the ASA. Any suggestions? (0 Replies)
Discussion started by: Ayaerlee
0 Replies

2. IP Networking

Cisco VPN server and client - connection drop

I have a Cisco 1841 router configured as Easy VPN Server. Here is the configuration of the router: Cisco# Cisco#show running-config Building configuration... Current configura - Pastebin.com I have a Centos 5.7 server with installed Cisco VPN client for Linux. The client successfully... (0 Replies)
Discussion started by: rcbandit
0 Replies

3. IP Networking

Cisco VPN pcf and OpenVPN

I was given my pcf file to login to work from home and wanted to use OpenVPN instead of the Cisco VPN client software. Can I use this pcf file with OpenVPN? I attempted to use vpnc: http://wiki.centos.org/HowTos/vpnc but it just times out ?? (2 Replies)
Discussion started by: metallica1973
2 Replies

4. Ubuntu

Ubuntu 10.04 - Unable to connect to Cisco VPN

Hi all, I am trying to configure and connect Cisco VPN on Ubuntu 10.04. I've imported .pcf file. The new vpn conn appears in the VPN Connections option. Now when I select it, it doesn't connect. Nothing happens. I am not able to connect to VPN at all. I tried using kvpnc as well but it... (10 Replies)
Discussion started by: morningSunshine
10 Replies

5. Red Hat

cisco anyconnect VPN client installation??

Anyone had installed Cisco AnyConnect VPN client on RedHat5.3 EL or CentOS 5.3? I tried on CentOS 5.3 but always getting host unreachable error. Same for windows xp works fine. The error log reports: Sep 1 19:14:03 localhost vpnagent: Function: tableCallbackHandler File: RouteMgr.cpp Line:... (3 Replies)
Discussion started by: zing_foru
3 Replies

6. Solaris

Cisco IOS VPN server IKE

How do I tell if Cisco IOS VPN server IKE is running on my solaris 10 system (1 Reply)
Discussion started by: pgsanders
1 Replies

7. Shell Programming and Scripting

continue after connecting to cisco vpn

Hi all, This will save me a tremendous amount of time if i can get this script working. I have alot of sites i need to connect to using cisco vpn and then ssh onto servers to retrieve some info. Its all repetitative and it needs scripted. what i have done so far is put this into a script. ... (0 Replies)
Discussion started by: borderblaster
0 Replies

8. IP Networking

Setup Dial In VPN on Cisco Router

Hello, Does anyone know where I can find configuration information on setting up a dial in VPN on Cicso IOS for a bunch of servers. Could not seem to find anything in search engines. Thanks (0 Replies)
Discussion started by: photon
0 Replies

9. IP Networking

Cisco vpn client

Who in the 64 ubuntu adopted cisco vpn client on the wireless network I downloaded the cisco vpn client for linux but run vpn_install make file when an error in cisco with the help of the document read in half a day, nor do I know this vpn client in the 64 systems in use. Who can help me, a... (1 Reply)
Discussion started by: Eason
1 Replies
Login or Register to Ask a Question

Featured Tech Videos