Visit Our UNIX and Linux User Community

mount extended partition

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers mount extended partition
# 1  
Old 08-31-2010
mount extended partition

Im new here, and may be my question is stupid, but...
Today I run PGP Desktop decript on my 2nd partition ( D:\ ) and when decript finish, I restart my PC.Now when I try to open D:\ its give me: D:\ is not accessable and I lose my files Smilie
So I load Linux live CD ( knoppix ) and try to mount this partition.When I type:

knoppix@Microknoppix:~$ fdisk -l

Disk /dev/hda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x03c503c5

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        2550    20482843+   7  HPFS/NTFS
/dev/hda2            2551       30401   223713157+   5  Extended
/dev/hda5            2551       10614    64774048+   7  HPFS/NTFS
/dev/hda6           10615       17272    53480353+   7  HPFS/NTFS
/dev/hda7           17273       27774    84357283+   7  HPFS/NTFS
/dev/hda8           27775       30401    21101346    7  HPFS/NTFS

/dev/hda2 is the target and Im 100% shure that this partition was NTFS.
Now /dev/hda2 is mounted in /media/hda2 but there is no files.
How can I mount this drive manually?And is there any another method by which i can solve this problem..?
# 2  
Old 09-01-2010
I highly doubt that sda2 was your D: drive, as Windows can't use an extended partition with NTFS, and most versions won't even work with more than 1 primary partition. More likely sda5 was the drive you're looking for.

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. AIX

Can't mount a partition

Hello, today i get some aix errors (can't lock files and strange things) then i umount FS to do a fsck but i get these errors root@omega / > fsck -p /dev/fslv06 The current volume is: /dev/fslv06 Unable to read primary superblock. Unable to read either superblock. I readed on this page... (9 Replies)
Discussion started by: thorin666
9 Replies

2. Red Hat

Warning: extended partition does not start at a cylinder boundary.

Can you please help me to remove this error. Disk /dev/sda: 64.4 GB, 64424509440 bytes 255 heads, 63 sectors/track, 7832 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk... (4 Replies)
Discussion started by: karthik9358
4 Replies

3. UNIX for Dummies Questions & Answers

Mount UEFI partition

I want to gain read/write access to a Windows 8 partition from a linux live cd. Prior to Windows 8, I used ntfs-3g to mount the partition from the command line. The "Fdisk -l" command does not seem to be able to read efi partitions. There must be some new strategy for linux users. This is... (6 Replies)
Discussion started by: jamarsh
6 Replies

4. Red Hat

Is it possible to extend a extended partition raw space in harddisk thru rhel 6

hi all, As going thru LVM concepts in rhel 6, got hit with a question about "how to use the raw partition of an harddisk which extended volume is taken a bit" please find the attached diagram... is it possible to use this raw space with previously created extended partition without data... (13 Replies)
Discussion started by: redhatlbug
13 Replies

5. Solaris

How to mount extended partation?

hi, i have created an extended partition during solaris 11 installation. My question is how this extended partition is mounted , so that i can use this partition for my work. Thanks (2 Replies)
Discussion started by: zeeshan047
2 Replies

6. Solaris

can not mount the selected partition

Dear Brothers First i installed suse linux with the following partition. my hd0 size is 75gb hdc1 swap 1 gb hdc2 native linux 39gb For the rest of the 35 gb i did not create any partition. so i planned to install solaris 10x86 on that free space. When i installed the solaris i... (1 Reply)
Discussion started by: sayed_021
1 Replies

7. UNIX for Dummies Questions & Answers

I've created a partition with GNU Parted, how do I mount the partition?

I've created a partition with GNU Parted, how do I mount the partition? The manual information at is good, but I am sure about how I mount the partition afterwards. Thanks, --Todd (1 Reply)
Discussion started by: jtp51
1 Replies

8. Solaris

how to mount other partition?

dear all, that is my problem : c0d0p1 is nt, c0d0p2 is solaris and other on extended partition is pcfs, so how can i mount it somewhere? because i dont know which one connect from raw to block dev. /dev/rdsk/c0d0p? any help would be great... :) (6 Replies)
Discussion started by: stdout
6 Replies

9. Solaris

can't mount a partition

Hello, I have a problem on my sun station, that run solaris7. To free temporarly a little space on /, I moved a few empty folders (mnt, net, awk, tftpboot) to the /home partition. Unfortunately the system froze just after this...maybe I should not have move this files, I don't know, I am a... (3 Replies)
Discussion started by: nabulus
3 Replies

10. UNIX for Dummies Questions & Answers

How to mount fat16 partition

Hello, I am trying to mount a FAT16 and FAT32 partition on an already installed Redhat system. I have tried to edit the fstab and mtab, and to put in the data I got from fdisk, but it just says cannot find it. The information given by fdisk on /dev/hda is: Device Boot Start ... (4 Replies)
Discussion started by: ghoti
4 Replies

Featured Tech Videos