Visit The New, Modern Unix Linux Community


make 3.82 install help


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers make 3.82 install help
# 1  
make 3.82 install help

Hello. This is what I get when I try to install

Code:
Todd-Sheppards-Computer:~/make-3.82 toddsheppard$ sudo make install
Password:
Making install in glob
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
Making install in config
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
Making install in po
if test "make" = "gettext-tools"; then \
  /bin/sh ../config/mkinstalldirs /usr/local/share/gettext/po; \
for file in Makefile.in.in remove-potcdate.sin quot.sed boldquot.sed en@quot.header en@boldquot.header insert-header.sin Rules-quot Makevars.template; do \
    /usr/bin/install -c -m 644 ./$file \
                    /usr/local/share/gettext/po/$file; \
  done; \
  for file in Makevars; do \
    rm -f /usr/local/share/gettext/po/$file; \
  done; \
else \
  : ; \
fi
Making install in doc
make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/share/info" || ../config/install-sh -c -d "/usr/local/share/info"
 /usr/bin/install -c -m 644 ./make.info ./make.info-1 ./make.info-2 '/usr/local/share/info'
 install-info --info-dir='/usr/local/share/info' '/usr/local/share/info/make.info'
test -z "/usr/local/bin" || config/install-sh -c -d "/usr/local/bin"
  /usr/bin/install -c make '/usr/local/bin'
test -z "/usr/local/share/man/man1" || config/install-sh -c -d "/usr/local/share/man/man1"
 /usr/bin/install -c -m 644 make.1 '/usr/local/share/man/man1'


But when I then go to install aircrack and it says fatal error and that I need make 3.81, I currently am running 3.79. Any help is greatly appreciated.

Last edited by pludi; 08-31-2010 at 02:19 AM..
# 2  
You've installed make (the binary) to /usr/local/bin. Try using the absolute path when invoking, or prepend that directory to your path.
# 3  
Thank you.Umm, can you put that in noob terms?
# 4  
Of course.

The configure script prepares not only the compilation, but also the installation process. And installation is done into the subdirectories of /usr/local, unless specified otherwise by configuration switches, as to not disturb software prepared by the vendor. That means the binaries go to /usr/local/bin or /usr/local/sbin, man pages to /usr/local/man/man?, ...

Now, for the shell to be able to run these binaries, it has to find them. This is done by searching the directories in the (aptly named) environment variable PATH. You can see the current contents by running
Code:
echo $PATH

Note that /usr/local/bin is, if even included at all, mentioned after /usr/bin. This means that the /usr/local/bin/make binary won't be found. There are 3 ways to change this:
  • Change the search order by prepending /usr/local/bin to the path:
    Code:
    export PATH=/usr/local/bin:$PATH

  • Explicitly run the new binary by running /usr/local/bin/make instead of just make
  • Use the switches configure provides to overwrite the systems default make. Note that this could create serious problems if they are incompatible.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #589
Difficulty: Medium
A binary search algorithm requires that the array being searched is sorted in descending order.
True or False?

10 More Discussions You Might Find Interesting

1. Fedora

Make check install and make all install

hi dear i want to know what is different between make check install and make all install? thanks in advane fereshte (3 Replies)
Discussion started by: komijani
3 Replies

2. OS X (Apple)

How should I install 'make' compiler ?

I need too install GDB in order to debug a program. I need to install GDB through the UNIX command 'make install'. I downloaded a full directory of hundreds of files allowing to get a gdb executable but need a compilation before ... The problem is UNIX can't find 'make' command. I work under... (5 Replies)
Discussion started by: shub22
5 Replies

3. Solaris

Problems with make install

Hi all, I'm working on a server with Solaris 10 and I'm trying to install the pptp client version 1.7.2. So, the generation of the execute file is ok, I run the command 'make' and I got the pptp file. Now I have to run the command 'make install' to install the software, but it stops at the... (3 Replies)
Discussion started by: idro
3 Replies

4. UNIX for Dummies Questions & Answers

Difference between configure/make/make install.

Hi, While installation of apache on linux, we perform the below tasks. 1) Untar 2) configure 3) make 4) make install. I wanted to understand the difference and working of configure/make/make install. Can any one help me understanding this? Thanks in advance. (1 Reply)
Discussion started by: praveen_b744
1 Replies

5. Solaris

Gani Network Driver Won't Install - make: Fatal error: Don't know how to make targ...

I attached a README file that I will refer to. I successfully completed everything in the README file until step 4. # pwd /gani/gani-2.4.4 # ls COPYING Makefile.macros gem.c Makefile Makefile.sparc_gcc gem.h Makefile.amd64_gcc ... (1 Reply)
Discussion started by: Bradj47
1 Replies

6. UNIX for Dummies Questions & Answers

install C compiler without make

Hi all, I dont have much knowledge about linux, but want to learn. I have installed Plop linux(PLoP - Home) on USB Flashdrive. I want to install gcc compiler to it. The installation of C compiler ask for make command, which is not found in the distribution. When I tried to install gnu make,... (4 Replies)
Discussion started by: johnsmithgr8
4 Replies

7. UNIX for Dummies Questions & Answers

problems using 'make' install

I am tring to install DBD::Oracle on Solaris 9 box, I issued command type cc type gcc but both are not found. then i manually searched for gcc, i found it and create a symbolic link to it in my directory. $ perl Makefile.pl (works ok) $ make (retuns error below) LD_RUN_PATH="" cc -G... (1 Reply)
Discussion started by: jameskay
1 Replies

8. Linux

Error in issuing a make and make install

Hi, Recently I install a package and try to do a make and make install. However, in the make it gives me below error:- make:Nothing to be done for 'install-exec-am' make:Nothing to be done for 'install-data-am' Can anyone please explain to me what does this mean? I have been trying... (1 Reply)
Discussion started by: ahjiefreak
1 Replies

9. UNIX for Dummies Questions & Answers

make install

Hi all, I am trying to install pam_passwdqc-1.0.2 on my Solaris 9 machines. After I did a make, I did a make install but it returns the follwing output, # /usr/ccs/bin/make install mkdir -p /lib/security install -c -m 755 pam_passwdqc.so /lib/security install: The -c, -f, -n options each... (2 Replies)
Discussion started by: stancwong
2 Replies

10. UNIX for Dummies Questions & Answers

make and make install commands

Hi there, I am installing a package at the moment on to my Solaris version 8 and I have run into a problem with the 'make' command. I have installed the package using the 'pkgadd' command and I am now at the stage where I have to use the 'make' command followed by the 'make install'... (4 Replies)
Discussion started by: gerwhelan
4 Replies

Featured Tech Videos