Visit The New, Modern Unix Linux Community


how to cancel a cronjob if the cronjob still running


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers how to cancel a cronjob if the cronjob still running
# 1  
how to cancel a cronjob if the cronjob still running

hi everyone I'm newbie in this forum hope I can get some help here Smilie

I have a command in crontab that executed every 1 minute
sometime this command need more than 1 minute to finish
the problem is, the crontab execute this command although it's not finish processing yet and causing the system hang

is there any way that can set the crontab to not execute the command if it's not finish yet?

thanks before for your help Smilie
# 2  
Hi,
One way I can think of is to put a check on the script that runs as a part of crontab. Whatever you want to do with the script you do after a check that if any command of similar name is still running. example: lets say if you are running /home/user/script.sh every one minute, then add a check
Code:
ps -ef | grep "script.sh" | grep -v grep

on your script.sh in the beginning

-Raja
# 3  
check for the process before running your command in the script

write a pid file, or grep for the process


Code:
ps -ef |  grep processname | grep -v grep || yourcommand

or something like that

Last edited by funksen; 08-18-2010 at 06:44 AM..
# 4  
ok this my command in the crontab:
*/1 * * * * /usr/bin/php /var/www/xml_updater.php

now, where should I put the grep command that you guys mentioned above?
# 5  
you write a script, from within the script you run your php command, and before that, you place the grep command


Code:
ps -ef |  grep  "[x]ml_updater.php"  || /usr/bin/php /var/www/xml_updater.php

# 6  
Quote:
Originally Posted by funksen
you write a script, from within the script you run your php command, and before that, you place the grep command


Code:
ps -ef |  grep  "[x]ml_updater.php"  || /usr/bin/php /var/www/xml_updater.php

hi Funk, thanks before for your help
I want to know what is exactly the code you give above do?
# 7  
if returncode of grep is greater than zero, eq the process has not been found, execute your script (||)
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #679
Difficulty: Medium
IEEE 802.3 CSMA/CD, CSMA/CD stands for Carrier Sense, Multiple Authorization with Collision Detection.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Cronjob not running on Ubuntu 14.04

I have created a test cronjob using crontab -e that runs a script at /home/cmccabe/cron.sh. I am not sure the script doesn't run though I can call it in terminal. Thank you :). crontab -e (run script sat at 6:10pm)? 10 18 * * 6 /home/cmccabe/cron.sh contents of cron.sh #!/bin/bash... (5 Replies)
Discussion started by: cmccabe
5 Replies

2. Shell Programming and Scripting

cronjob not running but runs manually

hello, i recently switched to a new ec2 box and transferred the cronjobs from the old box. For some reason one of the scripts won't work but it runs manually from the command line. I've read from previous threads it might be an environment issue but I added a line with the path to the script... (2 Replies)
Discussion started by: lencholamas
2 Replies

3. Shell Programming and Scripting

My Cronjob is not running

I created a script, size=`du -sm` size=`echo $size | sed 's/.$//'` size1='30720' if then { find /ask/tarballs -type f -name "*.tgz" -mtime +30 -exec ls -l {} \; find /ask/tarballs -type f -name "*.tgz" -mtime +30 -exec rm -f {} \; } else echo "Directory size doesnt exceed Threshold... (12 Replies)
Discussion started by: shaal89
12 Replies

4. UNIX for Dummies Questions & Answers

Script not running through Cronjob

Hi, I have a .ksh script which updates the database. The script is running fine manually but it is not running through cron.All the file permissions are fine. The script contents are as below: #!/usr/bin/ksh ddate=`date +%Y%m%d` echo $ddate nohup sqlplus crm/crm @db_state_sync.sql >>... (3 Replies)
Discussion started by: shivangi
3 Replies

5. Shell Programming and Scripting

Cronjob not running

Hi, having problem running my cronjob, need the script to run every monday. And the error i'm getting is "No such file or directory", i've tried to change the env to /bin/bash and also /usr/bin/sh but both failed. Need help here. tq 0 0 * * 1 /bin/bash /home/omc/munir/raccli_rnc.sh Rgds... (3 Replies)
Discussion started by: adawiyah29
3 Replies

6. UNIX for Advanced & Expert Users

SYS CRONJOB just not running...

I'm trying to run "SAR -i 60" under #/var/spool/cron/crontabs/SYS 0,10,20,30,40,50 0-6 sh -c "/usr/lib/sa/sa1 60 10 &" 55 23 * 0-6 /usr/lib/sa/sa2 -i 900 -A machine is not running above cron job under "sys" at all. This suppose to run every minutes and all time in 24 hours. When day... (6 Replies)
Discussion started by: deal732
6 Replies

7. Shell Programming and Scripting

Running scripts through cronjob.

Hello everybody, I'm trying to run a shell script in crontab file. But anyhow it's not getting executed. Following is the command that I've used in crontab. 30 07 * * * . ./.cronprofile;/om/reports/reportscripts/jitu/prod/prd_pre_to_post.sh 35 11 * * * .... (3 Replies)
Discussion started by: jitu.jk
3 Replies

8. UNIX for Advanced & Expert Users

Cronjob is not running

hi, I have a shell script which has a sql plus code and unix if else condition. The file is located at root.I logged in as a root user and i have all permissions. I tried to set up a cron job so that the script need to run every minute.the script is running successfully without any problem. I... (2 Replies)
Discussion started by: sanei05
2 Replies

9. Shell Programming and Scripting

Nested loop not running using cronjob

Hi I have created a shell script which uses three nested loops. When the cronjob is running the script there is a for loop which call a function which has two nested for loops. It is going into the function but the for loop in the function is not running. Can someone pleasae give me a solution... (9 Replies)
Discussion started by: bihani4u
9 Replies

10. Shell Programming and Scripting

Shell script not running thru Cronjob

Hi I have a shell script, it run ok if executed from the path it is located at but doesnot run when the same is tried through cron-job. can someone help me please. regards gaurav shrinivas Email address removed (8 Replies)
Discussion started by: gauravshrinivas
8 Replies

Featured Tech Videos