Visit Our UNIX and Linux User Community


Mount NFS


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Mount NFS
# 1  
Old 04-19-2010
Mount NFS

Hi

I have 2 servers, one is running on SunOS SPARC and the other is running on GNU Linux. Since my Linux is very poor I am not sure on how to mount a NFS from SunOS to Gnu Linux. Please help!

Code:
FS at Host Server:

root@rocux4 # ls -ld /data/PCFILES/GTPROD/DWHFILES.NEW
drwxrwxrwx   4 nobody   gentrack     512 Apr 18 03:17 /data/PCFILES/GTPROD/DWHFILES.NEW
root@rocux4 #

I need to mount it as /data/DWHFILES.NEW on to the GNU server with rwx permissions for a specific user: dwprod

Thanks in advance!!
# 2  
Old 04-19-2010
add the entry in /etc/fstab file
Code:
servername:/data/PCFILES/GTPROD/DWHFILES.NEW      /data/DWHFILES.NEW              nfs  exec,dev,suid,rw  1 1

Add an entry in /etc/hosts
Code:
servername    101.135.1.240

as root remount
Code:
mount -a


Last edited by Yogesh Sawant; 04-19-2010 at 04:37 PM.. Reason: added code tags
# 3  
Old 04-19-2010
hi Amit

This is wat i did on the Sun server (rocux4):

Edited the /etc/dfs/dfstab:

Code:
share -F nfs -o rw=wlglnxdw2.meridianenergy.co.nz /data/PCFILES/GTPROD/DWHFILES.NEW

And also i've created a DWHFILES.NEW folder at /data on the Linux box (wlglnxdw2) and changed the ownership to dwprod

Code:
[root@wlglnxdw2 data]# ls -ld DHWFILES.NEW
drwxr-xr-x 2 dwprod dwprod 4096 Apr 19 18:29 DHWFILES.NEW
[root@wlglnxdw2 data]#

So far Im right yeah?

Sp now at rocux4, I will need to do "shareall" and "service nfs start"

and then mount the FS existing on rocux4 to empty /data/DWHFILES.NEW to wlglnxdw2? But im not sure if this command is correct

Code:
mount -F nfs rocux4:/data/PCFILES/GTPROD/DWHFILES.NEW /data/DWHFILES.NEW

Can u check and confirm? Thanks
# 4  
Old 04-20-2010
Quote:
Originally Posted by hedkandi
Can u check and confirm?
GNU mount requires "-t" instead of "-F"
# 5  
Old 04-21-2010
Hi

On Client NFS:

I edited the /etc/hosts entry to allow the host NFS server:

Code:
192.168.141.82  rocux4.xxxx.co.nz rocux4

my team mate added a hosts.allow :

Code:
192.168.141.82 rocux4.xxxx.co.nz

Added this line to /etc/fstab:

Code:
rocux4:/data/PCFILES/GTPROD/DWHFILES.NEW /data/DWHFILES.NEW nfs rw,hard,intr 0 0

Created DWHFILES.NEW at /data on client server wlglnxdw2:

Code:
[root@wlglnxdw2 data]# ls -lrt
total 60
drwx------ 2 root   root   16384 Dec  8 13:17 lost+found
drwxrwxr-x 2 dwprod dwprod  4096 Jan 18 14:11 source
drwxrwxr-x 5 dwprod dwprod  4096 Feb 11 14:43 npx
drwxr-xr-x 7 dwprod dwprod 28672 Apr  1 15:47 ems
drwxr-xr-x 7 dwprod dwprod  4096 Apr  8 10:15 comit
drwxr-xr-x 2 root   root    4096 Apr 19 20:14 DHWFILES.NEW

And somehow this command still fails:

Code:
[root@wlglnxdw2 etc]# mount -t nfs rocux4:/data/PCFILES/GTPROD/DWHFILES.NEW /data/DWHFILES.NEW
mount.nfs: mount point /data/DWHFILES.NEW does not exist

At host rocux4 (SunOS rocux4 5.9 Generic_122300-38 sun4u sparc SUNW,Sun-Fire-V440
#):

added this line in /etc/dfs/sharetab:

Code:
/data/PCFILES/GTPROD/DWHFILES.NEW       -       nfs     rw=wlglnxdw2.xxxx.co.nz,root=wlglnxdw2.xxxx.co.nz

and this line at /etc/dfs/dfstab:

Code:
share -F nfs -o rw=wlglnxdw2.xxxx.co.nz,root=wlglnxdw2.xxxx.co.nz /data/PCFILES/GTPROD/DWHFI
LES.NEW

I cant restart the NFS on host server since theres other servers running as client from it...but i have restarted the NFS on wlglnxdw2 (client) and tried remonting it again but same error?

Any idea on how do i fix this?
# 6  
Old 04-21-2010
Quote:
And somehow this command still fails:
It fails because the designated mount point folder does not exist. Double-check your folder names:

Code:
drwxr-xr-x 2 root   root    4096 Apr 19 20:14 DHWFILES.NEW

Code:
mount -t nfs rocux4:/data/PCFILES/GTPROD/DWHFILES.NEW /data/DWHFILES.NEW

A typo?
# 7  
Old 04-30-2010
LOL, I missed that!!!

well, its done by, someone else did it

there were alot of other things involved, rcp wasnt running and there was an issue with the nfs

...so well someone eventually sorted that out Smilie

but thank you very much! u noticed the detail I had overlooked!!

thank u!!
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #908
Difficulty: Medium
If a Unix shell command line ends with the hashtag #, then the job runs in the background, and the shell does not wait for the job to terminate before printing the prompt and waiting for the next command line.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Mount NFS Share On NFS Client via bash script.

I need a help of good people with effective bash script to mount nfs shared, By the way I did the searches, since i haven't found that someone wrote a script like this in the past, I'm sure it will serve more people. The scenario as follow: An NFS Client with Daily CRON , running bash script... (4 Replies)
Discussion started by: Brian.t
4 Replies

2. Red Hat

NFS mount issue

we are facing a weird NFS mount issue on one of the linux host , a NFS volume of 2.4TB is mounted in the linux host , but df only reports 131g , which exactly matches rootfilesytem size nfs mount filer_filer1:/vol/bug_test/q0 131G 116G 8.5G 94% /nas/bug_test root... (2 Replies)
Discussion started by: skamal4u
2 Replies

3. Red Hat

NFS mount issue

Hi Friends, My source server is HP and my destination is linux. I have to mount a dir thru nfs from source to destn. almost 8 servers i did the same thing and it is working fine but on the 9th server i can't able to mount. Everything i have did for nfs configuration.Even i can able to ping... (1 Reply)
Discussion started by: Mohamed Thamim
1 Replies

4. Red Hat

NFS mount issues

Hi Experts, I have been using Linux (Redhat server 5.6) as a NFS server and it is mounted to 4 linux (SUSE) servers for storing the db logs. I added an entry in fstab in all my 4 clients to make sure the mount is available all the time. but unfortunately the mount is not showing in servers after... (6 Replies)
Discussion started by: sarav
6 Replies

5. IP Networking

Can't see home folder on one NFS mount but can in another mount on another share

Hello, I have a few Ubuntu 9.10 laptops I'm trying to learn NFS sharing with. I am just experimenting on this right now, so no harsh words about the security of what I'm playing with, please ;) Below are the configs /etc/exports on host /home/woodnt/Homeschool... (2 Replies)
Discussion started by: Narnie
2 Replies

6. OS X (Apple)

NFS Mount

Hello! Im trying to mount an nfs share. But got a bit of a problem. The problem im having is that i try to mount The problem is that the my.server.com/pub/home is owned by root. I know i can make a mount point my.server.com://pub/home/username - > /pub/home But that means i have to do... (1 Reply)
Discussion started by: dozy
1 Replies

7. UNIX for Dummies Questions & Answers

NFS mount

I have a NAS server that needs to have the share mounted on a unix server. I am not that familiar with NFS mounts....any help on what I have to do on the UNIX box...thanks! (7 Replies)
Discussion started by: andrewd
7 Replies

8. UNIX for Dummies Questions & Answers

mount -o llock -F nfs vs mount -F nfs

Hi, We encountered NFS issue (solaris) especially running on Oracle application. Problem such as forms hang when close button is click, concurrent job shows running status all time. Understand we need to use mount -o llock -F nfs instead of mount -F nfs to eliminate? this problem.. Can... (1 Reply)
Discussion started by: KhawHL
1 Replies

9. Filesystems, Disks and Memory

NFS mount

Hi All, Can any one help in Mounting remote filesystems with NFS? Thanks in advance. Regards, Suresh. (4 Replies)
Discussion started by: srvaka1
4 Replies

10. UNIX for Dummies Questions & Answers

Mount nfs filesystem

I try to share a directory from a wortstation to a server. the share command was no problem. Solaris 8 on mars share -F nfs -o rw /dir/dir2 on the server mount mars:/dir/dir2 /mount_point RPC: Program not registered <--- What is the meaning of this ? Thanks for you help ! (2 Replies)
Discussion started by: joerg
2 Replies

Featured Tech Videos