Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers pkgadd
# 1  
Old 03-24-2004

I am adding gcc 3.3.2 to my unix box what is the best way
to do it????
# 2  
Old 03-24-2004
the way the instructions tell you.
# 3  
Old 03-24-2004
good one's too easy sometimes Smilie

since the subject is pkgadd, I'm assuming that's an option. It will do everything for you. It's pretty simple.
Do a man on pkgadd.
# 4  
Old 03-25-2004
Optimus_P ...tell them Smilie

pkgadd -d <path to gcc package>

solaris packages usually have .pkg suffix

also if u omit the -d flag it will default to the /var/spool/pkg directory

moral of the story read man page only takes a few minutes !!
# 5  
Old 03-27-2004
Originally posted by silvaman
Optimus_P ...tell them Smilie

moral of the story read man page only takes a few minutes !!
not in most situations. man pages aren't always to the point which is what most unix admins that work in a fast pace environment WANT
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Pkgadd issue

Good Afternoon, I have 3 video driver packages in a directory that need to be installed. on a SunBlade 2500 running Solaris9. When I try running pkgadd -d /Recovery/CloneDrivers/SUNWpfbcf for example, I get pkgadd: ERROR: no packages were found in </var/spool/pkg> Permissions are 755, owner... (3 Replies)
Discussion started by: Stellaman1977
3 Replies

2. Solaris

Pkgadd with firefox

I am using Solaris 10, and trying to keep a number of old Sun workstations running. Since version 17 of firefox, I have had problems using pkgadd, and had to use tar to un-archive the components of firefox. Is this just a problem with firefox (and probably thunderbird), or is pkgadd broken (1 Reply)
Discussion started by: jkoval
1 Replies

3. Solaris

pkgadd changes permissions of /etc

Hi, when I install a package using pkgadd, it correctly installs the binary files with the user name that I want. However it also changes the permissions of /etc/rc2.d. I don't want this to happen. I want to retain original owner of /etc/rc2.d as it is. I could see that before installing,... (1 Reply)
Discussion started by: funwithdolphin
1 Replies

4. Shell Programming and Scripting

pkgadd question

Hi, Please could someone help me, understand how pkgadd works within unix. I have a software file, and I need to package this up and then pkgadd this to another server. Please could some advise me the best way to do this. regards venhart (2 Replies)
Discussion started by: venhart
2 Replies

5. Solaris

Pkgadd error

Hi All, Good Mng,Here I am getting one error while adding the top package to one of my Aun server. root@HYDREM01 # pkgadd -d top-3.6.1-sol9-sparc-local The following packages are available: 1 SMCtop top (sparc) 3.6.1 Select package(s) you wish to process (or... (6 Replies)
Discussion started by: lbreddy
6 Replies

6. Solaris

pkgadd woes

Morning all, I am attempting to load a package from a Solaris 8 CDROM. This fails with the error : "pkgadd: ERROR: unable to access pkgmap file </cdrom/ .........../SUNWlibC/pkgmap> No changes were made to the system" Any help would be appreciated Andy (6 Replies)
Discussion started by: AndyD
6 Replies

7. Solaris


Hi all. Is there an option to #pkgadd to test if package bundle you want to install requires a reboot? #pkgadd -d "package bundle" an option like test or a dry run? Suggestions, anyone? :confused: Reloader (2 Replies)
Discussion started by: Reloader
2 Replies

8. Solaris

pkgadd help

I'm trying to install a package and it worked on most of the sun boxes and one of the box is just freezing and not going further. Her is the output. pkgadd -d packagename.dstream Select package(s) you wish to process (or 'all' to process all packages). (default: all) : Processing... (1 Reply)
Discussion started by: mokkan
1 Replies

9. Solaris


is there an option in pkgadd to accept the default option? I want to use pkgadd in a script and do not want to stop at intercative questions. thx. (6 Replies)
Discussion started by: melanie_pfefer
6 Replies

10. UNIX for Dummies Questions & Answers

Pkgadd / gnutar

I have sucessfully installed GNUtar using pkgadd but with some questions: When I tried to install with pkgadd -d GNUtar (which is the directory of the package) - I received the error "pkgadd: command not found" Then I tried the same but with pkgadd -d. GNUtar and it installed fine. (found... (4 Replies)
Discussion started by: finster
4 Replies
Login or Register to Ask a Question

Featured Tech Videos