MTA problems; root gets no mail


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers MTA problems; root gets no mail
# 1  
Old 02-10-2010
MTA problems; root gets no mail

Hello,

I am afraid that I goofed up my mailing system.

I have an Ubuntu 9.10 system

Code:
$ uname -smor
Linux 2.6.31-14-generic x86_64 GNU/Linux

I am wanting to receive cron job mails. I noticed that cron jobs were trying to send mail to sendmail. I had installed ssmtp so I could send mail using gmail from the command line which also installed bsd-mailx. OOPS! I think this really messed up configurations. After further research, I purged ssmtp and reinstalled bsd-mailx which has postfix as a dependency.

Now, root doesn't get mail (via mail command), but root can send mail to users ok. Users can send and receive mail from user to user.

I think a side effect of this problem is that it messes up cron, as this is the only significant difference between this and other systems I have and they don't have this problem. Now cron processes hangs (the cron job itself completes) and becomes a zombie. Only restarting the cron service fixes it.

Any ideas how to resolve this short of restalling (which I'd rather not do)?

Thanks,
Narnie

---------- Post updated at 06:04 PM ---------- Previous update was at 12:29 PM ----------

More scrounging around showed :

Code:
$ cat /etc/aliases
# See man 5 aliases for format
postmaster:    root

Code:
$ echo "Howdy" | sendmail -v root@localhost
Mail Delivery Status Report will be mailed to <woodnt>.

I think we are on to something here.

No aliases for root to woodnt, but sendmail is sending to woodnt.

BTW, tried sending mail to root from another user not woodnt and neither woodnt nor root got the mail. See this for the results:

Code:
woodnt@toshiba-laptop ~/.xchat2/downloads $ su luke
Password: 
luke@toshiba-laptop /home/woodnt/.xchat2/downloads $ mail root
Subject: Hello
root
Cc: 
luke@toshiba-laptop /home/woodnt/.xchat2/downloads $ exit
exit
woodnt@toshiba-laptop ~/.xchat2/downloads $ mail
No mail for woodnt
woodnt@toshiba-laptop ~/.xchat2/downloads $ sudo su
toshiba-laptop downloads # mail
No mail for root
toshiba-laptop downloads # exit
exit

Any ideas where to go from here?

Last edited by Narnie; 02-10-2010 at 09:03 PM.. Reason: error correction
# 2  
Old 03-25-2010
Double check you don't have a a different file as the alias file in your config (which mean you may think root mail isn't suppose to go to woodnt but in some other file, it's set that way).

Check your mail logs - /var/log/mail.err, /var/log/mail.info, /var/log/mail.log, and /var/log/mail.warn - there are probably clues in there.
 
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

Problems sending mail: Difference between Mail and Mailx?

Whats the difference between mail and mailx? I'm trying to troubleshoot a problem where I can send mail from server A with this `echo $MESSAGE | mail -s "$SUBJECT" -r $FROM $RECIPIENTS` command but executing the same command from server B throws me this error (Both servers are RHEL) ... (1 Reply)
Discussion started by: RedSpyder
1 Replies

2. UNIX for Advanced & Expert Users

[SOLVED] Root mail going to user "mail" instead of root

I running Linux Mint Debian Edition tracking testing and have started a cron job that will send something to the root mailbox. Mint has heirloom and exim4 installed. However, mail was getting nothing. I realized that in /etc/aliases, there was a line root: mintSince you can't log into the mint... (0 Replies)
Discussion started by: Narnie
0 Replies

3. What is on Your Mind?

Most popular mail server(MTA)

Which among the following is most popular choice as a mail server - 1)Sendmail 2)Postfix 3)Qmail Which is the industry preferred one? (2 Replies)
Discussion started by: proactiveaditya
2 Replies

4. AIX

Able to send mail without running MTA (sendmail)?

Hi, I am facing a (for me and coworkers) strange behaviour. When I stop sendmail on a plain AIX 5.3 testing box (there is definetly no sendmail process left running anymore), I am still able to send mails to remote addresses via the mail command. I tried that on another box which is not a... (6 Replies)
Discussion started by: zaxxon
6 Replies

5. UNIX for Dummies Questions & Answers

localhost [127.0.0.1] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA

hardware = raq550 running on strongbolt2. my sendmail log is littered with this entry all through the day: localhost did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA it occurrs every 15 minutes. I don't have any problem sending or receiving mail. I did a search on google but couldn't... (0 Replies)
Discussion started by: tonj
0 Replies

6. UNIX for Dummies Questions & Answers

Non root login problems in AIX

Hi All, I have setup a non root user on AIX 5.3, using smit. When I try logging on as that user my login screen just disappears. I am using PUTTY. I login to the same box as root no problems. I have tried re-creating several different usernames but get the same effect I have also telneted from a... (2 Replies)
Discussion started by: hansul
2 Replies

7. UNIX for Dummies Questions & Answers

Root problems??

So when I log in as root on my eMac (running tiger, 10.4.11), some things don't work or reluctantly work. Examples: Computer:/Users/mat/Desktop root# pico test.doc Error opening terminal: network. Computer:/Users/mat/Desktop root# emacs test.doc Error opening terminal: network. ... (3 Replies)
Discussion started by: razordp
3 Replies

8. Shell Programming and Scripting

ssh root@mrp-gateway problems

Dear friends, exec 0<$SuppFile while read LINE do echo $LINE gatewayArchive=`ssh root@mrp-gateway "cd /usr/local/apache/data/PLAT/MIMUS/upload/PROD/archive && ls $LINE"` echo "gateway files :"$gatewayArchive done this loop is not repeating when i use ssh root@mrp-gateway line of code.... (1 Reply)
Discussion started by: kittusri9
1 Replies

9. AIX

Problems with disabling remote root login

Hello! I'm going through security checklist for AIX 5.3 and i just can't disable remote login for root through ssh. What i did: - in /etc/security/user i added a line: rlogin = false which works fine when i try to login through telnet - after installation of openSSH i edited... (3 Replies)
Discussion started by: veccinho
3 Replies

10. Solaris

mail problems - how to send mail on solaris

Hello I am new user on solaris... I need to configure my solaris to be able to send mails... I know mailx command mailx -s hello address@address.com but I get an error... you have mail in /var/mail/root # hello... User unknown /dead.letter... Saved message in /dead.letter what... (10 Replies)
Discussion started by: amon
10 Replies
Login or Register to Ask a Question

Featured Tech Videos