Visit Our UNIX and Linux User Community


Tape Backup


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Tape Backup
# 1  
Old 01-22-2004
Tape Backup

I have a script which runs overnight to backup a database into a tar file. I then gzip the file and send it off to a tape device.

The command I'm using for the tape backup is

tar cvf /dev/rmt/0n /var/dbbackup/${FILE}.gz

I thought the n meant no rewind so the next file is copied to tape but does not overwrite what's already there. However it seems as though the old files on the tape device are being overwritten i.e. when I do

tar -tvf /dev/rmt/0

I can only see last night's file
-rw-r--r-- 100/100 102192 Jan 23 03:15 2004 /var/dbbackup/AS1.2004012303.bak.gz

What's up with my tar options?
mattd
# 2  
Old 01-26-2004
One possible problem - you mention looking at the tape to see what's on it but you don't use the no rewind option. Anytime you don't use it, the tape will ,by default, rewind. Or anytime anyone doesn't use it the tape will rewind. Check that no one else is attempting to hit the drive - no other cron jobs, users,...
# 3  
Old 01-27-2004
I've had a look but I can't find other jobs hiting this tape.

While investigating I failed the applications over to the secondary box and ran;
# shutdown -i 0
then
ok probe-scsi-all

This sent the box into a "fault bus" error message hissy fit resulting in me having to pull the power cable out the back. Any more suggestions?
mattd
# 4  
Old 01-27-2004
Why would you shutdown the system? (I'm glad I didn't suggest that!)

If this is a SUN system, then sometimes after a shutdown it will hang by doing a probe-scsi-all. Normally all you have to do is a reset and break out (Stop-A) of the boot process to be able to run the proble-scsi-all.

But if you are getting error messages, you might want to see if you have your tape drive set up on the same id as a disk drive (which could cause errors).

Please post the system hardware, OS, and error messages you saw.
# 5  
Old 01-27-2004
The system info is Sun Fire V120 (UltraSPARC-IIe 648MHz), with 1024 MB RAM.

The reason I did a probe-scsi-all was that mt - f /dev/rmt/0 status said no device found. I tried shutting down with

sync; init 0

and probe-scsi-all seemd to better like it.

ok probe-scsi-all
/pci@1f,0/pci@1/scsi@8,1

/pci@1f,0/pci@1/scsi@8
Target 0
Unit 0 Disk SEAGATE ST336607LSUN36G 0307
Target 1
Unit 0 Disk SEAGATE ST336607LSUN36G 0307

ok

and when I do a boot -r the following error is given

NG: /pci@1f,0/pci@1/scsi@8,1 (glm1):
SCSI bus DATA IN phase parity error
WARNING: /pci@1f,0/pci@1/scsi@8,1 (glm1):
SCSI bus DATA IN phase parity error
WARNING: forceload of misc/md_trans failed
WARNING: forceload of misc/md_raid failed
WARNING: forceload of misc/md_hotspares failed
WARNING: forceload of misc/md_sp failed
configuring IPv4 interfaces: eri0 eri1.

As far as I am aware nothing has changed, any ideas?
mattd
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #1005
Difficulty: Easy
Regarding a circle, one full turn of the circle is equal to 2 radians.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

How to backup when there is no tape available?

Hi All! Letīs say there are a few solaris servers connected to a NetApp storage device, but with no tape library or tape device attached to none of them. Assuming the O.S. is installed on the root disks, how to recover if the O.S. failed in one of the systems? Please share your ideas. (13 Replies)
Discussion started by: fretagi
13 Replies

2. AIX

Backup on Tape

Hi, I am very new to AIX, i have a development and a production server with AIX 6.1. I am using following command to backup my system /usr/bin/mksysb '-m' '-V' '-i' /dev/rmt0 You can what i have in my root volume group in the atached file and and you can also see the backup information of... (14 Replies)
Discussion started by: salmanucit
14 Replies

3. UNIX for Dummies Questions & Answers

Backup Tape suggestion

Hi All, I would like some feedback / suggestion /recommendation about backup tape/disaster recovery for linux box as i'm new to linux. We have linux box running as webserver which hosting website files. I know that i have to backup all "website files". Is there any Linux system file i have... (2 Replies)
Discussion started by: c00kie88
2 Replies

4. SCO

Backup to SCSI Tape Backup aborts

I am trying to make a full backup of my system using the cpio command. The Tape Unit is a SCSI DDS. The process started fine but after about 30 minutes, it just stopped and showed the following message: 1755 Signal 31 - Core dumped Any idea of what is causing this and how to fix it? ... (4 Replies)
Discussion started by: zionpc
4 Replies

5. UNIX for Dummies Questions & Answers

Check backup file size on backup tape

Hi, I performed backup on tape and I want to append more files to my previous backup on the same backup tape. But before I do that I need to know the backup file size of the first backup I performed so that I know the available size on the backup tape. Can someone help me what command I will use... (0 Replies)
Discussion started by: ayhanne
0 Replies

6. UNIX for Dummies Questions & Answers

Mounting DLT tape and to backup file to tape

Hi there: I'm new here Can anyone help me: I have DS15 Alpha server : Unix 5.1B Now i need to connect a DLVT VS80 1U Rackmount Tape Drive unit. What is the exact comman to mount the DLTape IV?? How do i make backuo @ copy file to the tape? Thanx to all (0 Replies)
Discussion started by: ayzeayem
0 Replies

7. Solaris

backup to tape - compression?

How can I tell (from the command line) is compression is turned on for a tape drive? I need to backup a system that is approx 150gb to a tape that has 110gb uncompress but 220gb available compressed. Any ideas? Also is it possible to turn compression on or off from the command line? I am... (1 Reply)
Discussion started by: frustrated1
1 Replies

8. Solaris

backup using tape

hello everybody... i need some help ... so... i need to do some backups from one solaris system and i dont know whitch is the best solution....to use tar or ufsdump...? ...and .... how can i restore files from tape if on the tape i have 2 sessions....how can i access second session....? enough... (4 Replies)
Discussion started by: nich007
4 Replies

9. UNIX for Dummies Questions & Answers

How to add backup tape

Hi guys I have a Caldera Openlinux 3.1.1 i'm new with this OS so please bear with me. I have no idea about how to install my backup tape could any of you tell me how to do this. I worked before with unix sco openserver 5.0.6 and i know that you can use scoadmin and then option (tape ). ... (1 Reply)
Discussion started by: josramon
1 Replies

10. UNIX for Dummies Questions & Answers

Tape Backup

Can someone please.... help me how to install tape backup I am using FreeBSD Unix version running on I386 PC box. My IDE tape device is made by HP (Colorado 5GB). Thank you in advance! (15 Replies)
Discussion started by: jackpotp
15 Replies

Featured Tech Videos