PGREP Arguments


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers PGREP Arguments
# 1  
PGREP Arguments

I'm trying to figure out how to use pgrep to pull the arguments of a process.
Given:

Code:
root    308   1  0 00:00 ?     00:00:00 /bin/sh /some/random/path/somescript.sh -flag /another/path/blah

I can get the pid (308) using this command:
Code:
pgrep sh

However, what if I wanted to pull by "somescript.sh" or .*\.sh or something like that? How can I pull the pid by those arguments?

Also, is there a similar way to pkill using the exact same syntax as the pgrep command I'd be using to find this pid?
# 2  
e.g.:
Code:
pgrep '.*\.sh'

pgrep works the same but sends the specified signal to pid.
# 3  
I just tried it.

That returned nothing. But I think your expression was assuming that it ended with .sh (maybe).

I tried pgrep '.*sh.*\.sh.*'
but no dice either.

Any other responses here?

(Also, thanks for the efforts, Scrutinizer.)

---------- Post updated at 03:58 PM ---------- Previous update was at 03:34 PM ----------

I think I found the the answer. I can't do anything about it:

pgrep a process that has arguments
# 4  
Sorry, that should be
Code:
pgrep -f '.*\.sh'

# 5  
YESS!

You, sir, are great. It works.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #158
Difficulty: Easy
The migration of the ARPANET to TCP/IP was officially completed on January 1, 1983, when the new protocols were permanently activated.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Echo/kill pgrep

Hi folks. I'm wondering why the following doesn't work and hoe to fix it... I can: # pgrep foo 1234 I can: # echo | pgrep foo 1234 But I can't # kill | pgrep foo kill: usage: blah blah So why does echo pipe correctly but kill doesn't? (9 Replies)
Discussion started by: MuntyScrunt
9 Replies

2. Shell Programming and Scripting

Pgrep not showing desired output

I am searching for a process that should be up and running. Im using the following command ps -ef | grep elasticsearch to get elastic+ 1673 1 0 Jan29 ? 05:08:56 /bin/java -Xms4g -Xmx4g -Djava.awt.headless=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC... (1 Reply)
Discussion started by: Junaid Subhani
1 Replies

3. Shell Programming and Scripting

Pgrep for processes which are not associated with a terminal in Ubuntu

I would like to find all of the PIDs of processes which are not associated with a terminal and started by CRON. When I do the ps aux | less command, I see in the TTY field a lot of processes with ? character I would like to get those processes ID, is there a way to do that with pgrep? ... (1 Reply)
Discussion started by: ASF Studio
1 Replies

4. Shell Programming and Scripting

Ssh and pgrep not working

I have setup SSH keys . Trying to grep to get PID of remote jvm's . this is what am doing ssh -q testuser1@myhost.com 'PID1=pgrep -fl testapp1|awk "{print $1}";PID2=pgrep -fl testapp2|awk "{print $1}" ' echo $PID1, $PID2 it throws error"sh: -fl: command not found" ---------- Post updated... (1 Reply)
Discussion started by: kondagadu
1 Replies

5. Shell Programming and Scripting

grep with two arguments to arguments to surch for

Hello, is it possible to give grep two documents to surche for? like grep "test" /home/one.txt AND /home/two.txt ? thanks (1 Reply)
Discussion started by: Cybertron
1 Replies

6. HP-UX

pgrep doesn't perform full command line pattern matching

Hi! I need to get PID of some particular process and I wonder if I can use pgrep tool for this purpose. The problem is that pgrep doesn't perform pattern matching on the whole command line, even if I use -f key. Parsing output of ps command is not quite convenient... Also deamon, which PID I need... (2 Replies)
Discussion started by: Sapfeer
2 Replies

7. Shell Programming and Scripting

Too many arguments

echo "the number from 1 to 10:" i=1 while do echo $i i=`expr $i+1' done above is the program i written in Linux O.S using vi editor but i am getting the error that while: line 3: i am not understanding that why i am getting this error. can any body please help me regarding this... (3 Replies)
Discussion started by: bsatishbabu
3 Replies

8. Programming

pgrep returns 256

Hi Everyone, I have a strange behaviour In my c program i use this line: int retval = system("pgrep encoder"); while i expect retval to contain 0,1,2,3 i get 256. did i do something wrong? thanks, Alex (2 Replies)
Discussion started by: alex889
2 Replies

9. Shell Programming and Scripting

[: too many arguments

Hi Guys I have this small Bash script - but it fails when I'm trying to run it. ./test.sh: && ; then # date >> /writable/sys/shutdown.log shutdown -h "now" exit fi done (4 Replies)
Discussion started by: tainted2real
4 Replies

10. AIX

pgrep substitute for porting a linux script to AIX 5.x

Hi, I'm trying to get this script to work on an AIX 5.3 box, I couldn't get pgrep for AIX, I also realize that ps works differently on the IBM boxes. Could anybody just give me the specifics of a work around for my problem, I'll adjust the whole script: #!/bin/bash # applabs.com #to do: #... (3 Replies)
Discussion started by: thebytegrill
3 Replies

Featured Tech Videos