How do I boot second HDD?

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers How do I boot second HDD?
# 1  
Old 10-18-2009
How do I boot second HDD?

I have a Sun Blade 1500 (sparc)
I have two HDD's both configured with Solaris 10.
How do I chose at boot which HDD I want to use?
I've had a look through the FAQ, also done a web search but haven't come up with requisite info.
touch /reconfigure does not seem to help.
Any suggestions appreciated.
Lew Targett
# 2  
Old 10-18-2009
go to obp from os by enter "init 0" as root. after that run the command "devalias" at the <ok> prompt. look for your disk alias (which should be something like disk1 and disk2). now you can choose to boot from this aliases by enter "boot disk1" or "boot disk2".
# 3  
Old 10-18-2009
Hi, thanks.
devalias gives me

disk /pci@1e, 6000000/ide@d/disk@0,0
ide /pci@1e, 6000000/ide@d

(plus the other stuff)

Those two entries seem to be referring to the same disk (?yes)
The second HDD, drive 2, doesn't seem to be there?

Further suggestions appreciated.
Lew Targett

---------- Post updated at 07:52 PM ---------- Previous update was at 07:32 PM ----------

Further to the above
'seems' to show

entering these at the OK prompt gets no response.
Lew Targett
# 4  
Old 10-18-2009
do a "probe-ide" to find your disks or just a "show-disks".
# 5  
Old 10-19-2009
getting closer
probe-ide gives me
Device 0
Device 1
Device 2
When I enter (for Example) Device 1 at the 'ok' prompt, it asks for 'filename'
Help appreciated
# 6  
Old 10-19-2009
these aren't aliases... so you've to use the whole devicepath. would help if you post the complete output.
# 7  
Old 10-19-2009
Thanks again.
As follows, devalias gives

Device 0 (Primary Master)
ATA Model : ST380011A

Device 1 (Primary Slave)
ATA Model : HTS 722580VLAT20

Device 2 (Secondary Master)
Removable ATAPI Model : JLMS XJ-HD166S

Device 3 (Secondary Slave)
Not Present

If I choose, for example,
'Device 1'
and type boot Device 1
I get
boot : cannot open device
Enter filename (Device)

Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Want to dual boot windows/Linux on a ssd/hdd configuration

I have a small ssd (240 GB) and a 1TB hdd. I want to use the ssd to store anything related to Windows (os and other stuff like games) and also the linux bootloader (so linux boots faster). And I want my hdd space to be for linux stuff (like the fedora os, linux packages, etc). Can you help me do... (1 Reply)
Discussion started by: mafiaskafia
1 Replies

2. AIX

IBM AIX Internal HDD vs SAN HDD and Oracle

Hi Folks, I am facing an issue with the performance. P4 with 1 processor and 16 GB RAM and SAN HDD = Oracle report takes 25 minutes P5 with 2 processors and 16 GB RAM internall HDD with LPAR = Oracle Report takes 1 hour 15 minutes ( please note I have assigned all the max processors and... (7 Replies)
Discussion started by: filosophizer
7 Replies

3. Solaris

Solaris x86 installation using jumpstart does not local boot ( boot from hdd)

I am trying to install Solaris x86 using the Jumpstart server. I run the add_install_client command with appropriate options, and reboot my x86 Target box. The installation starts fine and unattended. After the installation completes and the target goes for a re-boot, it does not boot from the HDD... (9 Replies)
Discussion started by: hemalsid
9 Replies

4. Boot Loaders

Reboot and Select Proper Boot device or insert Boot media in select Boot device and press a key

Hello, I have kubuntu on my laptop and now I decided to switch to Windows 7. I made the bios settings properly (first choice is boot from cd\vd) but I see the error " reboot and select proper Boot device or insert Boot media in select Boot device and press a key " I have tried CD and... (0 Replies)
Discussion started by: rpf
0 Replies

5. UNIX for Dummies Questions & Answers

Old HDD copy to new HDD ? im lost...

Over the last few months the HDD spins louder and louder, so I fiqured its time to replace the HDD. Its been running 24/7/365 since 98 :eek:. yes i said since 98 :D I have an IBM system 43P Model 240. 233 MHz. running AIX Version 4. The current HDD is an IBM DGHS COMP IEC -950 FRU PN#... (5 Replies)
Discussion started by: Chevy89rocks
5 Replies

6. Solaris

cannot find boot device and won't boot off cdrom

I'm running solaris 2.5.1. My main development server is DEAD, i can't even boot off the cdrom, it powers up, acts like it is starting the boot process but then says cannot find boot device. I've done the search here on this site and saw the other posts, but at the ok prompt it won't even let me... (3 Replies)
Discussion started by: kymberm
3 Replies

7. Solaris

solaris boot problem boot error loading interpreter(misc/krtld)

When I installed the SOLARIS 10 OS first time, the desktop would not start up, this was because of network setup. Reinstalled worked. After a week due to some problem I had to reinstall OS, installation went fine and but when i reboot I get this error. cannot find mis/krtld boot error loading... (0 Replies)
Discussion started by: johncy_j
0 Replies

8. UNIX for Advanced & Expert Users

Cannot boot - Boot : Panic : File size out of range (EWS-UX/V unix)

Hey ! I am running EWS-UX/V (Rel 4.2) on NEC EWS/4800/330 station and I am having problems rebooting my station : I am getting the following message on display : BOOT : PANIC : File size out of range. According to user guide, this error is occuring when a file exceeding the limit and/or... (2 Replies)
Discussion started by: fredo
2 Replies

9. UNIX for Dummies Questions & Answers

dual boot solaris off of 2nd HDD

I did a search on the board, but I could not find anything specific to dual booting windows and solaris, with solaris being placed on a second hard drive. I have solaris 8 intel, and I am trying to dual boot, but the Solaris installation process is quite intimidating. I am afraid I am going to do... (3 Replies)
Discussion started by: dangral
3 Replies
Login or Register to Ask a Question