Bootloader problem Grub.

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Bootloader problem Grub.
# 8  
Old 09-26-2009
Ok, I have to say that the message from the first post..

Booting 'windows'
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
map (0x80) (0x83)
map (0x83) (0x80)
chainloader +1

Error 13: Invalid or unsupported executable format
..was only coming when I put the bootloader on another disk (I thought I give it a trySmilie). When the Linux didn't want to start up either anymore, I put the installation cd in it and set the bootloader back at the biggest drive. Now you don't get that message above when clicking on windows, but the computer just reboots and getting the bootloader again.
Apart from this I have done nothing with drives, there's only one external hd attached via USB lately by me from my broken laptop.

I am going to bed now it's late here (00.40)
Very much thanks until now, I appreciate it that you take the time to help me.

---------- Post updated at 11:19 AM ---------- Previous update was at 12:41 AM ----------

Originally Posted by Corona688
Good, that's it.

Have you added any disks lately, or done anything that'd change the order of drives as the BIOS reports them? Those map lines may be incorrect now.. Try commenting them out and doing
map (hd2) (hd0)
map (hd0) (hd2)

I tried this and it doesn't work. Still the same.
# 9  
Old 09-28-2009
Can someone help me underway
# 10  
Old 09-28-2009
Have you tried the super grub disk like dr house suggested? I'm beginning to think there's some non-grub related problem stopping the partition from booting.
# 11  
Old 09-29-2009
Originally Posted by Corona688
Have you tried the super grub disk like dr house suggested? I'm beginning to think there's some non-grub related problem stopping the partition from booting.
Yes I did, It didn't work, it gave one line with kernel blablabla.
But finally it works. I had a free cd of Ubuntu lying here, so I installed Ubuntu next to Mandriva, and the bootloader of Ubuntu took over. And windows works with it well. I can't tell you what exactly was the problem.
Maybe I throw Mandriva from my pc, because almost every time I tried to edit or install something I had troubles (2009.0 version). Even upgrading to .1 gave problems.
The only thing about Ubuntu is that it is too user friendly sometimes, when you have to install something you just click a few buttons, when using Mandriva I know exactly what I install. But with more users there is more help and information for me as a beginner.
# 12  
Old 09-29-2009
Heh! That used to be my complaint about Mandrake! Smilie (which became mandriva.)
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

Grub Bootloader & CentOS

I'm clueless about Grub and having issues with CentOS6.6 that is installed on the box. It also has Windows 8.1 installed. I want to reinstall CentOS to version 7, but want to insure I don't wipe anything, and the bootloader remains as is, but includes the new CentOS installation. How do I go about... (2 Replies)
Discussion started by: Nvizn
2 Replies

2. Red Hat

Can we specify which grub.conf to use in grub-install.

Hi, Can we specify which grub.conf to use while installing grub on RHEL. We are working on application which requires different grub configurations needed, depending on certain criteria we need to update grub with correct grub.conf. Can we use grub-install for this purpose? (4 Replies)
Discussion started by: successlin
4 Replies

3. Ubuntu

grub problem - unable to boot

I am not able to boot into my ubuntu. Grub gives me this message How do I boot linux? (6 Replies)
Discussion started by: locoroco
6 Replies

4. Ubuntu

Grub rescue problem after installing ubuntu 10.04 amd64 after i386

Hi all, I have Windows XP dual boot with Ubuntu 8.10 on my system. I brought in a portable HDD on which I installed Ubuntu 10.04 32-bit. The grub boot loader was installed along with this and to boot windows, I've had to plug in the HDD (with lucid install) everytime. It had been working fine.... (0 Replies)
Discussion started by: morningSunshine
0 Replies

5. Solaris

Problem at GRUB prompt

Hi, I have a SUNFIRE V40Z server with Solaris 10 i86pc platform. I am experiencing probkem at GRUB prompt. I have restarted my server thrice but it is getting stuck at GRUB. Moreover it is not accepting any key stroke from my keyboard. I am able to enter BIOS and navigate around. Please... (7 Replies)
Discussion started by: EmbedUX
7 Replies

6. Solaris

grub problem

hi , was using solaris in dual boot with xp , then I ' ve installed ubuntu too . The solaris grub has been in some way damaged , maybe because during the linux installation i've delete an old partition that I was not using by some months. It's normal that the solaris grub has been overriden by... (7 Replies)
Discussion started by: freeware
7 Replies

7. Linux

Bootloader problem Grub.

Hello, I have some questions about my Mandriva Linux. My father died last year and so I got automatically forced to use Linux (master computer). I have become a little bit known with it, had to reset the root password via command lines etc. But I have some problems I can't solve on my own. In... (0 Replies)
Discussion started by: blabla9002
0 Replies

8. Solaris

Grub problem

Hi friends, i am using inter pc i am using windows as well as unix in 2 different HDD when i restart from windows to unix my grup got some problem, Grub loading, please wait Error 22 (and hang here is there any way to recover my grup please.) (2 Replies)
Discussion started by: kurva
2 Replies

9. Solaris

grub problem

hi to all ,pls help me i am using p4 intel machine while trying new things my image of solaris boot have been deleted from grub now i want to boot solaris 10 from the grub command line but i don't know the command for this .please help me as i want to know solution for... (8 Replies)
Discussion started by: tiwsaj
8 Replies

10. UNIX for Dummies Questions & Answers

grub problem- keeps rebooting as soon as it tries to do grub

Hi, I installed solaris 10 a few weeks ago. It was working fine during the past two weeks. However, now when I start to load to the drive, I get this problem: The BIOS screen comes up like normal, then screen goes blank and a message "Grub loading stage 2" flashes real quick then the computer... (1 Reply)
Discussion started by: moesays
1 Replies
Login or Register to Ask a Question