failure of at command


 
Thread Tools Search this Thread
# 1  
failure of at command

This is my first posting. I am not a very sophisticated UNIX user.

I am trying to have an existing control string trigger another process at 4:00 p.m. My command looks like this on System V.4 UNIX.

at -f /scriptname 16:00

I have added the users to /etc/cron.d/at.allow and at.deny is empty. The message that appears is "cannot create a job for you". If I log on as super user this works, but it gives another message about "WARNING: This job may not be executed at the proper time".

I'm assuming my users are not authorized to create such jobs, but I don't know where to go to enable them to do this.

Thank you for any help you can provide.

DKuester
# 2  
Do a ls -l on /usr/bin/at

It should be suid to root. I'll bet that it's not. Put a user in at.deny...do you still get the same error for that user?
# 3  
Also (as a test) remove the at.allow file - according to the man page for at

If only at.deny exists and is empty, global usage is permitted.
# 4  
I did the ls -l it is rwxrwxrwx and the owner is root (group is sys). I also removed the at.allow and it still came back with the same message "cannot create a job for you". I will keep looking. Thanks for the input.
# 5  
Someone did a
chmod 777 /usr/bin/at
and broke your at command. Repair it with:
chmod 4755 /usr/bin/at
# 6  
Thank you! I think the chmod 4755 may have been the key.Smilie
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #31
Difficulty: Easy
Alan Turing was the founder of IBM.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

boot up failure unix sco after power failure

hi power went out. next day unix sco wont boot up error code 303. any help appreciated as we are clueless. (11 Replies)
Discussion started by: fredthayer
11 Replies

2. Shell Programming and Scripting

SFTP Failure

Hi , I need to write a IF condition to know if a SFTP file transfer is successful or not and send email if its failed. `sftp username@servername <<comm1 cd /directory put filename comm1 bye` I use above commands for my connections. So please help me to write a IF statement. ... (0 Replies)
Discussion started by: krishna87
0 Replies

3. Solaris

DMA failure ?

Our Solaris was hung yesterday, and dmesg show that, nxge3 : <== nxge_m_start: initialization failed nxge2 : nxge_dma_mem_alloc:ddi_dma_mem_alloc kmem alloc failed nxge2 : nxge_alloc_rx_buf_dma: Alloc Failed: dma 9 size_index 10 size requested 4194304 Does it mean the DMA failure ? How... (5 Replies)
Discussion started by: dehetoxic
5 Replies

4. UNIX for Advanced & Expert Users

su failure

Usually when su rejects an attempt to switch user it responds with "Sorry" but with a certain username on some unix servers the response is "Killed". I'm guessing the su accepted the username/password but refused to spawn child shell with the specified username. What's causing this and what has to... (8 Replies)
Discussion started by: twk
8 Replies

5. Solaris

make command failure

Hi After downloading and compiling new ntp source for Solaris 10 I used the make command on the ntp directory. I received the following output: bash-3.00# make (bk version) >/dev/null 2>&1 && \ cd . && \ x=`bk -R prs -hr+ -nd:I: ChangeSet` && \ y=`cat version... (2 Replies)
Discussion started by: shaife720
2 Replies

6. UNIX and Linux Applications

How to automatically detect command failure

I have a shell script. In this script I executes various command and my requirement is such that if any command fails I've to terminate the shell script. To achieve this objective I'm checking the value of $? after each command and if its value is greater thaen I 'exit' the script. Is there... (2 Replies)
Discussion started by: ashok2008
2 Replies

7. Shell Programming and Scripting

copy command failure

A cp command failure occured on our production system. A shell script copies a source file to a temporary directory - cp <source file on mount point 1> <dest path on mount point 2> The same script ran successfully for another file, about 3mins after the failure. The script did not have a... (1 Reply)
Discussion started by: mynix
1 Replies

8. UNIX for Dummies Questions & Answers

CRONTAB failure

am getting the following error while trying to create a new crontab file: (jravisha) jravisha- crontab -e no crontab for jravisha - using an empty one crontab: installing new crontab "/tmp/crontab.XXXXH3SJgR":1: premature EOF errors in crontab file, can't install. Do you want to retry the... (5 Replies)
Discussion started by: jithinravi
5 Replies

9. AIX

telnet failure

My hardware is a JS21 IBM server with AIX 5.3L. I can console into the blade but at times I am able to telnet to a LDAP server on port 389, but then there are times I can not telnet to the port. I can't ping the server when I experience this issues. My application I support goes down in flames and... (3 Replies)
Discussion started by: billet75
3 Replies

10. Programming

ld failure

Hi, I am using gmake to compile a c program with a makefile. The make file runs ld. I get the following error jsh1035c:/users/egate453/admegate/kapil/samples $ gmake -e -f GNUmakefile queue_c gmake -f ./GNUmakefile queue_c in_objdir=1 build_root=/users/egate453/admegate/kapil/samples... (2 Replies)
Discussion started by: handak9
2 Replies

Featured Tech Videos