Setting up a personal FTP

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Setting up a personal FTP
# 15  
i try mkdir etc but i get
550 permission denied.. and i am logged on as the only user!
# 16  
so if your connecting to your ftp server thanit sounds like you have it running.

that is a permissions error you are getting. do you can only write to directories that you own, or have write permissions in. logging in as root via ftp is not a good idea. a better idea would be to login as root directly and create a write directory that your user can write in, and ftp to that. instead of changing things around, i would reccomend logging in via ftp as usual, and just use your home directory.

your still not clear though on whats going on, please be more specific in your posts.

do not use your external ip address to connect to your server frominside of your lan. the ip address that your ISP gave you you can use to connect when you are outside of your LAN, like at a friends house. use your local ip address to connect when you are on your LAN.

i dont know if this has been fixed with later firmware upgrades, but with that model linksys router you can not use your external ip address from inside your LAN. the router will lock up and all network traffic and internet access is lost. you have to wait for the router to reset before you have access again. i dont know what the deal is with that, even cutting the power to the router dosnt work when this happens.

solution: make sure all FQDNs for machines inside your network are in your /etc/hosts file, pointing to INTERNAL IPs only.
# 17  
ok, ill try to go into more specifics if you can explain this to me a little easier.. i dont understand what you mean by FQDN's (ill try to figure out).

you second paragraph is a little fuzzy to me.. i login to linux via root or something like that...
When i login to my FTP i use the username it told me to use "FTP" and the password i had set... I am not quite sure how to logon to the FTP as root, or i dont know its password..

I have 2 computers connected to my router.
One computer is running red hat linux 9 (Shrike)
The other is a normal Windows xp computer

I believed i had the FTP running on my linux computer
So i decided to try out the FTP on my other computer (winodws xp)

Doesnt seem to work.. The ip i believe is for my linux computer ( is not working, i get an error saying "Windows cannot access this folder blah blah blah.. Details : FTP Session was terminated."

So, i test it on my linux machine and when i type "ftp localhost" (logged in on my linux "root" username) i recieve
Connected to localhost (
220 Welcome to Jason's FTP Service.
i login with my made username called "ftp" (please tell me if i should not do that).
asks me to specify password...
Then says login successfull.
Remote System type is unix
Using Binary mode to transfer files...

So, what i am saying is.. It seems to be connected.. Now, what should i do, if i cannot get to the ftp on a local machine.(The windows xp machine)

And i am not even sure if that port you said is even the correct port for the ftp? how would i know if thats for sure?

And if i am that dumb, how would i find out what the ip is for my linux machine.. i typed "ip addr" and i got "" assuming that is the local ip..

Smilie whew
# 18  
after extensive messing around.. i have finally figured out how to get the ftp working.. i can get to the ftp. My problem is, the FTP username i created (due to what the manual said) has no permission to do anything to the site (upload or anything). I tried to "adduser gear" on root@localhost.. i also created a password. This did create, but i am unable to log onto the ftp with the new username and password.. i am also unable to log in as root.... I checked all my settings from the readme and nothing seems to be wrong.. maybe i am just creating the user incorrectly
# 19  
you dont want to login via ftp as root. it is disabled for a reason. you can enable it but that is not a good idea. you may or may not have set up anonymous ftp correctly, the user ftp, and the alias anonymous when logging in via ftp are for anonymous ftp. what user do you use on the box besides root? did you create a user for your self? use that to login via ftp. it will put you in your home directory and you can upload and download as much as you want.

as for connecting from windows, it should work....however, i would not recommend using explorer or the windows ftp command. as with windows telnet, those clients are both broken.
search for ws_ftp on google for a good easy to use windows ftp client.

your linux machine is using a dynamic ip, so it may or may not be the same next time you reboot, and will change for sure when the lease on that address the router gave you expires.

what happens when connecting locally your machine might hang when trying to do a reverse lookup on connecting machines. you can add to your /etc/hosts file if you want an entry for every dynamic ip on your network. you only have 2 machines so, i would recomend you add these entries to /etc/hosts dynip1 dynip2

and so on. id also suggest you add your router address for convienience: router

this should speed things up, try connecting again.
# 20  
ok, i can log into the ftp without entering any username and password.... but, the only account that seems to work with the ftp is the "FTP" User that is located in /sbin/noname and has no permissions on the FTP... all other users are unable to reach the website... My Gearshifter account (that i think is located /bash/bin or something) is unable to log into the FTP... its kinda confusing.. i AIM'ed Synbios but he was unable to help me either..

To sum it up, the only account working for the ftp is account "FTP" which is located in "/sbin/noname" which if i were to change that directory, i am unable to use the accountSmilie

I could AIM you Norsk when i get home, so the problem could be fixed quicker...


PS i changed the ip address to be static to

Last edited by gearshifter; 10-08-2003 at 05:47 PM..

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #813
Difficulty: Medium
The CSS RGBA alpha parameter defines the opacity as a number between 1.0 (fully transparent) and 0.0 (fully opaque).
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

ftp files ntrans setting

Hi all, am transfer some set files to remote machine from unix like put file1 put file2 put file3 put fileend4 But on remote machine files are getting placed like this file1 fileend4 file2 file3 Are their is any sequence of file transfer like alphabetic order or... (3 Replies)
Discussion started by: vivek1489
3 Replies

2. AIX

default umask setting during ftp

Hi all, How do i change the default primary group of files uploaded in AIX (via ftp) in such a way that the files will be owned by tom:staff? I understand that the default file permission can be set in /etc/profile for aix by adding a new line umask=032 Do I add a line in umask as well?... (5 Replies)
Discussion started by: chipahoys
5 Replies

3. UNIX for Dummies Questions & Answers

Setting up FTP account

Hi, I am new to the workd of FTP administration. I was asked to make an account on our FTP server so that someone can only download and upload to his home directory. The account is made but what settings/cconfiguration can I verify to ensure that the user has access to his home directory only?... (1 Reply)
Discussion started by: mojoman
1 Replies

4. Linux

Setting up FTP service +on Fedora 9

Hi all, I set up FTP service at my linuxAbox. Everything is good. When i did FTP from my LinuxB box , it authenticated just fine. The problem is: 1. I can't list the directory 2. when i use ls command to list the directory, it showed: 227 Entering passive mode... (2 Replies)
Discussion started by: c00kie88
2 Replies

5. UNIX for Dummies Questions & Answers

Setting up FTP access to my Tomcat Dir

Hi Guys, Im trying to set up FTP to my Apache Tomcat dir on my server so my web designer can FTP in and look at things in a live environment. However at first I couldn't write to the dir, so i change some permissions, and now I cant access it at all! Here is my LS -all output: ... (4 Replies)
Discussion started by: boarderstu
4 Replies

6. Solaris

how to setting ftp

Dear expert, I have problem when try ftp to my unix box (solaris 10). I was setting /etc/default/login file for enable remote access. enabling service for ftp and in /etc/ftpd/ftpusers thereis exist root. but can not using root for ftp (message : 530 login incorrect) but with using... (4 Replies)
Discussion started by: heru_90
4 Replies

7. UNIX for Advanced & Expert Users

setting username and password for ftp

hi, i have set up an FTP server in one of our systems. could some one tell me the procedure to set up the username and password for it to enable other users to access the server. thanks (1 Reply)
Discussion started by: div
1 Replies

8. IP Networking

Setting up ftp to ip?

How can I set up a webpage from my computer, so that people knowing my ip-adress can connect? I'm using Ubuntu/linux and have some ftp programs but I have no idea how to set the up. Regards Richard (1 Reply)
Discussion started by: riwa
1 Replies

9. UNIX for Dummies Questions & Answers

setting up FTP on Linux/Unix

Hi, I do not currently have any versions of Unix or linux, but I am considering getting one. I have a home computer and I want to set it up with a linux with a GUI (I know nothing about that whol command line prompt),and I want to allow my friends to access certain files on my hard drive using... (5 Replies)
Discussion started by: KrazyGuyPaul
5 Replies

Featured Tech Videos