configure script can't find a library


 
Thread Tools Search this Thread
# 1  
configure script can't find a library

I installed libxml2 library from source and it installed itself in
/usr/local/lib

i added /usr/local/lib to ld.so.conf and ran a ldconfig ( as root )

then i tried to compile tablix-0.0.3 wich does require the installed version
of libxml2

i ran ./configure ( as normal user ) and i get the following error

checking for xml2-config... (cached) no
checking for libxml - version >= 2.4.3... no
*** The xml2-config script installed by LIBXML could not be found
*** If libxml was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the XML2_CONFIG environment variable to the
*** full path to xml2-config.

so nothing of the new library is found. What can i try next?
# 2  
Im sure you have done this, but try the obvious. Follow the instructions kicked out when the configure failed (make sure your path is set correctly). Use the find command to locate the library.
# 3  
export LD_LIBRARY_PATH=/usr/local/lib:/lib:/usr/lib
The result of this variable is the "configure" script will search the /usr/local/lib directory first.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #708
Difficulty: Medium
The MySQL SELECT statement allows you to read data from only a single table.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

configure library package for --host architecture

I am trying to decode "configure" script for "bluez" package as far as how are "configure" options for cross-compiling passed to libtoool or GCC to build C++ library. As far as I can tell the "configure" triplet analysis (case) has no options to analyze anything with "linux" in it ,therefore... (5 Replies)
Discussion started by: anne
5 Replies

2. UNIX for Advanced & Expert Users

Gimp's configure do not find Gegl libs

Hello, I have been trying to compile Gimp. To do so, I had to compile its dependencies Babl and Gegl. After doing so I use this command to try to compile it: ./configure --prefix=/media/34GB/Arquivos-de-Programas-Linux/Gimp-2.6.0/... (6 Replies)
Discussion started by: colt
6 Replies

3. Programming

Library/header path for ./configure

Hello, I am always confused about adding library path for ./configure when compiling software under Linux Debian based OS. For example the README of the software tells --with-boost=PATH specify directory for the boost header files --with-mpi=PATH specify prefix directory for... (4 Replies)
Discussion started by: yifangt
4 Replies

4. HP-UX

Unable to find library libncurses.so.

I'm trying to run a file name remote build which is to build a package on a target server. My target server is HP-UX-itanium 64 bit. When I run the remote build, somehow it cannot find `libncurses.so` or maybe it looks for the `libncurses.so` at some other location. This only happens on HP-UX... (3 Replies)
Discussion started by: fikriemuthafa
3 Replies

5. Linux

./configure problem for libsf library due to apparently missing libdb library.

Hello, ./configure script fails to configure libsf. Please check the following last few lines of configure script error. checking for db1/db.h... no checking for db.h... yes checking for dbopen in -ldb1... no configure: error: No libdb? No libsf. But find command shows the following; ... (4 Replies)
Discussion started by: vectrum
4 Replies

6. HP-UX

how could find HP UX application develop library

if I would like to develop application on HP UX ,where can I serarch the library and API ,like develop windows application with MSDN thanks (1 Reply)
Discussion started by: alert0919
1 Replies

7. Linux

Plz Help me to find GNU C++ Runtime Library

Hi, I am working with red hat Linux and i want to install one program but I am getting the error This product requires the GNU C++ Runtime Library (libstdc++-libc6.2-2.so.3) or later. Your system must be upgraded before installation can proceed. So please tell me how can i remove this... (2 Replies)
Discussion started by: smartgupta
2 Replies

8. Solaris

PZ help :configure: error: cannot find output from flex; giving up

While installing amanda server,i got the following error ## checking lex output file root... configure: error: cannot find output from flex; giving up. when i execute # which lex i got /usr/ccs/bin/lex setting the pathg does not work too After this i tried intalling flex in my /opt... (0 Replies)
Discussion started by: bullet350
0 Replies

9. HP-UX

ld: Can't find library or mismatched ABI for

I started building a program which connects to MySQL and got: ld: Can't find library or mismatched ABI for -lmysqlclient_r I tried building my own MySQL and use these, and it worked but then it gave me: ld: Can't find library or mismatched ABI for -lrt But librt is a system library (and... (1 Reply)
Discussion started by: selalerer
1 Replies

10. Programming

Can't find curses library

I am writing a c program with the use of the curses but when i tried compiling i get the error that the curses library is not found the header file i included is curses.h and th command i typed is gcc -o chat chat.c -lcurses 1) Is this correct in linux? 2) found a file libncurses.so.5.2 ... (1 Reply)
Discussion started by: xenon830
1 Replies

Featured Tech Videos