Visit Our UNIX and Linux User Community

Problem with putty and password

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem with putty and password
# 1  
Old 06-10-2009
Problem with putty and password

I am using putty to ssh into my linux machine, I followed the steps to create password less authentication.

1. generated both private and public key
2. copied the public key over to the ~/.ssh/authorized_keys file
3. loaded Private key with pagent (when it didnt work i used Auth in Putty to loaded it).
4. when i log in, it is still asking for password.

Please help
# 2  
Old 06-17-2009
In step 2, you created an empty authorized_keys file and copied and pasted the public key in puttygen's "public key for pasting into authorized_keys" window? Or did you copy puttygen's public key file over. The first one is the correct method.
# 3  
Old 06-17-2009
it was actually a permission problem, the user had a write permission for others, that was a no-no for passwordless ssh, so i changed the permission back to the default permission for users.


Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Problem in Unix script to exit from Putty

We have a requirement where in the user needs to select a option 4 from the menu and the putty window should be closed.I tried giving exit 0 ;; and this is only exiting from the script menu and showing back the prompt.Is there a way for this. (2 Replies)
Discussion started by: gopalt
2 Replies

2. IP Networking

password-less ssh problem

Hi, Whatever I do I can not get password-less ssh working, which I need! I have tried (which worked using FC8): On a client node: ssh-keygen -t dsa -f .ssh/id_dsa Exit back to the server: mv authorized_keys2 chmod 640 authorized_keys2 Also: ssh-keygen -t rsa ssh-copy-id... (6 Replies)
Discussion started by: Bic121
6 Replies

3. Shell Programming and Scripting

sftp password problem

Hello, trying to download data by the ksh via sftp (password protected). I am looking for the exact syntax. (I know there are 1000 of threads but I have not found anything how to add the password). User:ABC Passwrd:123 I tried several stuff like: sftp -b... (2 Replies)
Discussion started by: jurgen
2 Replies

4. UNIX for Advanced & Expert Users

Unix user with root power problem in to login in putty

Hello, I created a user in my AIX 5.3 system and i modified /etc/passwd file in and assigned this user the uid=0 like root user. The problem is that when this user log into the system through putty it asks for root password instead of the user password. As a result of this, if i reset the... (4 Replies)
Discussion started by: omonoiatis9
4 Replies

5. UNIX for Dummies Questions & Answers

Command to delay password entry - putty connection manager

Hi all, putty connection manager is great but when attempting to sudo or ssh to another box via the post login commands it is subject to issues due to network latency (what happens is that pcm enters the password before the unix box is ready to receive it). Is there any clever way I can make... (1 Reply)
Discussion started by: skinnygav
1 Replies

6. Solaris

Password policy problem ??

Hi Solaris's expert I need to change user password on Solaris10 2 servers. With the same password I can change it just only one. Try to check everything but not found difference?? password pattern: abcdeFgh9Jk server1 check all characters but server2 check only first 8 characters.Why??... (10 Replies)
Discussion started by: arm_naja
10 Replies

7. UNIX for Dummies Questions & Answers

reg putty problem

Hi, i am using PUTTY 0.51 release for connecting the Red hate linux box in SSH mode. its working fine but i can't able to scoll the scoll bar using scroll wheel inthe mouse. please suggest me how to solve it. thanks in advance. thanks and regards, ilayans (2 Replies)
Discussion started by: ilayans
2 Replies

8. Solaris

problem with root password

I have 3 servers all running solaris 9 using ssh I changed the root passwd on all 3 a few months ago. I cannot log in as root currently as it wont accept password. I try to su from another user to root - when I type the password that I know to be correct it rejects the password immediately... (1 Reply)
Discussion started by: frustrated1
1 Replies

9. UNIX for Dummies Questions & Answers

RSH password problem

Hello, I am currently trying to execute a command in a Windows machine from a UNIX server. In order to do this, I am using the RSH command in UNIX but whenever i do this I am getting this error "RSHD: <username>: could not retrieve password: Please login and run rsetup." I log in via the... (0 Replies)
Discussion started by: punyenye
0 Replies

10. UNIX for Dummies Questions & Answers

password problem

I get a $ sign - do I put in a password? What do I do? I don't have a password only a user name and an activation ID - what's next? No one will answer me! (1 Reply)
Discussion started by: kaye
1 Replies

Featured Tech Videos