mailx -s not working right


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers mailx -s not working right
# 1  
Old 08-06-2003
mailx -s not working right

I have set up in Solaris to email me and I received emails on the OS level. However, I don't get the mail in my MS Outlook. Please advise.
Thanks in advance.
# 2  
Old 08-06-2003
Please post the command string you are using. You can check /var/adm/messages to see what is being sent out.

If you are using only one receipent, then it's being sent locally which is why you pick it up on the system. You would need to look at .forward files or better yet, an alias.

Your /var/adm/messages file should have something like the following showing what message was sent and to where (if your /etc/syslog.conf was set up to log it):

Aug 3 03:20:19 abns1 sendmail[20839]: DAA20839: from=root, size=291, class=
0, pri=30291, nrcpts=1, msgid=<200308030720.DAA20839@abns1.prv.mycom.co
m>, relay=root@localhost
Aug 3 03:20:21 abns1 sendmail[20850]: DAA20839: to=upsops@mycom.com,
ctladdr=root (0/1), delay=00:00:02, xdelay=00:00:01, mailer=relay, relay=mailhos
t.mycom.com. [12.7.4.2], stat=Sent (2.0.0 h737KKQO016070 Message a
ccepted for delivery)

Last edited by RTM; 08-06-2003 at 06:49 PM..
# 3  
Old 08-07-2003
Have you specified the mail relay on the Solaris box? It likely cannot find route to send you the message. Solaris will try to send it to a system called "mailhost" by default. If this system does not exist it will not be able to deliver the message. You may want to speak with your Exchange Admin to see what the name of the relay host is. You can then add an entry like this to your /etc/hosts file:

xxx.xxx.xxx.xxx host.domain.com mailhost

where xxx.xxx.xxx.xxx is the IP of th relay and host.domain.com is the actual name of the relay host.
# 4  
Old 08-12-2003
I added the following line in /etc/hosts

xxx.xx.x.xx abc@def.com mailhost

When I try to send mail, I received mail in the OS level, nothing comes in to my Outlook.

Any advise.
Thanks in advance.
 
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

Mailx stopped working

after a new patch set on the 14th. I noticed that mailx stopped working, as far a I can tell that is the only thing that changed. solaris 10 OS it seems everything is the same, sendmail seems to be running root@server # ps -ef | grep -i sendmail smmsp 687 1 0 10:42:25 ? ... (0 Replies)
Discussion started by: goya
0 Replies

2. Shell Programming and Scripting

mailx not working on SunOS 5.9

I m trying to send o/p of one file using mailx command but is not working PFB command : cat healthchecklog | mailx -s "HEALTH CHECKS" abc@jkl.com also I have checked the ps -ef for mailx which is giveing below o/p ps -ef | grep mail root 364 1 0 Jun 08 ? ... (11 Replies)
Discussion started by: Jcpratap
11 Replies

3. Shell Programming and Scripting

mailx not working properly

I am using mailx command in my script to attach a file and send an email. I need to attach a csv file and send email to a mail id - I am using uuencode output.csv output.csv | mailx -s "test mail" xyz@abc.com This will send a mail with scrambled text in body. am i missing something ?... (4 Replies)
Discussion started by: Sriranga
4 Replies

4. Shell Programming and Scripting

mailx is not working

i have a file.i want to get that file to my mail.mail services are running.but still i didn't receive the mail. i have used this command. mailx -s file1 muraliinfy04@gmail.com < file2.txt.can anybody help me.it's urgent.I am new to unix. actually file1 i have directed to a file2.txt (8 Replies)
Discussion started by: muraliinfy04
8 Replies

5. Shell Programming and Scripting

mailx -s is not working

Hello, I have two unix boxes.. One of the unix box version is Linux iduxlys 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:15 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux I have shell script which has the below script. cat xyz.log|mailx -s "export is Successful" \ xyz.xyz@xyz The above... (3 Replies)
Discussion started by: govindts
3 Replies

6. Solaris

mailx not working

i am supporting a server running Solaris 5.6.I don't know if the mail is configured on this server. i ran the following commands and got the corresponding output. #which mailx /usr/bin/mailx #ps -ef | grep sendmail root 601 1 0 Jan 10 ? 0:01 /usr/lib/sendmail... (1 Reply)
Discussion started by: asalman.qazi
1 Replies

7. Shell Programming and Scripting

mailx not working

Hi All, I am strugging with mailx. I have a shell script which triggers mail when executed. I have mailx utility installed in system under /usr/bin/mailx but still when that script executes i am not getting mails..any idea why strange behaviour..? Tha:(nks in advance Usha (2 Replies)
Discussion started by: usha rao
2 Replies

8. UNIX for Dummies Questions & Answers

Mailx command not working

HI, I am sending a html attachment with the help of mailx and uuencode command ..but it is not working properly.. :confused: Following are the commands i tried out. parmdir=/opt/dwqa1/TEST/status_test uuencode $parmdir/some.html $parmdir/some.html | mailx -s TEST ajoshi@yahoo.com But in... (5 Replies)
Discussion started by: Amey Joshi
5 Replies

9. Solaris

mailx is not working.......

Hi All, I am working with solaris 5.9 servers.After some patch installation my mailx is not working in the server.I am using IBM Lotus Notes. Please help me to solve this issue (4 Replies)
Discussion started by: Renjesh
4 Replies

10. Shell Programming and Scripting

mailx is not working outside e-mails

HI i wrote schell script to send e-mail automatically. it works only e-mail for our company.say for example, company name is : abc, example: joe@abc.com every body is receiving with xxx@abc.com (abc.com) if any body from outside of our company like joe@xyz.com.(xyz.com) are not... (3 Replies)
Discussion started by: raosurya
3 Replies
Login or Register to Ask a Question

Featured Tech Videos