Visit The New, Modern Unix Linux Community


make and make install commands


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers make and make install commands
# 1  
Data make and make install commands

Hi there,

I am installing a package at the moment on to my Solaris version 8 and I have run into a problem with the 'make' command. I have installed the package using the 'pkgadd' command and I am now at the stage where I have to use the 'make' command followed by the 'make install' command. According to the instructions for the package you just type 'make' and 'make install' and it should compile. When I use the 'make' command I get the following error:

make: Fatal error: Command failed for target

Does anyone have any suggestions? Thanks
# 2  
Are there any more error messages before this?

The message only tells the make on the default target failed, but giving no indication of what actually failed
# 3  
Data

Hi Cbkihong,

This is the full error. GCC is definitely installed. I am running the 'make' command from the directory with the makefile in it. There is no other errors before this one.
I've tried the two different make commands on this:
/usr/ccs/bin/make and /usr/ccs/lib/svr4-make and they both give the same.


gcc -DBZERO -DSOLARIS -DGETTIMEOFDAY -DREGEXEC -O -c bb.c
sh: gcc: not found
*** Error code 1
make: Fatal error: Command failed for target `bb.o'

Thanks.
# 4  
It looks like you need to insure you have the directory that gcc is installed in as part of your PATH.

If you do the following and it doesn't know where gcc is, then that is your problem.

# which gcc
# 5  
Hammer & Screwdriver

Hi RTM,

I typed in the command # which gcc and I found it wasn't in my $path. I edited the makefile to include gcc in it's correct path and it compiled fine. Thanks for that.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #810
Difficulty: Medium
The CSS3 RGB Decimal Code for Turquoise is 64,224,218.
True or False?

10 More Discussions You Might Find Interesting

1. Fedora

Make check install and make all install

hi dear i want to know what is different between make check install and make all install? thanks in advane fereshte (3 Replies)
Discussion started by: komijani
3 Replies

2. UNIX for Dummies Questions & Answers

make 3.82 install help

Hello. This is what I get when I try to install Todd-Sheppards-Computer:~/make-3.82 toddsheppard$ sudo make install Password: Making install in glob make: Nothing to be done for `install-exec-am'. make: Nothing to be done for `install-data-am'. Making install in config make: Nothing to be... (3 Replies)
Discussion started by: 240shep19
3 Replies

3. UNIX for Dummies Questions & Answers

Difference between configure/make/make install.

Hi, While installation of apache on linux, we perform the below tasks. 1) Untar 2) configure 3) make 4) make install. I wanted to understand the difference and working of configure/make/make install. Can any one help me understanding this? Thanks in advance. (1 Reply)
Discussion started by: praveen_b744
1 Replies

4. Solaris

Gani Network Driver Won't Install - make: Fatal error: Don't know how to make targ...

I attached a README file that I will refer to. I successfully completed everything in the README file until step 4. # pwd /gani/gani-2.4.4 # ls COPYING Makefile.macros gem.c Makefile Makefile.sparc_gcc gem.h Makefile.amd64_gcc ... (1 Reply)
Discussion started by: Bradj47
1 Replies

5. UNIX for Dummies Questions & Answers

install C compiler without make

Hi all, I dont have much knowledge about linux, but want to learn. I have installed Plop linux(PLoP - Home) on USB Flashdrive. I want to install gcc compiler to it. The installation of C compiler ask for make command, which is not found in the distribution. When I tried to install gnu make,... (4 Replies)
Discussion started by: johnsmithgr8
4 Replies

6. UNIX for Dummies Questions & Answers

Cannot use Make commands

I just cant use any of the make commands. Any ideas? I already tried adding the path of the make command in my profile But nothing happened The error returned is Make: Could not read current directory. Stop. Please help me on this. (1 Reply)
Discussion started by: khestoi
1 Replies

7. UNIX for Dummies Questions & Answers

problems using 'make' install

I am tring to install DBD::Oracle on Solaris 9 box, I issued command type cc type gcc but both are not found. then i manually searched for gcc, i found it and create a symbolic link to it in my directory. $ perl Makefile.pl (works ok) $ make (retuns error below) LD_RUN_PATH="" cc -G... (1 Reply)
Discussion started by: jameskay
1 Replies

8. Shell Programming and Scripting

How to make a script out of commands

Hi, I have a very basic knowledge of Unix and I need your help for a small script that will do the following commands that I do manually by just giving the filename TPR20080414.txt cut -d'|' -f3,4 TPR20080414.txt> oe_012.lkp awk -F "|" '{temp=$1;$1=$2;$2=temp}1' OFS="|" oe_012.lkp >... (3 Replies)
Discussion started by: sickboy
3 Replies

9. Linux

Error in issuing a make and make install

Hi, Recently I install a package and try to do a make and make install. However, in the make it gives me below error:- make:Nothing to be done for 'install-exec-am' make:Nothing to be done for 'install-data-am' Can anyone please explain to me what does this mean? I have been trying... (1 Reply)
Discussion started by: ahjiefreak
1 Replies

10. UNIX for Dummies Questions & Answers

make install

Hi all, I am trying to install pam_passwdqc-1.0.2 on my Solaris 9 machines. After I did a make, I did a make install but it returns the follwing output, # /usr/ccs/bin/make install mkdir -p /lib/security install -c -m 755 pam_passwdqc.so /lib/security install: The -c, -f, -n options each... (2 Replies)
Discussion started by: stancwong
2 Replies

Featured Tech Videos